summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2019-12-18 19:06:18 +0100
committerConrad Kostecki <conikost@gentoo.org>2019-12-18 19:06:18 +0100
commit49c0bf602106b191f69a4732a6fd478046c226d7 (patch)
treea146fc401f2feb6881a1c8ca5d12bd8055df2a0b /net-im
parentdev-libs/libclthreads: fixed description (diff)
downloadgentoo-49c0bf602106b191f69a4732a6fd478046c226d7.tar.gz
gentoo-49c0bf602106b191f69a4732a6fd478046c226d7.tar.bz2
gentoo-49c0bf602106b191f69a4732a6fd478046c226d7.zip
net-im/yowsup: bump to version 3.2.3_p20190905
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/yowsup/Manifest1
-rw-r--r--net-im/yowsup/files/yowsup-3.2.3_p20190905-fix-install-path.patch21
-rw-r--r--net-im/yowsup/yowsup-3.2.3_p20190905.ebuild50
3 files changed, 72 insertions, 0 deletions
diff --git a/net-im/yowsup/Manifest b/net-im/yowsup/Manifest
index 2c2eb7f5be4c..f8f9d7791a77 100644
--- a/net-im/yowsup/Manifest
+++ b/net-im/yowsup/Manifest
@@ -1 +1,2 @@
DIST yowsup-3.2.3.tar.gz 140038 BLAKE2B 45df9151e897eea4f2997246d8c66409bc58160e01a84ee632f3e834058efcaed1d03047ddc6e8e7acbaa566d5fab2451fb21b30daf477bc83dfdd0bee7e6b59 SHA512 a1be36df5dc632071385cf0e252a208efb8982df98966d2c5a7b7558c626112e1ac2688be25fb6de1db9e9e04d36ab96784e589aeb90fcc6c6770edac791e568
+DIST yowsup-3.2.3_p20190905.tar.gz 150149 BLAKE2B 149c49df1a3b4df9163abcb1625b7e15e41d81f6a1a649c08d8cca88cce6cf10488778301fc96af3b2fe9e668e855023e56da6e6e8b3b9038994273f19404b78 SHA512 4b59a30bf73797750b92aecf45bf2e551fcbb249688efac631400bf532e21b739e9a6628ed01da4d520ed9296657ae8c5463c3560b165c5d696fd18f1e700be7
diff --git a/net-im/yowsup/files/yowsup-3.2.3_p20190905-fix-install-path.patch b/net-im/yowsup/files/yowsup-3.2.3_p20190905-fix-install-path.patch
new file mode 100644
index 000000000000..54258dd754bd
--- /dev/null
+++ b/net-im/yowsup/files/yowsup-3.2.3_p20190905-fix-install-path.patch
@@ -0,0 +1,21 @@
+--- a/setup.py 2019-05-07 18:52:38.000000000 +0200
++++ b/setup.py 2019-12-18 18:30:40.509051347 +0100
+@@ -33,7 +33,6 @@
+ #long_description=long_description,
+ packages= find_packages(),
+ include_package_data=True,
+- data_files = [('yowsup/common', ['yowsup/common/mime.types'])],
+ platforms='any',
+ #test_suite='',
+ classifiers = [
+--- a/yowsup/common/tools.py 2019-05-07 18:52:38.000000000 +0200
++++ b/yowsup/common/tools.py 2019-12-18 18:30:40.509051347 +0100
+@@ -165,7 +165,7 @@
+ return preview
+
+ class MimeTools:
+- MIME_FILE = os.path.join(os.path.dirname(__file__), 'mime.types')
++ MIME_FILE = os.path.join('/usr/share/yowsup/common', 'mime.types')
+ mimetypes.init() # Load default mime.types
+ try:
+ mimetypes.init([MIME_FILE]) # Append whatsapp mime.types
diff --git a/net-im/yowsup/yowsup-3.2.3_p20190905.ebuild b/net-im/yowsup/yowsup-3.2.3_p20190905.ebuild
new file mode 100644
index 000000000000..47b8ef707944
--- /dev/null
+++ b/net-im/yowsup/yowsup-3.2.3_p20190905.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS="bdepend"
+EGIT_COMMIT="2adc067f306d9e7d8b634f66e96c52d80a42e1ff"
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} )
+PYTHON_REQ_USE="readline"
+
+inherit distutils-r1
+
+DESCRIPTION="A library that enables you to build applications which use the WhatsApp service"
+HOMEPAGE="https://github.com/tgalal/yowsup"
+SRC_URI="https://github.com/tgalal/yowsup/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/configargparse[${PYTHON_USEDEP}]
+ dev-python/consonance[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/python-axolotl[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+
+PATCHES=( "${FILESDIR}/${PF}-fix-install-path.patch" )
+
+src_prepare() {
+ default
+
+ # After talking to upstream, version restriction can be lifted
+ # and also 'argparse' needs to be removed.
+ sed -e 's/==0.1.3-1//' -e 's/==0.2.2//' -e 's/==1.10//' -e 's/argparse/' -i setup.py || die
+}
+
+pkg_postinst() {
+ einfo "Warning: It seems that recently yowsup gets detected during registration"
+ einfo "resulting in an instant ban for your number right after registering"
+ einfo "with the code you receive by sms/voice."
+ einfo "See https://github.com/tgalal/yowsup/issues/2829 for more information."
+}