summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-01-26 18:48:17 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-01-26 18:48:35 +0100
commitea533bd044e37a3b3cdac4117f39a9e3d7c03e56 (patch)
tree1e5f5bdb1c202465ef5612b9791488480f986732 /net-im
parentnet-im/prosody: fix checkconfig on slotted lua (diff)
downloadgentoo-ea533bd044e37a3b3cdac4117f39a9e3d7c03e56.tar.gz
gentoo-ea533bd044e37a3b3cdac4117f39a9e3d7c03e56.tar.bz2
gentoo-ea533bd044e37a3b3cdac4117f39a9e3d7c03e56.zip
net-im/prosody: drop old version
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/prosody/files/prosody.initd-r443
-rw-r--r--net-im/prosody/prosody-0.11.7-r100.ebuild103
-rw-r--r--net-im/prosody/prosody-0.11.7-r2.ebuild94
3 files changed, 0 insertions, 240 deletions
diff --git a/net-im/prosody/files/prosody.initd-r4 b/net-im/prosody/files/prosody.initd-r4
deleted file mode 100644
index 1282e9dc4561..000000000000
--- a/net-im/prosody/files/prosody.initd-r4
+++ /dev/null
@@ -1,43 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-name="Prosody XMPP server"
-extra_started_commands="reload"
-jabber_pid="/run/jabber"
-jabber_logs="/var/log/jabber"
-pidfile="${jabber_pid}/prosody.pid"
-prosody_config="/etc/jabber/prosody.cfg.lua"
-
-command="/usr/bin/prosody"
-command_group="jabber"
-command_user="jabber"
-
-checkconfig() {
- if [ ! -f "${prosody_config}" ]; then
- eerror "Please create ${prosody_config} before starting Prosody!"
- return 1
- fi
-
- luac -p "${prosody_config}"
- return $?
-}
-
-depend() {
- need net
- provide jabber-server
- use dns postgresql
-}
-
-reload() {
- ebegin "Reloading configuration"
- start-stop-daemon --signal HUP --pidfile "${pidfile}"
- eend $?
-}
-
-start_pre() {
- checkconfig || return 1
-
- checkpath -d -m 0750 -o "${command_user}:${command_group}" -q "${jabber_logs}"
- checkpath -d -m 0750 -o "${command_user}:${command_group}" -q "${jabber_pid}"
-}
diff --git a/net-im/prosody/prosody-0.11.7-r100.ebuild b/net-im/prosody/prosody-0.11.7-r100.ebuild
deleted file mode 100644
index 9d4dfaa9cdb7..000000000000
--- a/net-im/prosody/prosody-0.11.7-r100.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( lua5-{1..3} luajit )
-LUA_REQ_USE="deprecated(+)"
-
-inherit lua-single systemd tmpfiles toolchain-funcs
-
-DESCRIPTION="Prosody is a modern XMPP communication server"
-HOMEPAGE="https://prosody.im/"
-SRC_URI="https://prosody.im/downloads/source/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 x86"
-IUSE="icu +idn +libevent libressl mysql postgres +sqlite +ssl test +zlib"
-REQUIRED_USE="
- ^^ ( icu idn )
- ${LUA_REQUIRED_USE}
-"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- $(lua_gen_cond_dep 'dev-lua/luaexpat[${LUA_USEDEP}]')
- $(lua_gen_cond_dep 'dev-lua/luafilesystem[${LUA_USEDEP}]')
- $(lua_gen_cond_dep 'dev-lua/luasocket[${LUA_USEDEP}]')
- net-im/jabber-base
- icu? ( dev-libs/icu:= )
- idn? ( net-dns/libidn:= )
- libevent? ( $(lua_gen_cond_dep 'dev-lua/luaevent[${LUA_USEDEP}]') )
- libressl? ( dev-libs/libressl:= )
- !libressl? ( dev-libs/openssl:0= )
- lua_single_target_lua5-1? ( $(lua_gen_cond_dep 'dev-lua/lua-bit32[lua_targets_lua5-1(-)]') )
- mysql? ( $(lua_gen_cond_dep 'dev-lua/luadbi[mysql,${LUA_USEDEP}]') )
- postgres? ( $(lua_gen_cond_dep 'dev-lua/luadbi[postgres,${LUA_USEDEP}]') )
- sqlite? ( $(lua_gen_cond_dep 'dev-lua/luadbi[sqlite,${LUA_USEDEP}]') )
- ssl? ( $(lua_gen_cond_dep 'dev-lua/luasec[${LUA_USEDEP}]') )
- zlib? ( $(lua_gen_cond_dep 'dev-lua/lua-zlib[${LUA_USEDEP}]') )
- ${LUA_DEPS}
-"
-
-DEPEND="${RDEPEND}"
-
-BDEPEND="
- virtual/pkgconfig
- test? ( $(lua_gen_cond_dep 'dev-lua/busted[${LUA_USEDEP}]') )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.11.7-bit32.patch"
- "${FILESDIR}/${PN}-0.11.7-gentoo.patch"
-)
-
-src_prepare() {
- default
-
- # Set correct plugin path for optional net-im/prosody-modules package
- sed -e "s/GENTOO_LIBDIR/$(get_libdir)/g" -i prosody.cfg.lua.dist || die
-}
-
-src_configure() {
- local myeconfargs=(
- --add-cflags="${CFLAGS}"
- --add-ldflags="${LDFLAGS}"
- --c-compiler="$(tc-getCC)"
- --datadir="${EPREFIX}/var/spool/jabber"
- --idn-library="$(usex idn 'idn' 'icu')"
- --libdir="${EPREFIX}/usr/$(get_libdir)"
- --linker="$(tc-getCC)"
- --lua-version="$(usex lua_single_target_luajit '5.1' $(ver_cut 1-2 $(lua_get_version)))"
- --no-example-certs
- --ostype="linux"
- --prefix="${EPREFIX}/usr"
- --runwith="${ELUA}"
- --sysconfdir="${EPREFIX}/etc/jabber"
- --with-lua-include="${EPREFIX}/$(lua_get_include_dir)"
- --with-lua-lib="${EPREFIX}/$(lua_get_cmod_dir)"
- )
-
- # Since the configure script is handcrafted,
- # and yells at unknown options, do not use 'econf'.
- ./configure "${myeconfargs[@]}" || die
-
- rm makefile || die
- mv GNUmakefile Makefile || die
-}
-
-src_install() {
- default
-
- keepdir /var/spool/jabber
-
- newinitd "${FILESDIR}"/prosody.initd-r4 prosody
- systemd_newunit "${FILESDIR}"/prosody.service-r2 prosody.service
-
- newtmpfiles "${FILESDIR}"/prosody.tmpfilesd-r1 prosody.conf
-}
-
-pkg_postinst() {
- tmpfiles_process prosody.conf
-}
diff --git a/net-im/prosody/prosody-0.11.7-r2.ebuild b/net-im/prosody/prosody-0.11.7-r2.ebuild
deleted file mode 100644
index e39395687019..000000000000
--- a/net-im/prosody/prosody-0.11.7-r2.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit systemd tmpfiles toolchain-funcs
-
-DESCRIPTION="Prosody is a modern XMPP communication server"
-HOMEPAGE="https://prosody.im/"
-SRC_URI="https://prosody.im/downloads/source/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 x86"
-IUSE="+libevent libressl luajit mysql postgres +sqlite +ssl test +zlib"
-RESTRICT="!test? ( test )"
-
-# dev-lang/lua:0 is 5.1 so lua-bit32 is required
-COMMON_DEPEND="
- dev-lua/lua-bit32
- net-dns/libidn
- net-im/jabber-base
- libressl? ( dev-libs/libressl:= )
- !libressl? ( dev-libs/openssl:0= )
- luajit? ( dev-lang/luajit:2 )
- !luajit? ( dev-lang/lua:0= )
-"
-
-DEPEND="
- ${COMMON_DEPEND}
- test? ( dev-lua/busted )
-"
-
-RDEPEND="
- ${COMMON_DEPEND}
- dev-lua/luaexpat
- dev-lua/luafilesystem
- dev-lua/luasocket
- libevent? ( dev-lua/luaevent )
- mysql? ( dev-lua/luadbi[mysql] )
- postgres? ( dev-lua/luadbi[postgres] )
- sqlite? ( dev-lua/luadbi[sqlite] )
- ssl? ( dev-lua/luasec )
- zlib? ( dev-lua/lua-zlib )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.11.7-bit32.patch"
- "${FILESDIR}/${PN}-0.11.7-gentoo.patch"
-)
-
-src_prepare() {
- default
-
- # Set correct plugin path for optional net-im/prosody-modules package
- sed -e "s/GENTOO_LIBDIR/$(get_libdir)/g" -i prosody.cfg.lua.dist || die
-}
-
-src_configure() {
- local myeconfargs=(
- --c-compiler="$(tc-getCC)"
- --datadir="${EPREFIX}/var/spool/jabber"
- --libdir="${EPREFIX}/usr/$(get_libdir)"
- --linker="$(tc-getCC)"
- --ostype="linux"
- --prefix="${EPREFIX}/usr"
- --runwith="$(usex luajit luajit lua)"
- --sysconfdir="${EPREFIX}/etc/jabber"
- --with-lua-include="${EPREFIX}/usr/include"
- --with-lua-lib="${EPREFIX}/usr/$(get_libdir)/lua"
- )
-
- # Since the configure script is handcrafted,
- # and yells at unknown options, do not use 'econf'.
- ./configure ${myeconfargs[@]} --cflags="${CFLAGS} -Wall -fPIC" --ldflags="${LDFLAGS} -shared" || die
-
- rm makefile || die
- mv GNUmakefile Makefile || die
-}
-
-src_install() {
- default
-
- newinitd "${FILESDIR}"/prosody.initd-r4 prosody
- systemd_newunit "${FILESDIR}"/prosody.service-r2 prosody.service
-
- newtmpfiles "${FILESDIR}"/prosody.tmpfilesd-r1 prosody.conf
-
- keepdir /var/spool/jabber
-}
-
-pkg_postinst() {
- tmpfiles_process prosody.conf
-}