summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2017-11-30 23:52:31 +0100
committerUlrich Müller <ulm@gentoo.org>2017-11-30 23:53:05 +0100
commitf44c18ebd3eaa57664260f788881fb815397ebd3 (patch)
treeb347edd70fd163dd815525a1a83479bb3637cc44 /net-im
parentdev-db/qt5-sqlcipher: Initial import. (diff)
downloadgentoo-f44c18ebd3eaa57664260f788881fb815397ebd3.tar.gz
gentoo-f44c18ebd3eaa57664260f788881fb815397ebd3.tar.bz2
gentoo-f44c18ebd3eaa57664260f788881fb815397ebd3.zip
net-im/openmittsu: Version bump.
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'net-im')
-rw-r--r--net-im/openmittsu/Manifest3
-rw-r--r--net-im/openmittsu/files/openmittsu-0.9.9.48-disable-googletest.patch79
-rw-r--r--net-im/openmittsu/openmittsu-0.9.9.48.ebuild53
3 files changed, 134 insertions, 1 deletions
diff --git a/net-im/openmittsu/Manifest b/net-im/openmittsu/Manifest
index 71482fa02813..524ec0f9cffd 100644
--- a/net-im/openmittsu/Manifest
+++ b/net-im/openmittsu/Manifest
@@ -1 +1,2 @@
-DIST openmittsu-0.9.2.109.tar.xz 1314888 SHA256 cf012e36ce157023082c8efa04ce6d4521ac16044334647c860a07b2ff94ea35 SHA512 ad70ff7c3ceedcf1d6711468152199742533b8f42abbae5ce52f3e29882ae6aea566e8a39258a3d3676a91774e144a70d91967b31e4634f23d527f14325d0a5b WHIRLPOOL f0843eaa35507374a69977c0e023c060f47448d72ea77c3f640b2b5e1ddd87dff756c31c3827c043107af798b5abb58287b07dba8c841be57167d1e8787b1a24
+DIST openmittsu-0.9.2.109.tar.xz 1314888 BLAKE2B 2c3b2e3e333d2e4ee2cf591fdaffc1b9e7b3b99d45093295ae9246e65b414124ad7a3e04ae558a1bd54c8704b3cf0858cbc53e6f30870b96a491fd1a9f8f7272 SHA512 ad70ff7c3ceedcf1d6711468152199742533b8f42abbae5ce52f3e29882ae6aea566e8a39258a3d3676a91774e144a70d91967b31e4634f23d527f14325d0a5b
+DIST openmittsu-0.9.9.48.tar.xz 2026628 BLAKE2B eafd2bc537a22b140e01e14da363d3943e24b86754a090fd1ed2ac80f1030e1a2fb30ee8a5395c6c9a143d5922354ac67e3376a94c34f670f8cbcfddc27da112 SHA512 e24ec8e0792df13e781080fe42934035f74b82be62a8ce4913175a13ee3acbead069d169871405f4312927165a7049291d009c7f968b088bdbb3e294f9ef2443
diff --git a/net-im/openmittsu/files/openmittsu-0.9.9.48-disable-googletest.patch b/net-im/openmittsu/files/openmittsu-0.9.9.48-disable-googletest.patch
new file mode 100644
index 000000000000..ceb162d5e6b1
--- /dev/null
+++ b/net-im/openmittsu/files/openmittsu-0.9.9.48-disable-googletest.patch
@@ -0,0 +1,79 @@
+Disable googletest for now, in order to avoid accessing the network
+at configure time.
+
+--- openmittsu-0.9.9.48-orig/CMakeLists.txt
++++ openmittsu-0.9.9.48/CMakeLists.txt
+@@ -212,28 +212,6 @@
+ # Add the binary dir include directory
+ include_directories("${PROJECT_BINARY_DIR}/include")
+
+-##########################################################
+-#
+-# Google Testing Framework
+-#
+-##########################################################
+-# Download and unpack googletest at configure time
+-configure_file("${PROJECT_SOURCE_DIR}/cmake/GoogleTest.cmake.in" googletest-download/CMakeLists.txt)
+-execute_process(COMMAND "${CMAKE_COMMAND}" -G "${CMAKE_GENERATOR}" .
+- WORKING_DIRECTORY "${CMAKE_BINARY_DIR}/googletest-download" )
+-execute_process(COMMAND "${CMAKE_COMMAND}" --build .
+- WORKING_DIRECTORY "${CMAKE_BINARY_DIR}/googletest-download" )
+-
+-# Prevent GoogleTest from overriding our compiler/linker options
+-# when building with Visual Studio
+-set(gtest_force_shared_crt ON CACHE BOOL "" FORCE)
+-
+-# Add googletest directly to our build. This adds
+-# the following targets: gtest, gtest_main, gmock
+-# and gmock_main
+-add_subdirectory("${CMAKE_BINARY_DIR}/googletest-src"
+- "${CMAKE_BINARY_DIR}/googletest-build" EXCLUDE_FROM_ALL)
+-
+
+ # Main Sources
+ file(GLOB OPENMITTSU_HEADERS ${PROJECT_SOURCE_DIR}/src/*.h)
+@@ -399,24 +377,17 @@
+
+ add_executable(openMittsuVersionInfo ${OPENMITTSU_BUILDTOOLS_VERSIONINFO_HEADERS} ${OPENMITTSU_BUILDTOOLS_VERSIONINFO_SOURCES_CPP} ${OPENMITTSU_HEADERS_GENERATED} ${OPENMITTSU_SOURCES_GENERATED})
+
+-add_executable(openMittsuTests ${OPENMITTSU_TEST_MAIN_FILE} ${OPENMITTSU_TEST_FILES}
+- ${OPENMITTSU_RESOURCESOURCES}
+-)
+-
+ if (MSVC)
+ set_target_properties(openMittsu PROPERTIES LINK_FLAGS_RELEASE "/SUBSYSTEM:WINDOWS")
+ endif(MSVC)
+
+ # Add target link dependencies
+-target_link_libraries(openMittsuCore ${Libsodium_LIBRARIES} gtest)
++target_link_libraries(openMittsuCore ${Libsodium_LIBRARIES})
+ target_link_libraries(openMittsu ${LIBQRENCODE_LIBRARY})
+
+-add_dependencies(openMittsuTests gtest)
+-
+ # Use the required modules from Qt 5.
+ target_link_libraries(openMittsuCore Qt5::Core Qt5::Gui Qt5::Widgets Qt5::Network Qt5::Multimedia Qt5::Sql)
+ target_link_libraries(openMittsu openMittsuCore Qt5::Core Qt5::Gui Qt5::Widgets Qt5::Network Qt5::Multimedia Qt5::Sql)
+-target_link_libraries(openMittsuTests openMittsuCore Qt5::Core Qt5::Gui Qt5::Widgets Qt5::Network Qt5::Multimedia Qt5::Sql)
+ target_link_libraries(openMittsuVersionInfo Qt5::Core)
+
+ # Link against libc++abi if requested.
+@@ -424,7 +395,6 @@
+ target_link_libraries(openMittsu "c++abi")
+ target_link_libraries(openMittsuCore "c++abi")
+ target_link_libraries(openMittsuVersionInfo "c++abi")
+- target_link_libraries(openMittsuTests "c++abi")
+ endif(OPENMITTSU_LINK_LIBCXXABI)
+
+ # Targets, CPACK...
+@@ -438,10 +408,6 @@
+ RUNTIME
+ DESTINATION bin
+ COMPONENT installComponent)
+-install(TARGETS openMittsuTests
+- RUNTIME
+- DESTINATION bin
+- COMPONENT installComponent)
+
+ if (MSVC)
+ set(OPENMITTSU_WINDEPLOYQT_EXE "${Qt5Core_DIR}/../../../bin/windeployqt.exe")
diff --git a/net-im/openmittsu/openmittsu-0.9.9.48.ebuild b/net-im/openmittsu/openmittsu-0.9.9.48.ebuild
new file mode 100644
index 000000000000..241dd833295c
--- /dev/null
+++ b/net-im/openmittsu/openmittsu-0.9.9.48.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils desktop
+
+DESCRIPTION="An open source chat client for Threema-style end-to-end encrypted chat networks"
+HOMEPAGE="https://www.openmittsu.de/"
+# git-archive-all.sh snapshot of https://github.com/blizzard4591/openMittsu.git
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2+ BitstreamVera OFL-1.1 Apache-2.0 CC0-1.0 MIT BSD-2 Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-db/qt5-sqlcipher
+ >=dev-libs/libsodium-1.0.11:=
+ >=dev-qt/qtcore-5.7.1:5=
+ >=dev-qt/qtgui-5.7.1:5=
+ >=dev-qt/qtmultimedia-5.7.1:5=
+ >=dev-qt/qtnetwork-5.7.1:5=[ssl]
+ >=dev-qt/qtsql-5.7.1:5=[sqlite]
+ >=dev-qt/qtwidgets-5.7.1:5=
+ >=media-gfx/qrencode-3.4.4-r1:="
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-disable-googletest.patch
+)
+
+DOCS=(
+ README.md
+ Example-client-configuration-file.ini
+ Example-contacts-file.txt
+)
+
+src_configure() {
+ local mycmakeargs=(
+ # set version manually, since autodetection works only with git
+ "-DOPENMITTSU_CUSTOM_VERSION_STRING=${PV%.*}-${PV##*.}-00000000"
+ "-DOPENMITTSU_DISABLE_VERSION_UPDATE_CHECK=ON"
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ local my_pn="openMittsu"
+ cmake-utils_src_install
+ newicon resources/icon.png ${my_pn}.png
+ make_desktop_entry ${my_pn} ${my_pn} ${my_pn}
+ rm "${ED}"/usr/bin/${my_pn}VersionInfo || die
+}