summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-12-09 04:14:39 +1100
committerMichael Palimaka <kensington@gentoo.org>2015-12-09 04:15:03 +1100
commitf388a3351b0bfdb1233211eefbc1e0d98b892190 (patch)
treeefff70350e61610c5c4f2dfbd73fec7e8e3b6317 /net-irc/bip
parentdev-lang/swi-prolog: bump 7.3 development version (diff)
downloadgentoo-f388a3351b0bfdb1233211eefbc1e0d98b892190.tar.gz
gentoo-f388a3351b0bfdb1233211eefbc1e0d98b892190.tar.bz2
gentoo-f388a3351b0bfdb1233211eefbc1e0d98b892190.zip
net-irc/bip: version bump to solve CVE-2011-5268 and CVE-2013-4550
Gentoo-bug: 490772 Package-Manager: portage-2.2.26
Diffstat (limited to 'net-irc/bip')
-rw-r--r--net-irc/bip/Manifest1
-rw-r--r--net-irc/bip/bip-0.8.9.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/net-irc/bip/Manifest b/net-irc/bip/Manifest
index bf166b4541ce..7f1005f53c32 100644
--- a/net-irc/bip/Manifest
+++ b/net-irc/bip/Manifest
@@ -1 +1,2 @@
DIST bip-0.8.8.tar.gz 220232 SHA256 7ca3fb96f5ee6b76eb398d7ea45344ea24855344ced11632241a33353bba05d7 SHA512 acd62a61379290088320567b299b9d2e236c24aea7c83c4bfb7dedba9727868fb931d7e2eb663c9041794c26583bcc923072049cb42eef0d13702f284bae2b34 WHIRLPOOL b2e5f7a1328832fce7b3c7eb706ec87e7eb023043e714dbc554126730d2e9dc37af2d127e15ef024fff1e95b9dd22351cd48b3b115b58b9fd9ecbdd92f20cda1
+DIST bip-0.8.9.tar.gz 256711 SHA256 3c950f71ef91c8b686e6835f9b722aa7ccb88d3da4ec1af19617354fd3132461 SHA512 572adb6e0982d74a39b0380ef6af51ba7f55b880f78e110b93e09616e6345bb4a9a60475df644ec891cae368287d502ba00bbf734370ba50c57b29de6934c138 WHIRLPOOL ffad5a0a525a09e6d31537dd4238353ac820a874f18a9590f039419e9d2b7aff4f92a1882f02db450e9e88957adbc4bc4eb993fbff01f7327bcdd02d0b1b6e6d
diff --git a/net-irc/bip/bip-0.8.9.ebuild b/net-irc/bip/bip-0.8.9.ebuild
new file mode 100644
index 000000000000..bfa178e41d50
--- /dev/null
+++ b/net-irc/bip/bip-0.8.9.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+inherit eutils
+
+DESCRIPTION="Multiuser IRC proxy with SSL support"
+HOMEPAGE="http://bip.milkypond.org/"
+SRC_URI="ftp://ftp.duckcorp.org/bip/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug freenode noctcp oidentd vim-syntax"
+
+COMMON_DEPEND="
+ dev-libs/openssl:0
+"
+DEPEND="${COMMON_DEPEND}
+ sys-devel/flex
+ virtual/yacc
+"
+RDEPEND="${COMMON_DEPEND}
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
+ oidentd? ( >=net-misc/oidentd-2.0 )
+"
+
+src_prepare() {
+ if use noctcp; then
+ sed -i -e '/irc_privmsg_check_ctcp(server, line);/s:^://:' src/irc.c || die
+ fi
+
+ if use freenode; then
+ epatch "${FILESDIR}/${PN}-freenode.patch" || die
+ fi
+
+ sed -i -e "s/-Werror//" Makefile.in || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable oidentd)
+}
+
+src_install() {
+ dobin src/bip src/bipmkpw
+
+ dodoc AUTHORS ChangeLog README NEWS TODO
+ newdoc samples/bip.conf bip.conf.sample
+ doman bip.1 bip.conf.5 bipmkpw.1
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins samples/bip.vim
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${FILESDIR}"/bip.vim
+ fi
+}
+
+pkg_postinst() {
+ elog 'The default configuration file is "~/.bip/bip.conf"'
+ elog "You can find a sample configuration file in"
+ elog "/usr/share/doc/${PF}/bip.conf.sample"
+}