summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-irc/miau
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-irc/miau')
-rw-r--r--net-irc/miau/Manifest1
-rw-r--r--net-irc/miau/metadata.xml8
-rw-r--r--net-irc/miau/miau-0.6.6.ebuild70
3 files changed, 79 insertions, 0 deletions
diff --git a/net-irc/miau/Manifest b/net-irc/miau/Manifest
new file mode 100644
index 000000000000..31be24f37f91
--- /dev/null
+++ b/net-irc/miau/Manifest
@@ -0,0 +1 @@
+DIST miau-0.6.6.tar.bz2 188284 SHA256 5409fd19748fe0eb98b9975270233878d02718538e9c3b438fe0b74d61465804 SHA512 0f61eae1a8c1ab60aee63b9cab482097381aa23218811e228f6bede0a73e194b4c34ac9add7d85c7160d74da25c840c1d356fb6afae31c10d90d7fc01de5e170 WHIRLPOOL 52d09103743db9f33c3f49d2daf8bb6aa3f45a69343c5bb193fdb3651e3c0ee191a9284d7b83b74d719625790fac2e051a669c1aedd4fcfcd66d1d2c570ebfe7
diff --git a/net-irc/miau/metadata.xml b/net-irc/miau/metadata.xml
new file mode 100644
index 000000000000..15b5f1e060e5
--- /dev/null
+++ b/net-irc/miau/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-irc</herd>
+ <upstream>
+ <remote-id type="sourceforge">miau</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-irc/miau/miau-0.6.6.ebuild b/net-irc/miau/miau-0.6.6.ebuild
new file mode 100644
index 000000000000..51b13c2e092c
--- /dev/null
+++ b/net-irc/miau/miau-0.6.6.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="Persistent IRC bouncer with multi-client support - a fork of muh"
+HOMEPAGE="http://miau.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE="debug ipv6"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if use ipv6; then
+ echo
+ ewarn "Enabling the ipv6 useflag will disable ipv4 entirely. Press"
+ ewarn "Ctrl+C now if you don't want this."
+ echo
+ ebeep 5
+ fi
+}
+
+src_compile() {
+ # --disable-debug seems to actually enabled it, using if use rather than
+ # use_enable to get around it.
+ if use debug; then
+ myconf="--enable-debug"
+ fi
+ econf \
+ --enable-dccbounce \
+ --enable-automode \
+ --enable-releasenick \
+ --enable-ctcp-replies \
+ --enable-mkpasswd \
+ --enable-uptime \
+ --enable-chanlog \
+ --enable-privlog \
+ --enable-onconnect \
+ --enable-empty-awaymsg \
+ $(use_enable ipv6) \
+ ${myconf} \
+ $(use_enable debug enduserdebug) \
+ $(use_enable debug pingstat) \
+ $(use_enable debug dumpstatus) \
+ || die "econf failed."
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed."
+ dodoc AUTHORS ChangeLog TODO README || die "dodoc failed."
+
+ mv "${D}/usr/share/doc/miau/examples/miaurc" \
+ "${D}/usr/share/doc/${PF}/miaurc.sample"
+ rm -rf "${D}/usr/share/doc/miau"
+}
+
+pkg_postinst() {
+ echo
+ elog "You'll need to configure miau before running it."
+ elog "Put your config in ~/.miau/miaurc"
+ elog "You can use the sample config is in /usr/share/doc/${PF}/miaurc.sample"
+ elog "For more information, see the documentation."
+ echo
+}