summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-03-09 14:48:10 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-03-09 14:48:35 +0300
commit424b14c84dcbbaff7f364df9863a34bf15750638 (patch)
tree2028b848731c75d0db4ed2d6aa09d456c95662a9 /net-irc
parentx11-themes/fedora-backgrounds: Fedora backgrounds (diff)
downloadgentoo-424b14c84dcbbaff7f364df9863a34bf15750638.tar.gz
gentoo-424b14c84dcbbaff7f364df9863a34bf15750638.tar.bz2
gentoo-424b14c84dcbbaff7f364df9863a34bf15750638.zip
net-irc/irssi-otr: block irssi-1.2* as it has built-in otr
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/irssi-otr/irssi-otr-1.0.0-r1.ebuild3
-rw-r--r--net-irc/irssi-otr/irssi-otr-1.0.2.ebuild3
2 files changed, 4 insertions, 2 deletions
diff --git a/net-irc/irssi-otr/irssi-otr-1.0.0-r1.ebuild b/net-irc/irssi-otr/irssi-otr-1.0.0-r1.ebuild
index acbe377b4c6..adc29addfcb 100644
--- a/net-irc/irssi-otr/irssi-otr-1.0.0-r1.ebuild
+++ b/net-irc/irssi-otr/irssi-otr-1.0.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -17,6 +17,7 @@ IUSE=""
# please note >=libotr-4.1.0 is required due to critical bugfix
# d748757e581b74e7298df155ad49174cb914102b, see README.md
RDEPEND="
+ !=net-irc/irssi-1.2*
>=dev-libs/glib-2.22.0:2
>=dev-libs/libgcrypt-1.2.0:0
>=net-libs/libotr-4.1.0
diff --git a/net-irc/irssi-otr/irssi-otr-1.0.2.ebuild b/net-irc/irssi-otr/irssi-otr-1.0.2.ebuild
index f9338b3ea99..5a4cc0eb98d 100644
--- a/net-irc/irssi-otr/irssi-otr-1.0.2.ebuild
+++ b/net-irc/irssi-otr/irssi-otr-1.0.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -14,6 +14,7 @@ SLOT="0"
KEYWORDS="amd64 hppa sparc x86"
RDEPEND="
+ !=net-irc/irssi-1.2*
dev-libs/glib:2
>=dev-libs/libgcrypt-1.7.3
>=net-libs/libotr-4.1.0