summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2017-07-06 09:14:07 +0300
committerEray Aslan <eras@gentoo.org>2017-07-06 09:14:07 +0300
commit3312cf299721a468a99b644487705e9e8fe05b50 (patch)
treeebe28543ed807fd063670b1d5e428bf2a2eeb80f /net-libs/courier-authlib
parentdev-db/sqlcipher: drop old versions (diff)
downloadgentoo-3312cf299721a468a99b644487705e9e8fe05b50.tar.gz
gentoo-3312cf299721a468a99b644487705e9e8fe05b50.tar.bz2
gentoo-3312cf299721a468a99b644487705e9e8fe05b50.zip
net-libs/courier-authlib: fix courier-unicode dependency
bug 623902 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'net-libs/courier-authlib')
-rw-r--r--net-libs/courier-authlib/courier-authlib-0.68.0-r1.ebuild149
1 files changed, 149 insertions, 0 deletions
diff --git a/net-libs/courier-authlib/courier-authlib-0.68.0-r1.ebuild b/net-libs/courier-authlib/courier-authlib-0.68.0-r1.ebuild
new file mode 100644
index 000000000000..fafe3ceee10e
--- /dev/null
+++ b/net-libs/courier-authlib/courier-authlib-0.68.0-r1.ebuild
@@ -0,0 +1,149 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit flag-o-matic
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+
+DESCRIPTION="Courier authentication library"
+SRC_URI="mirror://sourceforge/courier/${P}.tar.bz2"
+HOMEPAGE="http://www.courier-mta.org/"
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="berkdb crypt debug gdbm ldap libressl mysql pam postgres sqlite static-libs"
+
+RESTRICT="!berkdb? ( test )"
+
+DEPEND="net-mail/mailbase
+ >=net-libs/courier-unicode-2.0
+ gdbm? ( sys-libs/gdbm )
+ !gdbm? ( sys-libs/db:= )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ ldap? ( >=net-nds/openldap-1.2.11 )
+ mysql? ( virtual/mysql )
+ pam? ( virtual/pam )
+ postgres? ( dev-db/postgresql:= )
+ sqlite? ( dev-db/sqlite:3 )"
+
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if ! has_version 'dev-tcltk/expect' ; then
+ ewarn 'The dev-tcltk/expect package is not installed.'
+ ewarn 'Without it, you will not be able to change system login passwords.'
+ ewarn 'However non-system authentication modules (LDAP, MySQL, PostgreSQL,'
+ ewarn 'and others) will work just fine.'
+ fi
+}
+
+src_configure() {
+ filter-flags -fomit-frame-pointer
+ local myconf
+ if use berkdb ; then
+ if use gdbm ; then
+ ewarn "Both gdbm and berkdb selected. Using gdbm."
+ else
+ myconf="--with-db=db"
+ fi
+ fi
+ use gdbm && myconf="--with-db=gdbm"
+ use debug && myconf+=" debug=true"
+ use sqlite && myconf+=" --with-sqlite-libs"
+
+ econf \
+ --sysconfdir=/etc/courier \
+ --datadir=/usr/share/courier \
+ --libexecdir=/usr/$(get_libdir)/courier \
+ --localstatedir=/var/lib/courier \
+ --sharedstatedir=/var/lib/courier/com \
+ --with-authdaemonvar=/var/lib/courier/authdaemon \
+ --with-authshadow \
+ --without-redhat \
+ --with-mailuser=mail \
+ --with-mailgroup=mail \
+ --cache-file="${S}/configuring.cache" \
+ $(use_with pam authpam) \
+ $(use_with ldap authldap) \
+ $(use_with mysql authmysql) \
+ $(use_with postgres authpgsql) \
+ $(use_with sqlite authsqlite) \
+ ${myconf}
+}
+
+orderfirst() {
+ file="${D}/etc/courier/authlib/${1}" ; option="${2}" ; param="${3}"
+ if [[ -e "${file}" ]] ; then
+ orig="$(grep ^${option}= ${file} | cut -d\" -f 2)"
+ new="${option}=\"${param} `echo ${orig} | sed -e\"s/${param}//g\" -e\"s/ / /g\"`\""
+ sed -i -e "s/^${option}=.*$/${new}/" "${file}" || die
+ fi
+}
+
+finduserdb() {
+ for dir in \
+ /etc/courier/authlib /etc/courier /etc/courier-imap \
+ /usr/lib/courier/etc /usr/lib/courier-imap/etc \
+ /usr/local/etc /usr/local/etc/courier /usr/local/courier/etc \
+ /usr/local/lib/courier/etc /usr/local/lib/courier-imap/etc \
+ /usr/local/share/sqwebmail /usr/local/etc/courier-imap ; do
+ if [[ -e "${dir}/userdb" ]] ; then
+ einfo "Found userdb at: ${dir}/userdb"
+ cp -fR "${dir}/userdb" "${D}/etc/courier/authlib/" || die
+ chmod go-rwx "${D}/etc/courier/authlib/userdb" || die
+ continue
+ fi
+ done
+}
+
+src_install() {
+ diropts -o mail -g mail
+ dodir /etc/courier
+ keepdir /var/lib/courier/authdaemon
+ keepdir /etc/courier/authlib
+ emake DESTDIR="${D}" install
+ [[ ! -e "${D}/etc/courier/authlib/userdb" ]] && finduserdb
+ emake DESTDIR="${D}" install-configure
+ rm -f "${D}"/etc/courier/authlib/*.bak
+ chown mail:mail "${D}"/etc/courier/authlib/* || die
+ for y in "${D}"/etc/courier/authlib/*.dist ; do
+ [[ ! -e "${y%%.dist}" ]] && cp -f "${y}" "${y%%.dist}"
+ done
+ use pam && orderfirst authdaemonrc authmodulelist authpam
+ use ldap && orderfirst authdaemonrc authmodulelist authldap
+ use sqlite && orderfirst authdaemonrc authmodulelist authsqlite
+ use postgres && orderfirst authdaemonrc authmodulelist authpgsql
+ use mysql && orderfirst authdaemonrc authmodulelist authmysql
+
+ DOCS=( AUTHORS ChangeLog* INSTALL NEWS README )
+ HTML_DOCS=( README.html README_authlib.html NEWS.html INSTALL.html README.authdebug.html )
+ if use mysql ; then
+ DOCS+=( README.authmysql.myownquery )
+ HTML_DOCS+=( README.authmysql.html )
+ fi
+ if use postgres ; then
+ HTML_DOCS+=( README.authpostgres.html README.authmysql.html )
+ fi
+ if use ldap ; then
+ DOCS+=( README.ldap )
+ dodir /etc/openldap/schema
+ cp -f authldap.schema "${D}/etc/openldap/schema/" || die
+ fi
+ if use sqlite ; then
+ HTML_DOCS+=( README.authsqlite.html README.authmysql.html )
+ fi
+ einstalldocs
+
+ newinitd "${FILESDIR}/${PN}-r1" "${PN}"
+
+ use static-libs || find "${D}" -name "*.a" -delete
+}
+
+pkg_postinst() {
+ if [[ -e /etc/courier/authlib/userdb ]] ; then
+ einfo "Running makeuserdb ..."
+ chmod go-rwx /etc/courier/authlib/userdb || die
+ makeuserdb
+ fi
+}