summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-11-17 19:41:07 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-11-17 19:55:35 +0100
commit3f8848ed78c8f5f08024d635cebc3b6b425aff15 (patch)
tree343a6c1c746059c16fb55e3fb92556cf9050e2f2 /net-libs/gloox
parentsys-apps/openrc: remove 0.22.3-r1 since 0.22.4 is going stable (diff)
downloadgentoo-3f8848ed78c8f5f08024d635cebc3b6b425aff15.tar.gz
gentoo-3f8848ed78c8f5f08024d635cebc3b6b425aff15.tar.bz2
gentoo-3f8848ed78c8f5f08024d635cebc3b6b425aff15.zip
net-libs/gloox: Bump to version 1.0.18
Package-Manager: portage-2.3.2
Diffstat (limited to 'net-libs/gloox')
-rw-r--r--net-libs/gloox/Manifest1
-rw-r--r--net-libs/gloox/gloox-1.0.18.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/net-libs/gloox/Manifest b/net-libs/gloox/Manifest
index 05c1101a6c60..b9affe3af780 100644
--- a/net-libs/gloox/Manifest
+++ b/net-libs/gloox/Manifest
@@ -1,3 +1,4 @@
DIST gloox-1.0.16.tar.bz2 697791 SHA256 fe80376adc03813bbaca01aca60b83eea6df0bc2a67394b070f3ee70e460ddef SHA512 7722e154792428284fb5522f61d297eb63ad5d78b9a3139def21fbfd811beadfc0d13aaa03235c96975b3b29a7b1c2f9e384cb8f38b3c3e320c572c927643643 WHIRLPOOL 96d68aa61c96e4782911921714bedc1455507c96ceb017e8de947d097bd0b25dc2b776d49113b0bb4334f4000b4f9ba7e6c17b99d7eddb86ce2918a22a35c8ad
DIST gloox-1.0.17.tar.bz2 698239 SHA256 31a7825b975b2dbe43974e78b42f22b7328df1058f0be26970a7665bb20c8025 SHA512 8595586da391fa23f54eff7c8eb514e7000d3569eac3846edc28da02ec2da409f46013de93dd6d4b5185965675fc22ff2c96f031afa581e2d9243469b1b419f2 WHIRLPOOL a8b47ae64c76fc3b57b77d9241cb3aa14e576eb496776635c8fc9a36d9b22795f92c0d1c74da53483b6663e6b9b1f42dd2d0743af8bd9977c0d3a453c55f4246
+DIST gloox-1.0.18.tar.bz2 700080 SHA256 16730e7fd4679e098a6d6c1f94ee72aca825e8f40e6744f5921ac32fdf22548e SHA512 b8387796914e237fa07cff17862f8eafad8506173a3bcd7a659158daf845a33606b3ec58822c2f0f8f629aa1ee68a2ac58489dba83516cb7da264da3678317a7 WHIRLPOOL 6b38e7e3d480083fd98fc4d5f8c2402faf1c5242d3201c29d40995cafd2aadafb20780c7219a1a55497ab95754ea1c5b8f79756fed9f2f3b84780dc060f4b1d0
DIST gloox-1.0.9.tar.bz2 670206 SHA256 143dd50e1edc4eb1d304fa28bdd6ab9e53b60c37c1726dd0e34c06c51f9a453e SHA512 a3fa7acc76fdca0421030e71b6a13ca0b04589946df2a781609f1bddae5329299d68ce99a4a94a0760206b112759636379ce67d220422b99302fc799964bfa22 WHIRLPOOL 414eb34fa3ec11ae929f84198d95ed0da9de0739655ae1188ac3eb03998de5cecb9c165ad284496b405b49126236b628dc5b4579e855b10377add145fabb63b1
diff --git a/net-libs/gloox/gloox-1.0.18.ebuild b/net-libs/gloox/gloox-1.0.18.ebuild
new file mode 100644
index 000000000000..400508ac4847
--- /dev/null
+++ b/net-libs/gloox/gloox-1.0.18.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils
+
+MY_P="${P/_/-}"
+DESCRIPTION="A portable high-level Jabber/XMPP library for C++"
+HOMEPAGE="http://camaya.net/gloox"
+SRC_URI="http://camaya.net/download/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0/15"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~ia64 ~sparc ~x86"
+IUSE="debug gnutls idn libressl ssl static-libs test zlib"
+
+DEPEND="idn? ( net-dns/libidn )
+ gnutls? ( net-libs/gnutls )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ )
+ zlib? ( sys-libs/zlib )"
+
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ # Examples are not installed anyway, so - why should we build them?
+ econf \
+ --without-examples \
+ $(use debug && echo "--enable-debug") \
+ $(use_enable static-libs static) \
+ $(use_with idn libidn) \
+ $(use_with gnutls) \
+ $(use_with ssl openssl) \
+ $(use_with test tests) \
+ $(use_with zlib)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}