summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-08-06 23:07:23 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2017-08-06 23:27:08 +0200
commit162eb916afce161f6b26259aa659f8efdb0cad5b (patch)
tree48dbd0c94705d6db146ed8559fae2acbd8c0aadb /net-libs/gnome-online-accounts
parentdev-util/bumpversion: Add python3_6 support (diff)
downloadgentoo-162eb916afce161f6b26259aa659f8efdb0cad5b.tar.gz
gentoo-162eb916afce161f6b26259aa659f8efdb0cad5b.tar.bz2
gentoo-162eb916afce161f6b26259aa659f8efdb0cad5b.zip
net-libs/gnome-online-accounts: version bump 3.22.5 → 3.22.6
Update to support Facebook Graph API > 2.3. Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'net-libs/gnome-online-accounts')
-rw-r--r--net-libs/gnome-online-accounts/Manifest1
-rw-r--r--net-libs/gnome-online-accounts/gnome-online-accounts-3.22.6.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/net-libs/gnome-online-accounts/Manifest b/net-libs/gnome-online-accounts/Manifest
index 8a7ecc71114a..97b0192f8575 100644
--- a/net-libs/gnome-online-accounts/Manifest
+++ b/net-libs/gnome-online-accounts/Manifest
@@ -1 +1,2 @@
DIST gnome-online-accounts-3.22.5.tar.xz 1404888 SHA256 a8a4894ea5c6ba4508f8fec539287f2ebaf2c9bcf4426463b6724ca58b9d8982 SHA512 5c87decaeb64850be02c3191088d518a5c3b84cb8d202692ff50b59dbf83f28a56f5bf34873ec9cc16301da3f8b3f41a892cf6a67f9e9f9f2bf35a8bde07a258 WHIRLPOOL abc5c08bcc384159ff021fcec960baf707b49bbacf1d07984b01d7180244c8e4424e4c14ce3cdb7fd89c0e88dd33bfa40dbfcd32e1ace1a6730ef64d143ba64f
+DIST gnome-online-accounts-3.22.6.tar.xz 1404728 SHA256 464248492840f6e3c6b3a30c54dad4995c1e348bce04c899a6a26b7a2551f7e5 SHA512 6b5370447ccc5407ed5abd32b70c94c52de1166466e731e2a0295800e598be5c068a8fd6c492d439bce1a7faea8ed3638f689438d42e335997892738b51ed673 WHIRLPOOL 44494f1fb48e17874120ebf0a5b765f40dbb277030d01ee073377a5030af18249a422397f6f63dc2ebebdd759d083e021cf4c1bae556fc217d64026d4afec5c0
diff --git a/net-libs/gnome-online-accounts/gnome-online-accounts-3.22.6.ebuild b/net-libs/gnome-online-accounts/gnome-online-accounts-3.22.6.ebuild
new file mode 100644
index 000000000000..ecfd0b578b40
--- /dev/null
+++ b/net-libs/gnome-online-accounts/gnome-online-accounts-3.22.6.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="GNOME framework for accessing online accounts"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeOnlineAccounts"
+
+LICENSE="LGPL-2+"
+SLOT="0/1"
+IUSE="debug gnome +introspection kerberos" # telepathy"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# pango used in goaeditablelabel
+# libsoup used in goaoauthprovider
+# goa kerberos provider is incompatible with app-crypt/heimdal, see
+# https://bugzilla.gnome.org/show_bug.cgi?id=692250
+# json-glib-0.16 needed for bug #485092
+RDEPEND="
+ >=dev-libs/glib-2.40:2
+ >=app-crypt/libsecret-0.5
+ >=dev-libs/json-glib-0.16
+ dev-libs/libxml2:2
+ >=net-libs/libsoup-2.42:2.4
+ net-libs/rest:0.7
+ net-libs/telepathy-glib
+ >=net-libs/webkit-gtk-2.7.2:4
+ >=x11-libs/gtk+-3.19.12:3
+ x11-libs/pango
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.2:= )
+ kerberos? (
+ app-crypt/gcr:0=
+ app-crypt/mit-krb5 )
+"
+# telepathy? ( net-libs/telepathy-glib )
+# goa-daemon can launch gnome-control-center
+PDEPEND="gnome? ( >=gnome-base/gnome-control-center-3.2[gnome-online-accounts(+)] )"
+
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.3
+ >=dev-util/gdbus-codegen-2.30.0
+ >=dev-util/intltool-0.50.1
+ sys-devel/gettext
+ virtual/pkgconfig
+
+ dev-libs/gobject-introspection-common
+ gnome-base/gnome-common
+"
+# eautoreconf needs gobject-introspection-common, gnome-common
+
+# Due to sub-configure
+QA_CONFIGURE_OPTIONS=".*"
+
+src_prepare() {
+ gnome2_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ # TODO: Give users a way to set the G/FB/Windows Live secrets
+ # telepathy optional support is really a badly one, bug #494456
+ gnome2_src_configure \
+ --disable-static \
+ --enable-backend \
+ --enable-documentation \
+ --enable-exchange \
+ --enable-facebook \
+ --enable-flickr \
+ --enable-foursquare \
+ --enable-imap-smtp \
+ --enable-lastfm \
+ --enable-media-server \
+ --enable-owncloud \
+ --enable-pocket \
+ --enable-telepathy \
+ --enable-windows-live \
+ $(usex debug --enable-debug=yes ' ') \
+ $(use_enable kerberos)
+ #$(use_enable telepathy)
+ # gudev & cheese from sub-configure is overriden
+ # by top level configure, and disabled so leave it like that
+}