summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-07-30 12:01:32 +0200
committerPacho Ramos <pacho@gentoo.org>2016-07-30 12:49:28 +0200
commitd7717a0f5cd723bbd8a7e1a41732a8a9fff43980 (patch)
tree5de4e4389030f359534428f5dcc2a10094a34b89 /net-libs/gnome-online-accounts
parentnet-libs/gnome-online-accounts: Drop old (diff)
downloadgentoo-d7717a0f5cd723bbd8a7e1a41732a8a9fff43980.tar.gz
gentoo-d7717a0f5cd723bbd8a7e1a41732a8a9fff43980.tar.bz2
gentoo-d7717a0f5cd723bbd8a7e1a41732a8a9fff43980.zip
net-libs/gnome-online-accounts: Version bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'net-libs/gnome-online-accounts')
-rw-r--r--net-libs/gnome-online-accounts/Manifest1
-rw-r--r--net-libs/gnome-online-accounts/gnome-online-accounts-3.20.3.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/net-libs/gnome-online-accounts/Manifest b/net-libs/gnome-online-accounts/Manifest
index d8dc4297f0a4..90ed25dc908f 100644
--- a/net-libs/gnome-online-accounts/Manifest
+++ b/net-libs/gnome-online-accounts/Manifest
@@ -1,2 +1,3 @@
DIST gnome-online-accounts-3.18.4.tar.xz 1384756 SHA256 9f23460aa6b1d8a63a8f3e979cba791cc88b5e07116f07da59fdcea09d79c74d SHA512 1d78d8720d3547e782a9c9b1fee5ec794c8a0ec56d94f690adc1cce9d4f20da07b85a7c6e657b591153db667b3580d8900217e789144ac2e40eb963a7ac8d1a8 WHIRLPOOL 5459b9670c555a331c1c89583abd81836b8da2369355a97784fa370473341c49d5543d88870c49a8f47afd72a11feb27e3bfdb081b10fce8eb1a057eab279d02
DIST gnome-online-accounts-3.20.2.tar.xz 1483312 SHA256 4b555d9d2587d49148929e836ff02d5dda80c4138f69036fa214b71383cdc1dd SHA512 102e81f75792f87642e4f3c08e8367a6d333a16e71a28aec000f02f7e9c7ca687435846b20902a281fb4eec576e4b9ec19ac076832fe746666627ff306d1d91a WHIRLPOOL 60bd5eee541df19559d520c0247b583fca2457d5a02e6a7b21ebe81a6e886914f7e36175eca162ff8e76111ead39fc044616676508d18c93fa604934b88b8d87
+DIST gnome-online-accounts-3.20.3.tar.xz 1485044 SHA256 094fc04cf3e0b4ace667fce3b5bdcca5093e0c93f9184439e663c69546c1e046 SHA512 2980c60b67d9dc7900e027946c957e14e8b2fb4785a6a7f51e5e48e36655fba51cdd1d56f750d473116b960ffaebd658e9d974047a6f627dd962d492174f8d67 WHIRLPOOL 8cd15e7914347845859d9e3f20e9a2a54581b38eb3903288a42dd379d3bb9fcc366d472fdab27e16112ded884cd59e67f739233184ffa9df787b313f074d5343
diff --git a/net-libs/gnome-online-accounts/gnome-online-accounts-3.20.3.ebuild b/net-libs/gnome-online-accounts/gnome-online-accounts-3.20.3.ebuild
new file mode 100644
index 000000000000..87efca6ec351
--- /dev/null
+++ b/net-libs/gnome-online-accounts/gnome-online-accounts-3.20.3.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="GNOME framework for accessing online accounts"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeOnlineAccounts"
+
+LICENSE="LGPL-2+"
+SLOT="0/1"
+IUSE="debug gnome +introspection kerberos" # telepathy"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# pango used in goaeditablelabel
+# libsoup used in goaoauthprovider
+# goa kerberos provider is incompatible with app-crypt/heimdal, see
+# https://bugzilla.gnome.org/show_bug.cgi?id=692250
+# json-glib-0.16 needed for bug #485092
+RDEPEND="
+ >=dev-libs/glib-2.40:2
+ >=app-crypt/libsecret-0.5
+ >=dev-libs/json-glib-0.16
+ dev-libs/libxml2:2
+ >=net-libs/libsoup-2.42:2.4
+ net-libs/rest:0.7
+ net-libs/telepathy-glib
+ >=net-libs/webkit-gtk-2.7.2:4
+ >=x11-libs/gtk+-3.19.12:3
+ x11-libs/pango
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.2:= )
+ kerberos? (
+ app-crypt/gcr:0=
+ app-crypt/mit-krb5 )
+"
+# telepathy? ( net-libs/telepathy-glib )
+# goa-daemon can launch gnome-control-center
+PDEPEND="gnome? ( >=gnome-base/gnome-control-center-3.2[gnome-online-accounts(+)] )"
+
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.3
+ >=dev-util/gdbus-codegen-2.30.0
+ >=dev-util/intltool-0.50.1
+ sys-devel/gettext
+ virtual/pkgconfig
+
+ dev-libs/gobject-introspection-common
+ gnome-base/gnome-common
+"
+# eautoreconf needs gobject-introspection-common, gnome-common
+
+# Due to sub-configure
+QA_CONFIGURE_OPTIONS=".*"
+
+src_prepare() {
+ gnome2_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ # TODO: Give users a way to set the G/FB/Windows Live secrets
+ # telepathy optional support is really a badly one, bug #494456
+ gnome2_src_configure \
+ --disable-static \
+ --enable-backend \
+ --enable-documentation \
+ --enable-exchange \
+ --enable-facebook \
+ --enable-flickr \
+ --enable-foursquare \
+ --enable-imap-smtp \
+ --enable-lastfm \
+ --enable-media-server \
+ --enable-owncloud \
+ --enable-pocket \
+ --enable-telepathy \
+ --enable-windows-live \
+ $(usex debug --enable-debug=yes ' ') \
+ $(use_enable kerberos)
+ #$(use_enable telepathy)
+ # gudev & cheese from sub-configure is overriden
+ # by top level configure, and disabled so leave it like that
+}