summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-01-25 13:53:03 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-01-25 13:53:03 +0100
commit57a9cba8c1e7a799c1a6a951fbbf3a95e62615ef (patch)
tree7d50565d3729ce1053574e285f2049ec255435b9 /net-libs/gsoap
parentdev-vcs/tortoisehg: Bump to version 4.8.2 (diff)
downloadgentoo-57a9cba8c1e7a799c1a6a951fbbf3a95e62615ef.tar.gz
gentoo-57a9cba8c1e7a799c1a6a951fbbf3a95e62615ef.tar.bz2
gentoo-57a9cba8c1e7a799c1a6a951fbbf3a95e62615ef.zip
net-libs/gsoap: Bump to version 2.8.77
Package-Manager: Portage-2.3.58, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-libs/gsoap')
-rw-r--r--net-libs/gsoap/Manifest1
-rw-r--r--net-libs/gsoap/gsoap-2.8.77.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/net-libs/gsoap/Manifest b/net-libs/gsoap/Manifest
index ad3a36d5f8a1..515a7883c171 100644
--- a/net-libs/gsoap/Manifest
+++ b/net-libs/gsoap/Manifest
@@ -1,3 +1,4 @@
DIST gsoap_2.8.70.zip 32695627 BLAKE2B 6d803441804badf06b29cee8ca898dc864b9a0388f6f3fa58b84c1b237d77e22ab70e0cc5439915c715bdba7831b14f86d8003e1338b6184ddbfe845bb76ff75 SHA512 f7e9f85580c19bb390f1310bb47b690a5788b54c1e12c6fc0d9166039a84ae24ec5d3268cb67cd72b20e2eaa78689e175b975f07da44fd20e172a77ef37f4ae7
DIST gsoap_2.8.75.zip 32645773 BLAKE2B 120d79a33f90881ef5c4486ffef3a7713770622a65832be9997edeebbd4beac6dbdb6dfd876eb86f8622a1693908e6f56a47b48179fb37fdb12d313e2929ea7e SHA512 f5ebbe307b9125eec2284989a7ec1c16ade93df3b091ac44768750010bf51fdd9199ba96dbdc5b37b105bdd1156a0f90f41fdb407408d62b2c7750881db8b949
DIST gsoap_2.8.76.zip 32474005 BLAKE2B 4b604ea5c21ff98e2eddad3bd032e87e460d708a118ed65cb98e1577a7dc85f7103ffa4ddc4c3447425f4978f7ef72f6c1004fbe6d099a654ef3705fff53bc8a SHA512 4613ce97a52c08267f6186fc90dfa15dac3be0407b754a42ceef59a5f784078c90e43086b9920031d7690a775b42184c330af03c7c594d6cd5b781ff44b1c0b6
+DIST gsoap_2.8.77.zip 32495225 BLAKE2B 96d1d629eddfa470b53412f15fdb1ffdcc53bcda257ef4ed9c93b3da56cb1627fb98bed81108eb8344e6dbefa2b93c7cf9d9372186590c9a9668044eac9217e8 SHA512 3c03bd32ed9e6368f8483ff7979d2a75361f60f475a4b99b6d3a7d371719c254671d49177c70dd1538075a5e96b3e398d1d301e4fa66cb5979441b6bd6c60fd8
diff --git a/net-libs/gsoap/gsoap-2.8.77.ebuild b/net-libs/gsoap/gsoap-2.8.77.ebuild
new file mode 100644
index 000000000000..a36f6c5466c9
--- /dev/null
+++ b/net-libs/gsoap/gsoap-2.8.77.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_P="${PN}-2.8"
+
+DESCRIPTION="A cross-platform open source C and C++ SDK for SOAP/XML Web services"
+HOMEPAGE="http://gsoap2.sourceforge.net"
+SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.zip"
+
+LICENSE="GPL-2 gSOAP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug examples ipv6 libressl gnutls +ssl"
+
+RDEPEND="
+ sys-libs/zlib
+ gnutls? ( net-libs/gnutls )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl )
+ )
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ sys-devel/flex
+ sys-devel/bison
+"
+
+PATCHES=(
+ # Fix Pre-ISO headers
+ "${FILESDIR}/${PN}-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch"
+
+ # enable shared libs https://bugs.gentoo.org/583398
+ "${FILESDIR}/${PN}-2.8.70-shared_libs.patch"
+
+ # Fix parallel make
+ "${FILESDIR}/${PN}-2.8.70-parallel.patch"
+)
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ # Don't include xlocale.h as it got removed in >=glibc-2.26
+ --disable-xlocale
+ $(use_enable debug)
+ $(use_enable examples samples)
+ $(usex gnutls --enable-gnutls '')
+ $(usex ipv6 --enable-ipv6 '')
+ $(usex ssl '' --disable-ssl)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # yes, we also install the license-file since
+ # it contains info about how to apply the licenses
+ dodoc *.txt
+
+ docinto html
+ dodoc changelog.md
+
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+
+ if use examples; then
+ rm -r gsoap/samples/Makefile* gsoap/samples/*/Makefile* gsoap/samples/*/*.o || die
+ insinto /usr/share/doc/${PF}/examples
+ doins -r gsoap/samples/*
+ fi
+
+ if use doc; then
+ docinto html
+ dodoc -r gsoap/doc/*
+ fi
+}