summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-10-16 18:27:20 +0200
committerPacho Ramos <pacho@gentoo.org>2016-10-16 18:30:45 +0200
commitf7535f4853a945d83569ca6f11170863288a2acf (patch)
tree312d72329407de7f6adc988b033bb647553fbe2a /net-libs/gupnp-av
parentgnome-base/gvfs: Drop old (diff)
downloadgentoo-f7535f4853a945d83569ca6f11170863288a2acf.tar.gz
gentoo-f7535f4853a945d83569ca6f11170863288a2acf.tar.bz2
gentoo-f7535f4853a945d83569ca6f11170863288a2acf.zip
net-libs/gupnp-av: Version bump
Package-Manager: portage-2.3.1
Diffstat (limited to 'net-libs/gupnp-av')
-rw-r--r--net-libs/gupnp-av/Manifest1
-rw-r--r--net-libs/gupnp-av/gupnp-av-0.12.10.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/net-libs/gupnp-av/Manifest b/net-libs/gupnp-av/Manifest
index 14f5ae8065b4..36c29b8a0a19 100644
--- a/net-libs/gupnp-av/Manifest
+++ b/net-libs/gupnp-av/Manifest
@@ -1 +1,2 @@
+DIST gupnp-av-0.12.10.tar.xz 370552 SHA256 8038ef84dddbe7ad91c205bf91dddf684f072df8623f39b6555a6bb72837b85a SHA512 dbecef1f725dd05e1d4f7f9dede02f26a022d8d3c98ed2344d28746b74fb81703026df8cdd7ed0f3060b55a5da6d88def1e92a80e1f1892ad7c0806124ef5269 WHIRLPOOL e9498fc1298e8736b94f64f843c65827f9a103c73ec458ed8c86d048c4f250097bffa7c5482cccbdebd7381c4107981a85c15b2660654c01e6449ca2897c421d
DIST gupnp-av-0.12.8.tar.xz 357248 SHA256 759bc7d46aff894c282d17f508d9b5be82de96aa74b10cb6b0fc6c5e07cc273c SHA512 d56b9316758c0e4f4fbe3c5f4ca25b60c6f5a4fbbdd6037695598f1643fa112b334a7eca72df531c37e3c994e018c3fc018694f29f5c4240cff3a3e63075bcb7 WHIRLPOOL 67e20c07126b28f53ce69c3ba9a71a8a17a9943b262c25ab65a3f9a6438a2e7c5a7435d5b72c7156e2f1f93f59ce0b86dde8604e52d80ee8482f643c57417a0e
diff --git a/net-libs/gupnp-av/gupnp-av-0.12.10.ebuild b/net-libs/gupnp-av/gupnp-av-0.12.10.ebuild
new file mode 100644
index 000000000000..a73ffbc0cbed
--- /dev/null
+++ b/net-libs/gupnp-av/gupnp-av-0.12.10.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+VALA_USE_DEPEND="vapigen"
+
+inherit eutils gnome2 vala
+
+DESCRIPTION="Utility library aiming to ease the handling UPnP A/V profiles"
+HOMEPAGE="https://wiki.gnome.org/Projects/GUPnP"
+
+LICENSE="LGPL-2"
+SLOT="0/2" # subslot: soname version
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.16:2
+ >=net-libs/libsoup-2.28.2:2.4[introspection?]
+ dev-libs/libxml2
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+ !net-libs/gupnp-vala
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.10
+ virtual/pkgconfig
+ introspection? ( $(vala_depend) )
+"
+
+src_prepare() {
+ use introspection && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ --disable-static
+}