summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-12-27 22:00:49 +0100
committerJeroen Roovers <jer@gentoo.org>2018-12-27 22:26:46 +0100
commite1e2484aea288225586c5a0552a40fd35472fcca (patch)
tree669f9ba13d4db6bf829e92d99755ddbe640bd225 /net-libs/http-parser
parentsys-cluster/galera: Version bump for 25.3.25 (diff)
downloadgentoo-e1e2484aea288225586c5a0552a40fd35472fcca.tar.gz
gentoo-e1e2484aea288225586c5a0552a40fd35472fcca.tar.bz2
gentoo-e1e2484aea288225586c5a0552a40fd35472fcca.zip
net-libs/http-parser: Version 2.8.1_p20181224
Upstream nodejs is now basing their expectations of non-bundled http-parser on changes that have not been officially released yet. Package-Manager: Portage-2.3.52, Repoman-2.3.12 Fixes: https://bugs.gentoo.org/673830 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-libs/http-parser')
-rw-r--r--net-libs/http-parser/Manifest1
-rw-r--r--net-libs/http-parser/http-parser-2.8.1_p20181224.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/net-libs/http-parser/Manifest b/net-libs/http-parser/Manifest
index 8557aad9d1fb..70587f99d5f9 100644
--- a/net-libs/http-parser/Manifest
+++ b/net-libs/http-parser/Manifest
@@ -1 +1,2 @@
DIST http-parser-2.8.1.tar.gz 50731 BLAKE2B 1c4f3f61550f7f8e86d7b47e3986754a108dc979c6232d87ac418f9f8295b88ee43c4a5af150460f707e6ade01f5d435801f980ccbff93369ee0a9dc2eb60656 SHA512 6f52f543d979f39688ccefae236527a8183929b3d30f5370570107b01cf89d0338b448249a81102b78d31615d2e8f6e7c708f8961f55ece08e7d3a40e5ad0883
+DIST http-parser-2.8.1_p20181224.tar.gz 51363 BLAKE2B ada4bc8e4143c45fc03ae18a16426cbd7ee2c945ea01806e2e6527ee8080ae1f23c72f101e4d20d12fc5995794ab0c0beca358e42daa1c429c5db74253b0f1c3 SHA512 7b721bf5283510d106544a120c51779d7fc85ae9149ab0bffc07bed17b398db506ce75e994e5b11856ef1a9576979948c04400e7e9a33942a3017dcf9b21a174
diff --git a/net-libs/http-parser/http-parser-2.8.1_p20181224.ebuild b/net-libs/http-parser/http-parser-2.8.1_p20181224.ebuild
new file mode 100644
index 000000000000..43deb42fdd8b
--- /dev/null
+++ b/net-libs/http-parser/http-parser-2.8.1_p20181224.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs multilib-minimal
+
+HP_COMMIT="350258965909f249f9c59823aac240313e0d0120"
+DESCRIPTION="HTTP request/response parser for C"
+HOMEPAGE="https://github.com/nodejs/http-parser"
+SRC_URI="https://github.com/nodejs/http-parser/archive/${HP_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/2.8.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x64-macos ~x64-solaris"
+IUSE="static-libs"
+
+S=${WORKDIR}/${PN}-${HP_COMMIT}
+
+src_prepare() {
+ default
+ tc-export CC AR
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ emake PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)" CFLAGS_FAST="${CFLAGS}" library
+ use static-libs && emake CFLAGS_FAST="${CFLAGS}" package
+}
+
+multilib_src_test() {
+ emake CFLAGS_DEBUG="${CFLAGS}" CFLAGS_FAST="${CFLAGS}" test
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)" install
+ use static-libs && dolib.a libhttp_parser.a
+}