summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2019-04-01 13:29:14 +0100
committerTony Vroon <chainsaw@gentoo.org>2019-04-01 13:29:27 +0100
commita564d4b7c943a4942a9a65bff7c60834a23a5395 (patch)
tree76586d43d1c91a245f0e9be3fba17b65b7f54de2 /net-libs/libmbim
parentapp-admin/systemrescuecd-x86: Restrict mirror & bindist (diff)
downloadgentoo-a564d4b7c943a4942a9a65bff7c60834a23a5395.tar.gz
gentoo-a564d4b7c943a4942a9a65bff7c60834a23a5395.tar.bz2
gentoo-a564d4b7c943a4942a9a65bff7c60834a23a5395.zip
net-libs/libmbim: Propagate glib-utils fix to older versions.
This package requires glib-utils and should not rely on the glib ebuild to implicitly pull this in. Newly committed 1.18 is already fixed (the EAPI 7 way with a BDEPEND), but the older ebuilds needed the extra DEPEND. Closes: https://bugs.gentoo.org/667338 Suggested-By: Mart Raudsepp <leio@gentoo.org> Reported-By: Toralf Förster <toralf@gentoo.org> Signed-Off-By: Tony Vroon <chainsaw@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'net-libs/libmbim')
-rw-r--r--net-libs/libmbim/libmbim-1.10.0.ebuild3
-rw-r--r--net-libs/libmbim/libmbim-1.12.2.ebuild3
-rw-r--r--net-libs/libmbim/libmbim-1.12.4.ebuild3
-rw-r--r--net-libs/libmbim/libmbim-1.14.0.ebuild3
-rw-r--r--net-libs/libmbim/libmbim-1.14.4.ebuild3
-rw-r--r--net-libs/libmbim/libmbim-1.16.0.ebuild3
-rw-r--r--net-libs/libmbim/libmbim-1.16.2.ebuild3
-rw-r--r--net-libs/libmbim/libmbim-1.6.0.ebuild3
8 files changed, 16 insertions, 8 deletions
diff --git a/net-libs/libmbim/libmbim-1.10.0.ebuild b/net-libs/libmbim/libmbim-1.10.0.ebuild
index 3d883570ea6..580a6aac03e 100644
--- a/net-libs/libmbim/libmbim-1.10.0.ebuild
+++ b/net-libs/libmbim/libmbim-1.10.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -22,6 +22,7 @@ IUSE="static-libs"
RDEPEND=">=dev-libs/glib-2.32:2
virtual/libgudev:="
DEPEND="${RDEPEND}
+ dev-util/glib-utils
dev-util/gtk-doc-am
virtual/pkgconfig"
[[ ${PV} == "9999" ]] && DEPEND+=" dev-util/gtk-doc" #469214
diff --git a/net-libs/libmbim/libmbim-1.12.2.ebuild b/net-libs/libmbim/libmbim-1.12.2.ebuild
index a93d407b0ee..7d9320f581a 100644
--- a/net-libs/libmbim/libmbim-1.12.2.ebuild
+++ b/net-libs/libmbim/libmbim-1.12.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -22,6 +22,7 @@ IUSE="static-libs"
RDEPEND=">=dev-libs/glib-2.32:2
virtual/libgudev:="
DEPEND="${RDEPEND}
+ dev-util/glib-utils
dev-util/gtk-doc-am
virtual/pkgconfig"
[[ ${PV} == "9999" ]] && DEPEND+=" dev-util/gtk-doc" #469214
diff --git a/net-libs/libmbim/libmbim-1.12.4.ebuild b/net-libs/libmbim/libmbim-1.12.4.ebuild
index b7960c01b17..a91f073f9d4 100644
--- a/net-libs/libmbim/libmbim-1.12.4.ebuild
+++ b/net-libs/libmbim/libmbim-1.12.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -22,6 +22,7 @@ IUSE="static-libs"
RDEPEND=">=dev-libs/glib-2.32:2
virtual/libgudev:="
DEPEND="${RDEPEND}
+ dev-util/glib-utils
dev-util/gtk-doc-am
virtual/pkgconfig"
[[ ${PV} == "9999" ]] && DEPEND+=" dev-util/gtk-doc" #469214
diff --git a/net-libs/libmbim/libmbim-1.14.0.ebuild b/net-libs/libmbim/libmbim-1.14.0.ebuild
index 0f1540ae369..f10f42cfecd 100644
--- a/net-libs/libmbim/libmbim-1.14.0.ebuild
+++ b/net-libs/libmbim/libmbim-1.14.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -17,6 +17,7 @@ IUSE="static-libs udev"
RDEPEND=">=dev-libs/glib-2.32:2
udev? ( virtual/libgudev:= )"
DEPEND="${RDEPEND}
+ dev-util/glib-utils
dev-util/gtk-doc-am
virtual/pkgconfig"
diff --git a/net-libs/libmbim/libmbim-1.14.4.ebuild b/net-libs/libmbim/libmbim-1.14.4.ebuild
index 30d61f25ae3..9620241e897 100644
--- a/net-libs/libmbim/libmbim-1.14.4.ebuild
+++ b/net-libs/libmbim/libmbim-1.14.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -17,6 +17,7 @@ IUSE="static-libs udev"
RDEPEND=">=dev-libs/glib-2.32:2
udev? ( virtual/libgudev:= )"
DEPEND="${RDEPEND}
+ dev-util/glib-utils
dev-util/gtk-doc-am
virtual/pkgconfig"
diff --git a/net-libs/libmbim/libmbim-1.16.0.ebuild b/net-libs/libmbim/libmbim-1.16.0.ebuild
index 30d61f25ae3..9620241e897 100644
--- a/net-libs/libmbim/libmbim-1.16.0.ebuild
+++ b/net-libs/libmbim/libmbim-1.16.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -17,6 +17,7 @@ IUSE="static-libs udev"
RDEPEND=">=dev-libs/glib-2.32:2
udev? ( virtual/libgudev:= )"
DEPEND="${RDEPEND}
+ dev-util/glib-utils
dev-util/gtk-doc-am
virtual/pkgconfig"
diff --git a/net-libs/libmbim/libmbim-1.16.2.ebuild b/net-libs/libmbim/libmbim-1.16.2.ebuild
index b2159d5d442..f10f42cfecd 100644
--- a/net-libs/libmbim/libmbim-1.16.2.ebuild
+++ b/net-libs/libmbim/libmbim-1.16.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -17,6 +17,7 @@ IUSE="static-libs udev"
RDEPEND=">=dev-libs/glib-2.32:2
udev? ( virtual/libgudev:= )"
DEPEND="${RDEPEND}
+ dev-util/glib-utils
dev-util/gtk-doc-am
virtual/pkgconfig"
diff --git a/net-libs/libmbim/libmbim-1.6.0.ebuild b/net-libs/libmbim/libmbim-1.6.0.ebuild
index d52ec04ba37..c959f6cc15b 100644
--- a/net-libs/libmbim/libmbim-1.6.0.ebuild
+++ b/net-libs/libmbim/libmbim-1.6.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -22,6 +22,7 @@ IUSE="doc static-libs test"
RDEPEND=">=dev-libs/glib-2.32
virtual/libgudev:="
DEPEND="${RDEPEND}
+ dev-util/glib-utils
doc? ( dev-util/gtk-doc )
virtual/pkgconfig"
[[ ${PV} == "9999" ]] && DEPEND+=" dev-util/gtk-doc" #469214