summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-07-11 06:58:45 +0200
committerJeroen Roovers <jer@gentoo.org>2016-07-11 06:59:14 +0200
commit7290fced5951aba8094071880250fa318c18d079 (patch)
tree1d17ae4694a29a0412aade076e476e05a6eef4cf /net-libs/libmnl
parentnet-misc/youtube-dl: Old. (diff)
downloadgentoo-7290fced5951aba8094071880250fa318c18d079.tar.gz
gentoo-7290fced5951aba8094071880250fa318c18d079.tar.bz2
gentoo-7290fced5951aba8094071880250fa318c18d079.zip
net-libs/libmnl: Version bump.
Package-Manager: portage-2.3.0
Diffstat (limited to 'net-libs/libmnl')
-rw-r--r--net-libs/libmnl/Manifest1
-rw-r--r--net-libs/libmnl/libmnl-1.0.4.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/net-libs/libmnl/Manifest b/net-libs/libmnl/Manifest
index 5e56654fdb8e..9de91440d524 100644
--- a/net-libs/libmnl/Manifest
+++ b/net-libs/libmnl/Manifest
@@ -1 +1,2 @@
DIST libmnl-1.0.3.tar.bz2 337375 SHA256 6f14336e9acdbc62c2dc71bbb59ce162e54e9af5c80153e92476c5443fe784de SHA512 c47b76a6125271ef9dce13bc8bebd415d2bbd79b6d50491d8ba23344e7e6fe0c1413fe055913ab9444203f0d73166b79f0d4b532b13b62feecde3e5a8cd442a7 WHIRLPOOL 80717c63015e8df36a11c2b7914d63747ff296fac72b4f3a66670038f94d28961ddc6dce2050c41d3ceaf195030b61535ee84a628fa1fa686d8fed013f4d6261
+DIST libmnl-1.0.4.tar.bz2 301270 SHA256 171f89699f286a5854b72b91d06e8f8e3683064c5901fb09d954a9ab6f551f81 SHA512 e2bbfb688fe41913d53c74ba7ec95b4e88ee2c52b556b8608185f2fcbd629665423a3b37f877f84426ba257cf6040fa701539d67166b00b8e3e2dfde6831a2f9 WHIRLPOOL b6372180b2f4f6e5d2fa920db05680d5376c7279c44de476114fa4fa70e00938033f67e0e7b188c3202aca7f2fb6b9e8a17121d711185da3b94a6e90987e4fcc
diff --git a/net-libs/libmnl/libmnl-1.0.4.ebuild b/net-libs/libmnl/libmnl-1.0.4.ebuild
new file mode 100644
index 000000000000..59025da99211
--- /dev/null
+++ b/net-libs/libmnl/libmnl-1.0.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Minimalistic netlink library"
+HOMEPAGE="http://netfilter.org/projects/libmnl"
+SRC_URI="http://www.netfilter.org/projects/${PN}/files/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux"
+IUSE="examples static-libs"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ gen_usr_ldscript -a mnl
+ prune_libtool_files
+
+ if use examples; then
+ find examples/ -name 'Makefile*' -delete
+ dodoc -r examples/
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}