summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/libnetfilter_conntrack
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/libnetfilter_conntrack')
-rw-r--r--net-libs/libnetfilter_conntrack/Manifest2
-rw-r--r--net-libs/libnetfilter_conntrack/libnetfilter_conntrack-1.0.3.ebuild43
-rw-r--r--net-libs/libnetfilter_conntrack/libnetfilter_conntrack-1.0.4.ebuild43
-rw-r--r--net-libs/libnetfilter_conntrack/metadata.xml5
4 files changed, 93 insertions, 0 deletions
diff --git a/net-libs/libnetfilter_conntrack/Manifest b/net-libs/libnetfilter_conntrack/Manifest
new file mode 100644
index 000000000000..132351b653cc
--- /dev/null
+++ b/net-libs/libnetfilter_conntrack/Manifest
@@ -0,0 +1,2 @@
+DIST libnetfilter_conntrack-1.0.3.tar.bz2 390454 SHA256 fc1710854d26d527087dbbefb110193650d9aae1876f90cb64b8d5c0a8dd95a4 SHA512 9949d3b3352e2cad3310128089de024950a1178a2a42c7a0ecec026dfe3b51b9b1b658d291d95d1a7d2ea038608ada4f77b9b8b2c72f9e887fb6211a1e25f628 WHIRLPOOL 4daab5dddf617fc00c6f21796b56a14eebe77e67601bd2fb9a4bd8b178c700ff83746496f6f88fe549ad964e85d31f8c7294b99204adbc2fc19223bdfaa83bac
+DIST libnetfilter_conntrack-1.0.4.tar.bz2 428147 SHA256 d9ec4a3caf49417f2b0a2d8d44249133e8c3ec78c757b7eb8c273f1cb6929c7d SHA512 53b5e5b26ca58abd6b9d83979bbb61aac4b24a85aa425c6b4fc4472b8273e30393678d6acd1aec0e959916b919cd561582ddd4b2ee656b6cb774aa9d9819c046 WHIRLPOOL 5028ca559a734019c6796b6ed73b120a1cf84c27748ae640f084ee5f1fd0c9b0f34e485a526761e35eb29c0e65e9126853b489bdb5e7d45b7cbe960113584a82
diff --git a/net-libs/libnetfilter_conntrack/libnetfilter_conntrack-1.0.3.ebuild b/net-libs/libnetfilter_conntrack/libnetfilter_conntrack-1.0.3.ebuild
new file mode 100644
index 000000000000..553a02c68b72
--- /dev/null
+++ b/net-libs/libnetfilter_conntrack/libnetfilter_conntrack-1.0.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools-utils linux-info
+
+DESCRIPTION="programming interface (API) to the in-kernel connection tracking state table"
+HOMEPAGE="http://www.netfilter.org/projects/libnetfilter_conntrack/"
+SRC_URI="http://www.netfilter.org/projects/${PN}/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86"
+IUSE="static-libs"
+
+RDEPEND="
+ >=net-libs/libmnl-1.0.3
+ >=net-libs/libnfnetlink-1.0.0
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+DOCS=( README )
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ if kernel_is lt 2 6 18 ; then
+ die "${PN} requires at least 2.6.18 kernel version"
+ fi
+
+ #netfilter core team has changed some option names with kernel 2.6.20
+ if kernel_is lt 2 6 20 ; then
+ CONFIG_CHECK="~IP_NF_CONNTRACK_NETLINK"
+ else
+ CONFIG_CHECK="~NF_CT_NETLINK"
+ fi
+
+ check_extra_config
+}
diff --git a/net-libs/libnetfilter_conntrack/libnetfilter_conntrack-1.0.4.ebuild b/net-libs/libnetfilter_conntrack/libnetfilter_conntrack-1.0.4.ebuild
new file mode 100644
index 000000000000..18d248cd920a
--- /dev/null
+++ b/net-libs/libnetfilter_conntrack/libnetfilter_conntrack-1.0.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools-utils linux-info
+
+DESCRIPTION="programming interface (API) to the in-kernel connection tracking state table"
+HOMEPAGE="http://www.netfilter.org/projects/libnetfilter_conntrack/"
+SRC_URI="http://www.netfilter.org/projects/${PN}/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ia64 m68k ppc ppc64 s390 sh sparc x86"
+IUSE="static-libs"
+
+RDEPEND="
+ >=net-libs/libmnl-1.0.3
+ >=net-libs/libnfnetlink-1.0.0
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+DOCS=( README )
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ if kernel_is lt 2 6 18 ; then
+ die "${PN} requires at least 2.6.18 kernel version"
+ fi
+
+ #netfilter core team has changed some option names with kernel 2.6.20
+ if kernel_is lt 2 6 20 ; then
+ CONFIG_CHECK="~IP_NF_CONNTRACK_NETLINK"
+ else
+ CONFIG_CHECK="~NF_CT_NETLINK"
+ fi
+
+ check_extra_config
+}
diff --git a/net-libs/libnetfilter_conntrack/metadata.xml b/net-libs/libnetfilter_conntrack/metadata.xml
new file mode 100644
index 000000000000..03aa50bab7e3
--- /dev/null
+++ b/net-libs/libnetfilter_conntrack/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+</pkgmetadata>