summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/libnids
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/libnids')
-rw-r--r--net-libs/libnids/Manifest1
-rw-r--r--net-libs/libnids/files/libnids-1.24-ldflags.patch11
-rw-r--r--net-libs/libnids/files/libnids-1.24-static-libs.patch29
-rw-r--r--net-libs/libnids/libnids-1.24-r6.ebuild54
-rw-r--r--net-libs/libnids/metadata.xml13
5 files changed, 108 insertions, 0 deletions
diff --git a/net-libs/libnids/Manifest b/net-libs/libnids/Manifest
new file mode 100644
index 000000000000..ceb019443d68
--- /dev/null
+++ b/net-libs/libnids/Manifest
@@ -0,0 +1 @@
+DIST libnids-1.24.tar.gz 151021 SHA256 314b4793e0902fbf1fdb7fb659af37a3c1306ed1aad5d1c84de6c931b351d359 SHA512 2046900023e853d7dbd7061c9f47d8a8ba26320991ca34198249019c1b9a6f75010574f9f022d02976272a384cf769394c4cc3ae536fc6164716cadc4770bb53 WHIRLPOOL c012e724c0f724cd817db4726a4ee1c0a438d717fe8534f96c41829e5574a3edaf4fd287c3acd65da4ee6591bb55dcd0f0bb71da7302e7b8ba43992ba85a1455
diff --git a/net-libs/libnids/files/libnids-1.24-ldflags.patch b/net-libs/libnids/files/libnids-1.24-ldflags.patch
new file mode 100644
index 000000000000..0f3daca463b6
--- /dev/null
+++ b/net-libs/libnids/files/libnids-1.24-ldflags.patch
@@ -0,0 +1,11 @@
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -65,7 +65,7 @@
+ ar -cr $@ $(OBJS)
+ $(RANLIB) $@
+ $(LIBSHARED): $(OBJS_SHARED)
+- $(CC) -shared -Wl,-soname,$(LIBSHARED) -o $(LIBSHARED) $(OBJS_SHARED) $(LIBS) $(LNETLIB) $(PCAPLIB)
++ $(CC) -shared -Wl,-soname,$(LIBSHARED) $(LDFLAGS) -o $(LIBSHARED) $(OBJS_SHARED) $(LIBS) $(LNETLIB) $(PCAPLIB)
+
+ _install install: $(LIBSTATIC)
+ ../mkinstalldirs $(install_prefix)$(libdir)
diff --git a/net-libs/libnids/files/libnids-1.24-static-libs.patch b/net-libs/libnids/files/libnids-1.24-static-libs.patch
new file mode 100644
index 000000000000..7bf9a0f1b629
--- /dev/null
+++ b/net-libs/libnids/files/libnids-1.24-static-libs.patch
@@ -0,0 +1,29 @@
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -62,19 +62,22 @@
+
+
+ $(LIBSTATIC): $(OBJS)
+- ar -cr $@ $(OBJS)
++ $(AR) -cr $@ $(OBJS)
+ $(RANLIB) $@
+ $(LIBSHARED): $(OBJS_SHARED)
+ $(CC) -shared -Wl,-soname,$(LIBSHARED) $(LDFLAGS) -o $(LIBSHARED) $(OBJS_SHARED) $(LIBS) $(LNETLIB) $(PCAPLIB)
+
+-_install install: $(LIBSTATIC)
++installbase:
+ ../mkinstalldirs $(install_prefix)$(libdir)
+ ../mkinstalldirs $(install_prefix)$(includedir)
+ ../mkinstalldirs $(install_prefix)$(mandir)/man3
+- $(INSTALL) -c -m 644 libnids.a $(install_prefix)$(libdir)
+ $(INSTALL) -c -m 644 nids.h $(install_prefix)$(includedir)
+ $(INSTALL) -c -m 644 libnids.3 $(install_prefix)$(mandir)/man3
+-_installshared installshared: install $(LIBSHARED)
++
++_install install: $(LIBSTATIC) installbase
++ $(INSTALL) -c -m 644 libnids.a $(install_prefix)$(libdir)
++
++_installshared installshared: $(LIBSHARED) installbase
+ $(INSTALL) -c -m 755 $(LIBSHARED) $(install_prefix)$(libdir)
+ ln -s -f $(LIBSHARED) $(install_prefix)$(libdir)/libnids.so
+
diff --git a/net-libs/libnids/libnids-1.24-r6.ebuild b/net-libs/libnids/libnids-1.24-r6.ebuild
new file mode 100644
index 000000000000..581561bba51d
--- /dev/null
+++ b/net-libs/libnids/libnids-1.24-r6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="an implementation of an E-component of Network Intrusion Detection System"
+HOMEPAGE="http://libnids.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="1.2"
+KEYWORDS="amd64 ppc x86"
+IUSE="+glib +libnet static-libs"
+
+RDEPEND="
+ !net-libs/libnids:1.1
+ glib? ( dev-libs/glib:2 )
+ libnet? ( >=net-libs/libnet-1.1.0-r3 )
+ net-libs/libpcap
+"
+DEPEND="
+ ${RDEPEND}
+ glib? ( virtual/pkgconfig )
+"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-ldflags.patch"
+ epatch "${FILESDIR}/${P}-static-libs.patch"
+}
+
+src_configure() {
+ tc-export AR
+ append-flags -fno-strict-aliasing
+
+ econf \
+ --enable-shared \
+ $(usex glib '' --disable-libglib) \
+ $(use_enable libnet)
+}
+
+src_compile() {
+ emake shared $(usex static-libs static '')
+}
+
+src_install() {
+ local tgt
+ for tgt in _installshared $(usex static-libs _install ''); do
+ emake install_prefix="${D}" ${tgt}
+ done
+
+ dodoc CHANGES CREDITS MISC README doc/*
+}
diff --git a/net-libs/libnids/metadata.xml b/net-libs/libnids/metadata.xml
new file mode 100644
index 000000000000..d669db19d880
--- /dev/null
+++ b/net-libs/libnids/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <longdescription>emulates the IP stack of Linux 2.0.x and offers IP defragmentation, TCP stream assembly and TCP port scan detection.</longdescription>
+ <use>
+ <flag name="glib">Use <pkg>dev-libs/glib</pkg> for multiprocessing support</flag>
+ <flag name="libnet">Include code requiring <pkg>net-libs/libnet</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">libnids</remote-id>
+ </upstream>
+</pkgmetadata>