summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-06-13 22:32:05 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-06-13 22:35:45 +0200
commit547bbcbdb43009c3f56f0568353308ac35242eda (patch)
treef155d1437f187d8d6ff9061be46f8ca5d9d151f3 /net-libs/librsync
parentapp-admin/rasdaemon: 0.6.1 bup (diff)
downloadgentoo-547bbcbdb43009c3f56f0568353308ac35242eda.tar.gz
gentoo-547bbcbdb43009c3f56f0568353308ac35242eda.tar.bz2
gentoo-547bbcbdb43009c3f56f0568353308ac35242eda.zip
net-libs/librsync: 2.0.2 version bump
Non-maintainer commit. Bug: https://bugs.gentoo.org/657270 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'net-libs/librsync')
-rw-r--r--net-libs/librsync/Manifest1
-rw-r--r--net-libs/librsync/librsync-2.0.2.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/net-libs/librsync/Manifest b/net-libs/librsync/Manifest
index c1563d1b1f88..4336e15f900c 100644
--- a/net-libs/librsync/Manifest
+++ b/net-libs/librsync/Manifest
@@ -1,3 +1,4 @@
DIST librsync-0.9.7.tar.gz 453802 BLAKE2B 0f8a7a758d847498876401aa04473946970be0257dc0cc4abce85adc7adb5d480d7a41e03d43f667e44ec646ce74a75dfa6b0c63c7f239338244b67eb432e31f SHA512 339362fd01c94411849d3e4a6e95db1bef6cffa0475b1af49d73f11be0421a12d4c73ecbf1a272af01b2a21cec81b4a801c1f7d735e107d0242707fb4c45f9ef
DIST librsync-2.0.0.tar.gz 155049 BLAKE2B ca1d938cc8a60ffe5b16b804344164c69296738f6d01adb991a7d0f9685544c8be77608cd17aa269f14bd92cf7390896caa94c84e95313f17e6fa36a4c0e2a46 SHA512 1a88dcc3aa60949e058c57eb0df3e0086823c493de40fed927246f5aada6274db57202074456a0ce5d9aa8b81b41836b0d6221ded6a75d43829572584177e8c0
DIST librsync-2.0.1.tar.gz 169765 BLAKE2B 3b3a109307dc03e567338709f1c3958a2ae7887165208848359677305f6a983edc1bc71c721dd3f414f77e0507426ae5bb59b9fde51595a92379227ac316127a SHA512 70c1ed0f3a8ad8c1201ce67b5411c4aabb4c78ba9d60e4ee658d9a8818c6511322abd53b583869b8927a29b0f105e1a5c9b05efa748eb435e8fc3b7be3344e04
+DIST librsync-2.0.2.tar.gz 174480 BLAKE2B e77d554ad08a852459fe2798249f47ca7f26849b4b8622c5b64f7f9b6d23f1fedc443f747c7988679a3548ea1f6fd2902c424717faaf73a5cfd7e19012a2d72d SHA512 5d2bc1d62b37e9ed7416203615d0a0e3c05c4c884b5da63eda10dd5c985845b500331bce226e4d45676729382c85b41528282e25d491afda31ba434ac0fefad7
diff --git a/net-libs/librsync/librsync-2.0.2.ebuild b/net-libs/librsync/librsync-2.0.2.ebuild
new file mode 100644
index 000000000000..5b3da0604c6d
--- /dev/null
+++ b/net-libs/librsync/librsync-2.0.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Remote delta-compression library"
+HOMEPAGE="https://librsync.github.io/"
+SRC_URI="https://github.com/librsync/librsync/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+RDEPEND="
+ dev-libs/popt
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_LIBB2=OFF
+ )
+
+ cmake-utils_src_configure
+}