summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-09-16 15:31:34 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-09-16 17:48:17 +0200
commit25c725a0ae3e342731bdc9b02cd9e9d180831590 (patch)
treee2df9dc9928fa10f6dac4b243f8c46d9794fd092 /net-libs/libtirpc
parentdev-ml/capnp-ocaml: run proper build target in src_compile to avoid building ... (diff)
downloadgentoo-25c725a0ae3e342731bdc9b02cd9e9d180831590.tar.gz
gentoo-25c725a0ae3e342731bdc9b02cd9e9d180831590.tar.bz2
gentoo-25c725a0ae3e342731bdc9b02cd9e9d180831590.zip
net-libs/libtirpc: Add exported symbol bugfix from Arch; see the patch for links
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'net-libs/libtirpc')
-rw-r--r--net-libs/libtirpc/files/libtirpc-1.0.2-exports.patch17
-rw-r--r--net-libs/libtirpc/libtirpc-1.0.2-r1.ebuild64
2 files changed, 81 insertions, 0 deletions
diff --git a/net-libs/libtirpc/files/libtirpc-1.0.2-exports.patch b/net-libs/libtirpc/files/libtirpc-1.0.2-exports.patch
new file mode 100644
index 000000000000..174f4e3471f8
--- /dev/null
+++ b/net-libs/libtirpc/files/libtirpc-1.0.2-exports.patch
@@ -0,0 +1,17 @@
+See
+https://bugs.alpinelinux.org/issues/7041
+https://git.alpinelinux.org/cgit/aports/commit/?id=9edb53cea056101c4963a04b747bf102de23f919
+(just hit this myself when building libnsl)
+... dilfridge
+
+--- a/src/libtirpc.map
++++ b/src/libtirpc.map
+@@ -298,7 +298,7 @@
+ key_gendes;
+ key_get_conv;
+ key_setsecret;
+- key_secret_is_set;
++ key_secretkey_is_set;
+ key_setnet;
+ netname2host;
+ netname2user;
diff --git a/net-libs/libtirpc/libtirpc-1.0.2-r1.ebuild b/net-libs/libtirpc/libtirpc-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..e88a976324aa
--- /dev/null
+++ b/net-libs/libtirpc/libtirpc-1.0.2-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit autotools multilib-minimal toolchain-funcs eutils
+
+DESCRIPTION="Transport Independent RPC library (SunRPC replacement)"
+HOMEPAGE="http://libtirpc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
+ mirror://gentoo/${PN}-glibc-nfs.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/3" # subslot matches SONAME major
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ipv6 kerberos static-libs"
+
+RDEPEND="kerberos? ( >=virtual/krb5-0-r1[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.2-bcopy-to-memmove.patch"
+ "${FILESDIR}/${PN}-1.0.2-bzero-to-memset.patch"
+ "${FILESDIR}/${PN}-1.0.2-glibc-2.26.patch"
+ "${FILESDIR}/${PN}-1.0.2-exports.patch"
+)
+
+src_prepare() {
+ cp -r "${WORKDIR}"/tirpc "${S}"/ || die
+ epatch "${PATCHES[@]}"
+ epatch_user
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ $(use_enable ipv6) \
+ $(use_enable kerberos gssapi) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install() {
+ default
+
+ # libtirpc replaces rpc support in glibc, so we need it in /
+ gen_usr_ldscript -a tirpc
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ insinto /etc
+ doins doc/netconfig
+
+ insinto /usr/include/tirpc
+ doins -r "${WORKDIR}"/tirpc/*
+
+ # makes sure that the linking order for nfs-utils is proper, as
+ # libtool would inject a libgssglue dependency in the list.
+ use static-libs || prune_libtool_files
+}