summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-01-21 16:27:17 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-01-21 16:27:35 +0300
commit3fa1e996223925a8680d72a48bac39bab4a022d4 (patch)
tree6d1c92ff0ad586f0e75857c5eef94c8499e256d3 /net-libs/libtorrent-rasterbar
parentwww-apps/agendav: update php dependency (diff)
downloadgentoo-3fa1e996223925a8680d72a48bac39bab4a022d4.tar.gz
gentoo-3fa1e996223925a8680d72a48bac39bab4a022d4.tar.bz2
gentoo-3fa1e996223925a8680d72a48bac39bab4a022d4.zip
net-libs/libtorrent-rasterbar: Version bump (v1.2.0)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'net-libs/libtorrent-rasterbar')
-rw-r--r--net-libs/libtorrent-rasterbar/Manifest1
-rw-r--r--net-libs/libtorrent-rasterbar/libtorrent-rasterbar-1.2.0.ebuild110
2 files changed, 111 insertions, 0 deletions
diff --git a/net-libs/libtorrent-rasterbar/Manifest b/net-libs/libtorrent-rasterbar/Manifest
index f4bd96395319..a7fb2861e3cc 100644
--- a/net-libs/libtorrent-rasterbar/Manifest
+++ b/net-libs/libtorrent-rasterbar/Manifest
@@ -1,2 +1,3 @@
DIST libtorrent-rasterbar-1.1.10.tar.gz 3902542 BLAKE2B 3a78862ce2825c9da32ab38122db05c2816daa237559446a60702f562e971c5597210dfc2612235294cec3f60fa3de8cab3a0246887ac4779b01171a460f70f0 SHA512 414deeb9765bfb6072af5fa00ad836bfe3751622a80783ea84389e31355b342a4371f0dc195b2d27b154826e515b2e6063c8786f792afa347abba9caadaa5b2a
DIST libtorrent-rasterbar-1.1.11.tar.gz 4044314 BLAKE2B 96192ffdcb5bd1888307c874e2685314db9a99438337b0cb67ef317a2fe54b4a0e8e28fcdf34a1656a9abb69cc79f9bbda22cdedf1b8f2ba4f1b5488922c87b3 SHA512 1e0449406ea34b226033e3f54f719c5f2842043c7e54107e847050c67b1c5e9d2cb5a08fbf0e81c2c6e31eda6fe85c5ec0ff8ca47916c979894f778fc3313bb6
+DIST libtorrent-rasterbar-1.2.0.tar.gz 3546062 BLAKE2B a02ef8f273d8e6ec3b6f6a42d518f7cbba669f109f907e243bb90cd674009894b9edce2f355b52d77275f3fcd9537e9c26280f7b78dfbb1792f52d6c7f50f7da SHA512 2dae77f32cf3da388edece7e64b8d9cf359cca735a101d96bb18fb06573fd1d84c303e5bebd370f637d7c73010ea2d99e38748b2259ce02ae8f0dbc0c4f01518
diff --git a/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-1.2.0.ebuild b/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-1.2.0.ebuild
new file mode 100644
index 000000000000..c18af82cf1ac
--- /dev/null
+++ b/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-1.2.0.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE="threads"
+DISTUTILS_OPTIONAL=true
+DISTUTILS_IN_SOURCE_BUILD=true
+
+inherit autotools distutils-r1 flag-o-matic
+
+MY_PV=$(ver_rs 1-2 '_')
+MY_P=${PN/-rasterbar}_${MY_PV}
+
+DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
+HOMEPAGE="https://libtorrent.org"
+SRC_URI="https://github.com/arvidn/libtorrent/archive/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/9"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug +dht doc examples libressl python +ssl static-libs test"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ virtual/libiconv
+ examples? ( !net-p2p/mldonkey )
+ python? (
+ ${PYTHON_DEPS}
+ dev-libs/boost:=[python,${PYTHON_USEDEP}]
+ )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+"
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+"
+
+S="${WORKDIR}/${PN/-rasterbar}-${MY_P}"
+
+src_prepare() {
+ mkdir "${S}"/build-aux/ || die
+ touch "${S}"/build-aux/config.rpath || die
+ eautoreconf
+
+ default
+
+ # bug 578026
+ # prepend -L${S}/... to ensure bindings link against the lib we just built
+ sed -i -e "s|^|-L${S}/src/.libs |" bindings/python/link_flags.in || die
+
+ # prepend -I${S}/... to ensure bindings use the right headers
+ sed -i -e "s|^|-I${S}/src/include |" bindings/python/compile_flags.in || die
+
+ use python && distutils-r1_src_prepare
+}
+
+src_configure() {
+ append-cxxflags -std=c++11 # bug 634506
+
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable debug export-all)
+ $(use_enable dht dht $(usex debug logging $(usex ('yes' 'no'))))
+ $(use_enable examples)
+ $(use_enable ssl encryption)
+ $(use_enable static-libs static)
+ $(use_enable test tests)
+ --with-libiconv
+ )
+ econf "${myeconfargs[@]}"
+
+ if use python; then
+ python_configure() {
+ econf "${myeconfargs[@]}" \
+ --enable-python-binding \
+ --with-boost-python="${EPYTHON#python}"
+ }
+ distutils-r1_src_configure
+ fi
+}
+
+src_compile() {
+ default
+
+ python_compile() {
+ cd "${BUILD_DIR}/../bindings/python" || die
+ distutils-r1_python_compile
+ }
+ use python && distutils-r1_src_compile
+}
+
+src_install() {
+ use doc && HTML_DOCS+=( "${S}"/docs )
+
+ default
+
+ python_install() {
+ cd "${BUILD_DIR}/../bindings/python" || die
+ distutils-r1_python_install
+ }
+ use python && distutils-r1_src_install
+
+ find "${D}" -name '*.la' -delete || die
+}