summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2017-01-27 18:14:33 +0100
committerMike Gilbert <floppym@gentoo.org>2017-01-27 12:33:53 -0500
commit5d9b7ab316c35e871c1528231e5e5190c50265ef (patch)
tree87f9afce7ca2c3321790ffb2b71b2995d63f5dbc /net-libs/neon
parentdev-db/sqlite: Version bump (3.16.2). (diff)
downloadgentoo-5d9b7ab316c35e871c1528231e5e5190c50265ef.tar.gz
gentoo-5d9b7ab316c35e871c1528231e5e5190c50265ef.tar.bz2
gentoo-5d9b7ab316c35e871c1528231e5e5190c50265ef.zip
net-libs/neon: Version bump (0.30.2).
Diffstat (limited to 'net-libs/neon')
-rw-r--r--net-libs/neon/Manifest1
-rw-r--r--net-libs/neon/neon-0.30.2.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/net-libs/neon/Manifest b/net-libs/neon/Manifest
index ec1be1836ca4..253841ba3490 100644
--- a/net-libs/neon/Manifest
+++ b/net-libs/neon/Manifest
@@ -1,2 +1,3 @@
DIST neon-0.30.0.tar.gz 909989 SHA256 2962cfcb5d30f3272e3d2fa0e473434419770a3801afe3d46e5d1650787990c2 SHA512 67f8a6c5549c37d984d8a0af88cd93c8c51593fa995662fd686e47acb630143d7b0c02c09d3c19f6a0181e0ff82940618cf72a76f9cb17bb964293f4118f013e WHIRLPOOL 75df16aae54410e97887ad1b1d45a17e58868cffff7d929f511c4840179ace1500c33228b02de7a038b9620d729e5153e1e14cc916ed1af9ce90bf4c49fb4b71
DIST neon-0.30.1.tar.gz 911414 SHA256 00c626c0dc18d094ab374dbd9a354915bfe4776433289386ed489c2ec0845cdd SHA512 4a9e45c886e04c5e1a1c781f7c2544b73724e09745097b1e8dc9adf9acd79af1762d668d4f18c295d7b4148d57af797834dd3c1203f2529089f7d1972ca71e63 WHIRLPOOL 747385544f0fbacc6c39fa5911ee5a21654ac21ecea89f297c17b43c21a7a649ae47b08b155733e9da0286a24024f4e54dcff3c9c2d678d9abe27f83054d718b
+DIST neon-0.30.2.tar.gz 932779 SHA256 db0bd8cdec329b48f53a6f00199c92d5ba40b0f015b153718d1b15d3d967fbca SHA512 634caf87522e0bd2695c6fba39cae2465e403f9fbd8007eb10e4e035c765d24cb8da932c67bfa35c34aa51b90c7bc7037ebebaa1ec43259366d5d07233efc631 WHIRLPOOL 977464fc686727dcbdb9def45159d783586fceb289c0eca937429ae3d2b39d9c6bb63a5029be566107d415718ee6ab315b8167c02b3093884757932f89e3b704
diff --git a/net-libs/neon/neon-0.30.2.ebuild b/net-libs/neon/neon-0.30.2.ebuild
new file mode 100644
index 000000000000..d88dd4075816
--- /dev/null
+++ b/net-libs/neon/neon-0.30.2.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit autotools libtool multilib-minimal
+
+DESCRIPTION="HTTP and WebDAV client library"
+HOMEPAGE="http://www.webdav.org/neon/"
+SRC_URI="http://www.webdav.org/neon/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/27"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc expat gnutls kerberos libproxy libressl nls pkcs11 ssl static-libs zlib"
+RESTRICT="test"
+
+RDEPEND="expat? ( dev-libs/expat:0=[${MULTILIB_USEDEP}] )
+ !expat? ( dev-libs/libxml2:2=[${MULTILIB_USEDEP}] )
+ gnutls? (
+ app-misc/ca-certificates
+ net-libs/gnutls:0=[${MULTILIB_USEDEP}]
+ pkcs11? ( dev-libs/pakchois:0=[${MULTILIB_USEDEP}] )
+ )
+ !gnutls? ( ssl? (
+ libressl? ( dev-libs/libressl:=[${MULTILIB_USEDEP}] )
+ !libressl? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )
+ pkcs11? ( dev-libs/pakchois:0=[${MULTILIB_USEDEP}] )
+ ) )
+ kerberos? ( virtual/krb5:0=[${MULTILIB_USEDEP}] )
+ libproxy? ( net-libs/libproxy:0=[${MULTILIB_USEDEP}] )
+ nls? ( virtual/libintl:0=[${MULTILIB_USEDEP}] )
+ zlib? ( sys-libs/zlib:0=[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig[${MULTILIB_USEDEP}]"
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/neon-config
+)
+
+src_prepare() {
+ # Use CHOST-prefixed version of xml2-config for cross-compilation.
+ sed -e "s/AC_CHECK_PROG(XML2_CONFIG,/AC_CHECK_TOOL(XML2_CONFIG,/" -i macros/neon-xml-parser.m4 || die "sed failed"
+
+ eapply_user
+
+ AT_M4DIR="macros" eautoreconf
+
+ elibtoolize
+
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local myconf=()
+
+ if has_version sys-libs/glibc; then
+ einfo "Enabling SSL library thread-safety using POSIX threads..."
+ myconf+=(--enable-threadsafe-ssl=posix)
+ fi
+
+ if use expat; then
+ myconf+=(--with-expat)
+ else
+ myconf+=(--with-libxml2)
+ fi
+
+ if use gnutls; then
+ myconf+=(--with-ssl=gnutls --with-ca-bundle="${EPREFIX}/etc/ssl/certs/ca-certificates.crt")
+ elif use ssl; then
+ myconf+=(--with-ssl=openssl)
+ fi
+
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --enable-shared \
+ $(use_with kerberos gssapi) \
+ $(use_with libproxy) \
+ $(use_enable nls) \
+ $(use_with pkcs11 pakchois) \
+ $(use_enable static-libs static) \
+ $(use_with zlib) \
+ "${myconf[@]}"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install-{config,headers,lib,man,nls}
+
+ if multilib_is_native_abi && use doc; then
+ dohtml -r doc/html/
+ fi
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name "*.la" -delete
+
+ dodoc AUTHORS BUGS NEWS README THANKS TODO
+}