summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/netembryo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/netembryo')
-rw-r--r--net-libs/netembryo/Manifest1
-rw-r--r--net-libs/netembryo/metadata.xml11
-rw-r--r--net-libs/netembryo/netembryo-0.1.1.ebuild38
3 files changed, 50 insertions, 0 deletions
diff --git a/net-libs/netembryo/Manifest b/net-libs/netembryo/Manifest
new file mode 100644
index 000000000000..7b329c09d8d5
--- /dev/null
+++ b/net-libs/netembryo/Manifest
@@ -0,0 +1 @@
+DIST netembryo-0.1.1.tar.bz2 265851 RMD160 f67bfd35a4493d1180d14912f1d4f72367a6f8c5 SHA1 e647e71be4091d18c0e628f7f959e2433fbcd824 SHA256 b20c12f09e99f9c00efab3b9588457fd8a2fa6bb3ed26c35ada572c0b172a981
diff --git a/net-libs/netembryo/metadata.xml b/net-libs/netembryo/metadata.xml
new file mode 100644
index 000000000000..b55e0e950209
--- /dev/null
+++ b/net-libs/netembryo/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <maintainer>
+ <email>media-video@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="sctp">Support for Stream Control Transmission Protocol</flag>
+ </use>
+</pkgmetadata>
diff --git a/net-libs/netembryo/netembryo-0.1.1.ebuild b/net-libs/netembryo/netembryo-0.1.1.ebuild
new file mode 100644
index 000000000000..477964a148e0
--- /dev/null
+++ b/net-libs/netembryo/netembryo-0.1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit multilib
+
+DESCRIPTION="a network abstraction library"
+HOMEPAGE="http://lscube.org/projects/netembryo/"
+SRC_URI="http://lscube.org/files/downloads/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ipv6 +sctp test"
+
+RDEPEND=">=dev-libs/openssl-0.9.8
+ sctp? ( net-misc/lksctp-tools )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( >=dev-libs/glib-2.20:2
+ sys-apps/gawk
+ dev-util/ctags )"
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --disable-static \
+ $(use_enable ipv6) \
+ $(use_enable sctp) \
+ $(use_enable test tests)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog README TODO
+ find "${D}"usr/$(get_libdir) -name '*.la' -delete
+}