summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/txtorcon
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/txtorcon')
-rw-r--r--net-libs/txtorcon/Manifest1
-rw-r--r--net-libs/txtorcon/metadata.xml12
-rw-r--r--net-libs/txtorcon/txtorcon-0.13.0.ebuild31
3 files changed, 44 insertions, 0 deletions
diff --git a/net-libs/txtorcon/Manifest b/net-libs/txtorcon/Manifest
new file mode 100644
index 000000000000..7f060945e6f4
--- /dev/null
+++ b/net-libs/txtorcon/Manifest
@@ -0,0 +1 @@
+DIST txtorcon-0.13.0.tar.gz 208077 SHA256 3218d0fa0c22f49eee9324a5862b2d53ef77d5cb8e555e2bcffc24070aaeca7d SHA512 45f94a8a147b176ced1b93b5949df84e7321090aa0a755f1a4232050ebe09812986200b31ef63433b8c2f24b2066b5f3b746e4c3677529c7d7be8aebd1c97e25 WHIRLPOOL db91499f39dd79295af35abcdeaf08e2d92988994800bfea4662ddcbc2d5b252dbace08b6429c08f66fad9a76f8bd0aeb7dbe2e28e467f3c17f8aa4601158666
diff --git a/net-libs/txtorcon/metadata.xml b/net-libs/txtorcon/metadata.xml
new file mode 100644
index 000000000000..9ce1c0433878
--- /dev/null
+++ b/net-libs/txtorcon/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">txtorcon</remote-id>
+ <remote-id type="github">meejah/txtorcon</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-libs/txtorcon/txtorcon-0.13.0.ebuild b/net-libs/txtorcon/txtorcon-0.13.0.ebuild
new file mode 100644
index 000000000000..9be62daf5363
--- /dev/null
+++ b/net-libs/txtorcon/txtorcon-0.13.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python2_7)
+
+inherit distutils-r1
+
+DESCRIPTION="Twisted-based Tor controller client, with state-tracking and configuration abstractions"
+HOMEPAGE="https://github.com/meejah/txtorcon https://pypi.python.org/pypi/txtorcon"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-python/twisted-core[${PYTHON_USEDEP}]
+ dev-python/ipaddr[${PYTHON_USEDEP}]
+ net-misc/tor
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ dev-python/geoip-python[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+python_test() {
+ trial --reporter=text test || die
+}