summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-04-01 12:23:08 +0200
committerJeroen Roovers <jer@gentoo.org>2019-04-01 12:24:39 +0200
commit13b97042173234896370a5624e5f0ae312ef0b7a (patch)
treece5f82da4a20a75ebab9a5266037ce22f760eb21 /net-libs/wvstreams
parentdev-libs/appstream: remove 0.12.3 and 0.12.4 (diff)
downloadgentoo-13b97042173234896370a5624e5f0ae312ef0b7a.tar.gz
gentoo-13b97042173234896370a5624e5f0ae312ef0b7a.tar.bz2
gentoo-13b97042173234896370a5624e5f0ae312ef0b7a.zip
net-libs/wvstreams: Use Debian SRC_URI/patchset
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Fixes: https://bugs.gentoo.org/614810 Fixes: https://bugs.gentoo.org/634488 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-libs/wvstreams')
-rw-r--r--net-libs/wvstreams/Manifest2
-rw-r--r--net-libs/wvstreams/wvstreams-4.6.1_p14.ebuild97
2 files changed, 99 insertions, 0 deletions
diff --git a/net-libs/wvstreams/Manifest b/net-libs/wvstreams/Manifest
index ccf728a6855d..579ea20214df 100644
--- a/net-libs/wvstreams/Manifest
+++ b/net-libs/wvstreams/Manifest
@@ -1 +1,3 @@
DIST wvstreams-4.6.1.tar.gz 1118456 BLAKE2B 62243d9adc6ff5d01b7dfeb2ce24e8e530914e6ac4540e542dc3cee31e00d32211ad1c6085d7f5bd6e5fd85ff66e8c93afa37cec81f976590ba150f039dc8580 SHA512 59d64e527d86394b768b35254bf95ea59c412c0e092393ea3c84ec3202949150439bb6093bd7350b64ad4767acdb8feb38806c03de4e5cf238ed893f41db4a4a
+DIST wvstreams_4.6.1-14.debian.tar.xz 21124 BLAKE2B 2af6ec180c3130dd7def733e5ea569fd0a81cd2c2411daca25e6042dcbe78792bafc4b13f1c1fffddb6cd66273f11c62f54b415c975cbea0af052b18ff0955d1 SHA512 93ea7c4fbab542bd552d6e91ae0c49a27ad8aded177ae6474943acb08d204ab31eac49b3f416b4d90a38ea697f3641c09651a64f9c40d12543d454aadf2ad9e4
+DIST wvstreams_4.6.1.orig.tar.gz 1118456 BLAKE2B 62243d9adc6ff5d01b7dfeb2ce24e8e530914e6ac4540e542dc3cee31e00d32211ad1c6085d7f5bd6e5fd85ff66e8c93afa37cec81f976590ba150f039dc8580 SHA512 59d64e527d86394b768b35254bf95ea59c412c0e092393ea3c84ec3202949150439bb6093bd7350b64ad4767acdb8feb38806c03de4e5cf238ed893f41db4a4a
diff --git a/net-libs/wvstreams/wvstreams-4.6.1_p14.ebuild b/net-libs/wvstreams/wvstreams-4.6.1_p14.ebuild
new file mode 100644
index 000000000000..ea079309144b
--- /dev/null
+++ b/net-libs/wvstreams/wvstreams-4.6.1_p14.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic toolchain-funcs
+
+DESCRIPTION="A network programming library in C++"
+HOMEPAGE="https://github.com/apenwarr/wvstreams"
+SRC_URI="
+ mirror://debian/pool/main/w/${PN}/${PN}_${PV/_p*}.orig.tar.gz
+ mirror://debian/pool/main/w/${PN}/${PN}_${PV/_p/-}.debian.tar.xz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="pam doc +ssl +dbus debug boost"
+
+#Tests fail if openssl is not compiled with -DPURIFY. Gentoo's isn't. FAIL!
+RESTRICT="test"
+
+#QA Fail: xplc is compiled as a part of wvstreams.
+#It'll take a larger patching effort to get it extracted, since upstream integrated it
+#more tightly this time. Probably for the better since upstream xplc seems dead.
+
+RDEPEND="
+ dev-libs/openssl:0=
+ sys-libs/readline:0=
+ sys-libs/zlib
+ dbus? ( >=sys-apps/dbus-1.4.20 )
+ pam? ( virtual/pam )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ boost? ( >=dev-libs/boost-1.34.1:= )
+"
+DOCS="ChangeLog README*"
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.6.1-autoconf.patch
+ "${FILESDIR}"/${PN}-4.6.1-gcc47.patch
+ "${FILESDIR}"/${PN}-4.6.1-parallel-make.patch
+ "${FILESDIR}"/${PN}-4.6.1-_DEFAULT_SOURCE.patch
+)
+S=${WORKDIR}/${P/_p*}
+
+src_prepare() {
+ default
+
+ eapply $(awk '{ print "'${WORKDIR}'/debian/patches/" $0; }' < ${WORKDIR}/debian/patches/series)
+
+ eautoreconf
+}
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+ append-flags -fno-tree-dce -fno-optimize-sibling-calls #421375
+
+ tc-export AR CXX
+
+ use boost && export ac_cv_header_tr1_functional=no
+
+ econf \
+ $(use_enable debug) \
+ $(use_with dbus) \
+ $(use_with pam) \
+ --cache-file="${T}"/config.cache \
+ --disable-optimization \
+ --localstatedir=/var \
+ --with-openssl \
+ --with-zlib \
+ --without-qt \
+ --without-tcl \
+ --without-valgrind
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ doxygen || die
+ fi
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ default
+
+ if use doc; then
+ docinto html
+ dodoc -r Docs/doxy-html/*
+ fi
+}