summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/wvstreams
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/wvstreams')
-rw-r--r--net-libs/wvstreams/Manifest1
-rw-r--r--net-libs/wvstreams/files/wvstreams-4.6.1-gcc47.patch50
-rw-r--r--net-libs/wvstreams/files/wvstreams-4.6.1-glibc212.patch23
-rw-r--r--net-libs/wvstreams/files/wvstreams-4.6.1-openssl-1.0.0.patch16
-rw-r--r--net-libs/wvstreams/files/wvstreams-4.6.1-parallel-make.patch56
-rw-r--r--net-libs/wvstreams/metadata.xml16
-rw-r--r--net-libs/wvstreams/wvstreams-4.6.1-r2.ebuild105
-rw-r--r--net-libs/wvstreams/wvstreams-4.6.1-r3.ebuild105
8 files changed, 372 insertions, 0 deletions
diff --git a/net-libs/wvstreams/Manifest b/net-libs/wvstreams/Manifest
new file mode 100644
index 000000000000..3da826a19a69
--- /dev/null
+++ b/net-libs/wvstreams/Manifest
@@ -0,0 +1 @@
+DIST wvstreams-4.6.1.tar.gz 1118456 SHA256 8403f5fbf83aa9ac0c6ce15d97fd85607488152aa84e007b7d0621b8ebc07633 SHA512 59d64e527d86394b768b35254bf95ea59c412c0e092393ea3c84ec3202949150439bb6093bd7350b64ad4767acdb8feb38806c03de4e5cf238ed893f41db4a4a WHIRLPOOL 4d5a8e39332d00c1614d81e3d980d2458aebdf745b6630c8875adfff89b2c0baf08d39e5f7cc47bb4dbe37bc573c7e019e31163837df6d6d13741eeccc1c8e7a
diff --git a/net-libs/wvstreams/files/wvstreams-4.6.1-gcc47.patch b/net-libs/wvstreams/files/wvstreams-4.6.1-gcc47.patch
new file mode 100644
index 000000000000..b284da8f3e79
--- /dev/null
+++ b/net-libs/wvstreams/files/wvstreams-4.6.1-gcc47.patch
@@ -0,0 +1,50 @@
+http://bugs.gentoo.org/419563
+http://bugs.gentoo.org/419971
+
+See -gcc47-patch and -magic.patch in Fedora git:
+
+http://pkgs.fedoraproject.org/gitweb/?p=libwvstreams.git;a=tree
+
+--- include/wvtask.h
++++ include/wvtask.h
+@@ -45,7 +45,8 @@
+ typedef void TaskFunc(void *userdata);
+
+ static int taskcount, numtasks, numrunning;
+- int magic_number, *stack_magic;
++ int volatile magic_number;
++ int *stack_magic;
+ WvString name;
+ int tid;
+
+@@ -84,7 +85,7 @@
+ static WvTaskMan *singleton;
+ static int links;
+
+- static int magic_number;
++ static int volatile magic_number;
+ static WvTaskList all_tasks, free_tasks;
+
+ static void get_stack(WvTask &task, size_t size);
+--- include/wvuid.h
++++ include/wvuid.h
+@@ -7,6 +7,7 @@
+ #ifndef __WVUID_H
+ #define __WVUID_H
+
++#include <unistd.h>
+ #include "wvstring.h"
+
+ #if WIN32
+--- utils/wvtask.cc
++++ utils/wvtask.cc
+@@ -58,7 +58,8 @@
+ int WvTask::taskcount, WvTask::numtasks, WvTask::numrunning;
+
+ WvTaskMan *WvTaskMan::singleton;
+-int WvTaskMan::links, WvTaskMan::magic_number;
++int WvTaskMan::links;
++int volatile WvTaskMan::magic_number;
+ WvTaskList WvTaskMan::all_tasks, WvTaskMan::free_tasks;
+ ucontext_t WvTaskMan::stackmaster_task, WvTaskMan::get_stack_return,
+ WvTaskMan::toplevel;
diff --git a/net-libs/wvstreams/files/wvstreams-4.6.1-glibc212.patch b/net-libs/wvstreams/files/wvstreams-4.6.1-glibc212.patch
new file mode 100644
index 000000000000..473d3e832933
--- /dev/null
+++ b/net-libs/wvstreams/files/wvstreams-4.6.1-glibc212.patch
@@ -0,0 +1,23 @@
+http://bugs.gentoo.org/333301
+
+--- ipstreams/wvunixdgsocket.cc
++++ ipstreams/wvunixdgsocket.cc
+@@ -1,5 +1,5 @@
+ #include "wvunixdgsocket.h"
+-#ifdef MACOS
++#if defined(MACOS) || defined(__GNUC__)
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #endif
+--- streams/wvatomicfile.cc
++++ streams/wvatomicfile.cc
+@@ -11,7 +11,8 @@
+ #include "wvfileutils.h"
+ #include "wvstrutils.h"
+
+-#ifdef MACOS
++#if defined(MACOS) || defined(__GNUC__)
++#include <sys/types.h>
+ #include <sys/stat.h>
+ #endif
+
diff --git a/net-libs/wvstreams/files/wvstreams-4.6.1-openssl-1.0.0.patch b/net-libs/wvstreams/files/wvstreams-4.6.1-openssl-1.0.0.patch
new file mode 100644
index 000000000000..c27e7233627f
--- /dev/null
+++ b/net-libs/wvstreams/files/wvstreams-4.6.1-openssl-1.0.0.patch
@@ -0,0 +1,16 @@
+http://bugs.gentoo.org/304283
+
+--- crypto/wvx509.cc
++++ crypto/wvx509.cc
+@@ -1157,7 +1157,11 @@
+
+ if (ext)
+ {
++#if OPENSSL_VERSION_NUMBER >= 0x10000000L
++ const X509V3_EXT_METHOD *method = X509V3_EXT_get(ext);
++#else
+ X509V3_EXT_METHOD *method = X509V3_EXT_get(ext);
++#endif
+ if (!method)
+ {
+ WvDynBuf buf;
diff --git a/net-libs/wvstreams/files/wvstreams-4.6.1-parallel-make.patch b/net-libs/wvstreams/files/wvstreams-4.6.1-parallel-make.patch
new file mode 100644
index 000000000000..d6f7d6e76174
--- /dev/null
+++ b/net-libs/wvstreams/files/wvstreams-4.6.1-parallel-make.patch
@@ -0,0 +1,56 @@
+--- Makefile
++++ Makefile
+@@ -131,12 +131,19 @@
+ # libwvstreams: stream/event handling library
+ #
+ TARGETS += libwvstreams.so
+-TARGETS += crypto/tests/ssltest ipstreams/tests/unixtest
++TARGETS += crypto/tests/ssltest
++crypto/tests/ssltest: $(LIBWVSTREAMS)
++
++TARGETS += ipstreams/tests/unixtest
++ipstreams/tests/unixtest: $(LIBWVSTREAMS)
++
+ TARGETS += crypto/tests/printcert
++crypto/tests/printcert: $(LIBWVSTREAMS)
+
+ ifndef _MACOS
+ ifneq ("$(with_readline)", "no")
+ TARGETS += ipstreams/tests/wsd
++ ipstreams/tests/wsd: $(LIBWVSTREAMS)
+ ipstreams/tests/wsd-LIBS += -lreadline
+ else
+ TEST_SKIP_OBJS += ipstreams/tests/wsd
+@@ -179,7 +186,11 @@
+ #
+ ifneq ("$(with_dbus)", "no")
+ TARGETS += libwvdbus.so
+- TARGETS += dbus/tests/wvdbus dbus/tests/wvdbusd
++ TARGETS += dbus/tests/wvdbus
++ dbus/tests/wvdbus: $(LIBWVDBUS)
++
++ TARGETS += dbus/tests/wvdbusd
++ dbus/tests/wvdbusd: $(LIBWVDBUS)
+ TESTS += $(call tests_cc,dbus/tests)
+ libwvdbus_OBJS += $(call objects,dbus)
+ libwvdbus.so: $(libwvdbus_OBJS) $(LIBWVSTREAMS)
+--- wvrules-posix.mk
++++ wvrules-posix.mk
+@@ -85,12 +85,15 @@
+ $(AR) s $1
+ endef
+
+-CC: FORCE
++CC:
+ @CC="$(CC)" CFLAGS="$(CFLAGS)" CPPFLAGS="$(CPPFLAGS)" \
+ $(WVSTREAMS)/gen-cc CC c
+
+-CXX: FORCE
++CXX:
+ @CC="$(CXX)" CFLAGS="$(CXXFLAGS)" CPPFLAGS="$(CPPFLAGS)" \
+ $(WVSTREAMS)/gen-cc CXX cc
+
++#All files must depend on the above two rules. This is a godawful hack.
++$(shell find -type f '(' -name '*.c' -o -name '*.cc' ')' ): CC CXX
++
+ wvlink=$(LINK_MSG)$(WVLINK_CC) $(LDFLAGS) $($1-LDFLAGS) -o $1 $(filter %.o %.a %.so, $2) $($1-LIBS) $(XX_LIBS) $(LDLIBS) $(PRELIBS) $(LIBS)
diff --git a/net-libs/wvstreams/metadata.xml b/net-libs/wvstreams/metadata.xml
new file mode 100644
index 000000000000..4fd26ae6812a
--- /dev/null
+++ b/net-libs/wvstreams/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-dialup</herd>
+ <upstream>
+ <remote-id type="google-code">wvstreams</remote-id>
+ </upstream>
+ <use>
+ <flag name="boost">
+ Use <pkg>dev-libs/boost</pkg> to provide TR1-compatible
+ functional interface. This USE flag is only needed with GCC
+ earlier than version 4.1, or with other compilares not providing
+ said interface.
+ </flag>
+ </use>
+</pkgmetadata>
diff --git a/net-libs/wvstreams/wvstreams-4.6.1-r2.ebuild b/net-libs/wvstreams/wvstreams-4.6.1-r2.ebuild
new file mode 100644
index 000000000000..a462106b74a1
--- /dev/null
+++ b/net-libs/wvstreams/wvstreams-4.6.1-r2.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools eutils flag-o-matic toolchain-funcs versionator
+
+DESCRIPTION="A network programming library in C++"
+HOMEPAGE="http://alumnit.ca/wiki/?WvStreams"
+SRC_URI="http://wvstreams.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ppc sparc x86"
+IUSE="pam doc +ssl +dbus debug"
+
+#Tests fail if openssl is not compiled with -DPURIFY. Gentoo's isn't. FAIL!
+RESTRICT="test"
+
+#QA Fail: xplc is compiled as a part of wvstreams.
+#It'll take a larger patching effort to get it extracted, since upstream integrated it
+#more tightly this time. Probably for the better since upstream xplc seems dead.
+
+RDEPEND="sys-libs/readline
+ sys-libs/zlib
+ dbus? ( >=sys-apps/dbus-1.4.20 )
+ dev-libs/openssl:0
+ pam? ( sys-libs/pam )"
+DEPEND="${RDEPEND}
+ || ( >=sys-devel/gcc-4.1 >=dev-libs/boost-1.34.0 )
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+DOCS="ChangeLog README*"
+
+pkg_setup() {
+ if has_version '>=sys-devel/gcc-4.1' && ! has_version '>=dev-libs/boost-1.34.1'
+ then
+ if ! version_is_at_least 4.1 "$(gcc-fullversion)"
+ then
+ eerror "This package requires the active gcc to be at least version 4.1"
+ eerror "or >=dev-libs/boost-1.34.1 must be installed."
+ die "Please activate >=sys-devel/gcc-4.1 with gcc-config."
+ fi
+ fi
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-parallel-make.patch \
+ "${FILESDIR}"/${P}-openssl-1.0.0.patch \
+ "${FILESDIR}"/${P}-glibc212.patch \
+ "${FILESDIR}"/${P}-gcc47.patch
+
+ sed -i \
+ -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' \
+ -e 's:AM_PROG_CC_STDC:AC_PROG_CC:' \
+ configure.ac argp/configure.ac || die
+
+ eautoreconf
+ pushd argp >/dev/null
+ eautoreconf
+ popd >/dev/null
+}
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+ append-flags -fno-tree-dce -fno-optimize-sibling-calls #421375
+
+ tc-export CXX
+
+ econf \
+ --localstatedir=/var \
+ $(use_enable debug) \
+ --disable-optimization \
+ $(use_with dbus) \
+ --with-openssl \
+ $(use_with pam) \
+ --without-tcl \
+ --without-qt \
+ --with-zlib \
+ --without-valgrind
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ doxygen || die
+ fi
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ default
+
+ if use doc; then
+ #the list of files is too big for dohtml -r Docs/doxy-html/*
+ cd Docs/doxy-html
+ dohtml -r *
+ fi
+}
diff --git a/net-libs/wvstreams/wvstreams-4.6.1-r3.ebuild b/net-libs/wvstreams/wvstreams-4.6.1-r3.ebuild
new file mode 100644
index 000000000000..0b2b9a966d28
--- /dev/null
+++ b/net-libs/wvstreams/wvstreams-4.6.1-r3.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils flag-o-matic toolchain-funcs versionator
+
+DESCRIPTION="A network programming library in C++"
+HOMEPAGE="http://alumnit.ca/wiki/?WvStreams"
+SRC_URI="http://wvstreams.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ppc sparc x86"
+IUSE="pam doc +ssl +dbus debug boost"
+
+#Tests fail if openssl is not compiled with -DPURIFY. Gentoo's isn't. FAIL!
+RESTRICT="test"
+
+#QA Fail: xplc is compiled as a part of wvstreams.
+#It'll take a larger patching effort to get it extracted, since upstream integrated it
+#more tightly this time. Probably for the better since upstream xplc seems dead.
+
+RDEPEND="sys-libs/readline
+ sys-libs/zlib
+ dbus? ( >=sys-apps/dbus-1.4.20 )
+ dev-libs/openssl:0
+ pam? ( virtual/pam )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ boost? ( >=dev-libs/boost-1.34.1:= )"
+
+DOCS="ChangeLog README*"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} == "binary" ]] && return
+
+ if ! use boost && ! version_is_at_least 4.1 "$(gcc-fullversion)"; then
+ eerror "This package requires the active gcc to be at least version 4.1"
+ eerror "or USE=boost must be installed."
+ die "Please activate >=sys-devel/gcc-4.1 with gcc-config."
+ fi
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-parallel-make.patch \
+ "${FILESDIR}"/${P}-openssl-1.0.0.patch \
+ "${FILESDIR}"/${P}-glibc212.patch \
+ "${FILESDIR}"/${P}-gcc47.patch
+
+ sed -i \
+ -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' \
+ -e 's:AM_PROG_CC_STDC:AC_PROG_CC:' \
+ configure.ac argp/configure.ac || die
+
+ eautoreconf
+ pushd argp >/dev/null
+ eautoreconf
+ popd >/dev/null
+}
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+ append-flags -fno-tree-dce -fno-optimize-sibling-calls #421375
+
+ tc-export AR CXX
+
+ use boost && export ac_cv_header_tr1_functional=no
+
+ econf \
+ --localstatedir=/var \
+ $(use_enable debug) \
+ --disable-optimization \
+ $(use_with dbus) \
+ --with-openssl \
+ $(use_with pam) \
+ --without-tcl \
+ --without-qt \
+ --with-zlib \
+ --without-valgrind
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ doxygen || die
+ fi
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ default
+
+ if use doc; then
+ #the list of files is too big for dohtml -r Docs/doxy-html/*
+ cd Docs/doxy-html
+ dohtml -r *
+ fi
+}