summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-05-24 09:55:41 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-05-24 09:59:50 +0200
commit0c6adb3529b53c76ad34bc2a5cd4257c0a2b8ce1 (patch)
treef9a1f50e0babc9875886e89bab81cb87f9a3f408 /net-libs
parentdev-libs/libfilezilla: Removed old. (diff)
downloadgentoo-0c6adb3529b53c76ad34bc2a5cd4257c0a2b8ce1.tar.gz
gentoo-0c6adb3529b53c76ad34bc2a5cd4257c0a2b8ce1.tar.bz2
gentoo-0c6adb3529b53c76ad34bc2a5cd4257c0a2b8ce1.zip
net-libs/gsoap: Bump to version 2.8.32
Package-Manager: portage-2.2.28 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gsoap/Manifest1
-rw-r--r--net-libs/gsoap/gsoap-2.8.32.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/net-libs/gsoap/Manifest b/net-libs/gsoap/Manifest
index 0499f6e511ef..1f4c45210548 100644
--- a/net-libs/gsoap/Manifest
+++ b/net-libs/gsoap/Manifest
@@ -5,3 +5,4 @@ DIST gsoap_2.8.28.zip 23729531 SHA256 453b36d97a98b35c2829284219dd09a4d60f073a5b
DIST gsoap_2.8.29.zip 24006374 SHA256 a9dacc4f862892df6cf9119d1c5d627af3a864c17f17b6542c560e72070b1381 SHA512 ce79cf52210e8ce34b39dc25931dbdc36bdd770ac01e70583e1e4a2f1006f20d259dd57d02a1baf2f937016c63837b9a9befca3d71f992f7a798a55de70a8c61 WHIRLPOOL a5c884b7c7e9144d293674d4977edbe8fda780003cca554acd08db5aade0f09702b294d69bb67f26f668d3a6f195791f9f6483d4a94df83f09ab79bc8985fb08
DIST gsoap_2.8.30.zip 24060216 SHA256 edd20799656471d330033d6d945e684f988b4e79e009fab6c258c83c07ce2b42 SHA512 a4dfb1b5d1021ef2d37a23fedef21135e019ad4fb8ab6bce2d27e159a2bf71aa1660065300f0c790766bccfa630f3b132bb6142aad9104bb1718a9a92e403e19 WHIRLPOOL 41660292d7e05835c87ee46a90dab1223dbaf931574310223099d5c25bc27f91a345f43a4d05cd36212bc558b70f56d1c052833a59d3c8a1133cbfd50550368e
DIST gsoap_2.8.31.zip 24083228 SHA256 ca786022130dc6bb33ef7e94913e911e8867a67f4712977cd4ee34e3c9e5e9ca SHA512 607e557ccc488f1dfb5d533078528032530fb01ecdfd489b856110a145bb655f7718797fbca59ab839bb1b7e31319a4682ebdcf723c6b3c7211e4a8b6ecbe21d WHIRLPOOL e9c99d73f8a9357d73a07fc4bc4b17171b30868723547e7d53a1cb6361f3ccfcd1a793a1803b9236008d57c83f508b4cdc5d684c73cb607d61507c851290076d
+DIST gsoap_2.8.32.zip 24099759 SHA256 fb1d91c6b99da7981f44aeb848b54697d067b0d8905bc09b3e4d05bcf6fa3a02 SHA512 81d51a3fcc60c1b20c3b89b02f26ce51d93a80e094c01c4121a6d5eabd4548be87035a855d4e5f8418a3cf2594df452ca34c27b5b76dc275e0e0725e9df58232 WHIRLPOOL 35e0cd3c61d4dd97dc8cf4418a599755d8334e701fd4b0b42f31f6b7cbfff5de39345f03e775e19e91055f6041d4abb3f38ec54c247acaab26edaf6ff2aca529
diff --git a/net-libs/gsoap/gsoap-2.8.32.ebuild b/net-libs/gsoap/gsoap-2.8.32.ebuild
new file mode 100644
index 000000000000..e8c1c2e6b7c7
--- /dev/null
+++ b/net-libs/gsoap/gsoap-2.8.32.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools eutils
+
+MY_P="${PN}-2.8"
+
+DESCRIPTION="A cross-platform open source C and C++ SDK for SOAP/XML Web services"
+HOMEPAGE="http://gsoap2.sourceforge.net"
+SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.zip"
+
+LICENSE="GPL-2 gSOAP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug examples ipv6 libressl gnutls +ssl"
+
+RDEPEND="
+ sys-libs/zlib
+ gnutls? ( net-libs/gnutls )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl )
+ )
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ sys-devel/flex
+ sys-devel/bison
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+
+ # Fix Pre-ISO headers
+ eapply "${FILESDIR}/${PN}-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=()
+ use ssl || myconf+=( --disable-ssl )
+ use gnutls && myconf+=( --enable-gnutls )
+ use ipv6 && myconf+=( --enable-ipv6 )
+ econf \
+ ${myconf[@]} \
+ $(use_enable debug) \
+ $(use_enable examples samples)
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # yes, we also install the license-file since
+ # it contains info about how to apply the licenses
+ dodoc *.txt
+
+ dohtml changelog.md
+
+ prune_libtool_files --all
+
+ if use examples; then
+ rm -rf gsoap/samples/Makefile* gsoap/samples/*/Makefile* gsoap/samples/*/*.o || die
+ insinto /usr/share/doc/${PF}/examples
+ doins -r gsoap/samples/*
+ fi
+
+ if use doc; then
+ dohtml -r gsoap/doc/*
+ fi
+}