summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2017-02-13 15:26:46 -0500
committerMike Frysinger <vapier@gentoo.org>2017-02-13 15:27:32 -0500
commit180385176a0d090749aa60a607082f0620716fb5 (patch)
tree8f317fcb3ff4ea506df1bd722145915f9abbb623 /net-libs
parentsys-fs/lvm2: Add sanlock USE flag for lvmlockd, fixes #604334 (diff)
downloadgentoo-180385176a0d090749aa60a607082f0620716fb5.tar.gz
gentoo-180385176a0d090749aa60a607082f0620716fb5.tar.bz2
gentoo-180385176a0d090749aa60a607082f0620716fb5.zip
net-libs/libupnp: drop unused patches
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libupnp/files/CVE-2016-6255.patch65
-rw-r--r--net-libs/libupnp/files/libupnp-1.6.18-suse.patch132
-rw-r--r--net-libs/libupnp/files/libupnp-1.6.19-suse.patch132
3 files changed, 0 insertions, 329 deletions
diff --git a/net-libs/libupnp/files/CVE-2016-6255.patch b/net-libs/libupnp/files/CVE-2016-6255.patch
deleted file mode 100644
index 1448ab308128..000000000000
--- a/net-libs/libupnp/files/CVE-2016-6255.patch
+++ /dev/null
@@ -1,65 +0,0 @@
-From be0a01bdb83395d9f3a5ea09c1308a4f1a972cbd Mon Sep 17 00:00:00 2001
-From: Matthew Garrett <mjg59@srcf.ucam.org>
-Date: Tue, 23 Feb 2016 13:53:20 -0800
-Subject: [PATCH] Don't allow unhandled POSTs to write to the filesystem by
- default
-
-If there's no registered handler for a POST request, the default behaviour
-is to write it to the filesystem. Several million deployed devices appear
-to have this behaviour, making it possible to (at least) store arbitrary
-data on them. Add a configure option that enables this behaviour, and change
-the default to just drop POSTs that aren't directly handled.
----
- configure.ac | 4 ++++
- upnp/inc/upnpconfig.h.in | 5 +++++
- upnp/src/genlib/net/http/webserver.c | 4 ++++
- 3 files changed, 13 insertions(+)
-
-diff --git a/configure.ac b/configure.ac
-index dd88734..ea2bc09 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -482,6 +482,10 @@ if test "x$enable_scriptsupport" = xyes ; then
- AC_DEFINE(IXML_HAVE_SCRIPTSUPPORT, 1, [see upnpconfig.h])
- fi
-
-+RT_BOOL_ARG_ENABLE([postwrite], [no], [write to the filesystem on otherwise unhandled POST requests])
-+if test "x$enable_postwrite" = xyes ; then
-+ AC_DEFINE(UPNP_ENABLE_POST_WRITE, 1, [see upnpconfig.h])
-+fi
-
- RT_BOOL_ARG_ENABLE([samples], [yes], [compilation of upnp/sample/ code])
-
-diff --git a/upnp/inc/upnpconfig.h.in b/upnp/inc/upnpconfig.h.in
-index 46ddc6e..5df8c5a 100644
---- a/upnp/inc/upnpconfig.h.in
-+++ b/upnp/inc/upnpconfig.h.in
-@@ -135,5 +135,10 @@
- * (i.e. configure --enable-open_ssl) */
- #undef UPNP_ENABLE_OPEN_SSL
-
-+/** Defined to 1 if the library has been compiled to support filesystem writes on POST
-+ * (i.e. configure --enable-postwrite) */
-+#undef UPNP_ENABLE_POST_WRITE
-+
-+
- #endif /* UPNP_CONFIG_H */
-
-diff --git a/upnp/src/genlib/net/http/webserver.c b/upnp/src/genlib/net/http/webserver.c
-index 8991c16..8b2ecf2 100644
---- a/upnp/src/genlib/net/http/webserver.c
-+++ b/upnp/src/genlib/net/http/webserver.c
-@@ -1369,9 +1369,13 @@ static int http_RecvPostMessage(
- if (Fp == NULL)
- return HTTP_INTERNAL_SERVER_ERROR;
- } else {
-+#ifdef UPNP_ENABLE_POST_WRITE
- Fp = fopen(filename, "wb");
- if (Fp == NULL)
- return HTTP_UNAUTHORIZED;
-+#else
-+ return HTTP_NOT_FOUND;
-+#endif
- }
- parser->position = POS_ENTITY;
- do {
diff --git a/net-libs/libupnp/files/libupnp-1.6.18-suse.patch b/net-libs/libupnp/files/libupnp-1.6.18-suse.patch
deleted file mode 100644
index 2e91990c0243..000000000000
--- a/net-libs/libupnp/files/libupnp-1.6.18-suse.patch
+++ /dev/null
@@ -1,132 +0,0 @@
---- configure.ac 2013-01-29 16:39:56.000000000 +0100
-+++ configure.ac 2013-02-17 10:40:53.680021913 +0100
-@@ -7,9 +7,9 @@
- # (C) Copyright 2005-2007 Rémi Turboult <r3mi@users.sourceforge.net>
- #
-
--AC_PREREQ(2.60)
-+AC_PREREQ([2.60])
-
--AC_INIT([libupnp], [1.6.18], [mroberto@users.sourceforge.net])
-+AC_INIT([libupnp],[1.6.18],[mroberto@users.sourceforge.net])
- dnl ############################################################################
- dnl # *Independently* of the above libupnp package version, the libtool version
- dnl # of the 3 libraries need to be updated whenever there is a change released:
-@@ -366,7 +366,6 @@
- # installed libraries.
- #
- AC_CONFIG_HEADERS([autoconfig.h upnp/inc/upnpconfig.h])
--#AC_SYS_LARGEFILE_SENSITIVE
-
- AC_REVISION([$Revision: 1.1 $])
-
-@@ -506,9 +505,12 @@
- #
- # Checks for programs
- #
--AC_PROG_CC
-+AC_PROG_CC_STDC
-+AC_USE_SYSTEM_EXTENSIONS
-+AC_SYS_LARGEFILE
- AM_PROG_CC_C_O
--AC_PROG_LIBTOOL
-+m4_ifdef([AM_PROG_AR], [AM_PROG_AR])
-+LT_INIT
- AC_PROG_INSTALL
- AC_PROG_MAKE_SET
- AC_PROG_EGREP
-@@ -532,9 +534,7 @@
- #:
- # Use -O0 in debug so that variables do not get optimized out
- AX_CFLAGS_GCC_OPTION([-O0, -g])
-- else
-- # add optimise for size
-- AX_CFLAGS_GCC_OPTION([-Os])
-+
- fi
- ;;
- esac
-@@ -548,8 +548,7 @@
- #
- AC_TYPE_SIZE_T
- AC_TYPE_OFF_T
--AC_DEFINE([_LARGE_FILE_SOURCE], [], [Large files support])
--AC_DEFINE([_FILE_OFFSET_BITS], [64], [File Offset size])
-+
-
-
- #
---- ixml/Makefile.am.orig
-+++ ixml/Makefile.am
-@@ -7,7 +7,7 @@
-
- SUBDIRS = doc
-
--AM_CPPFLAGS = -I$(srcdir)/inc -I$(srcdir)/src/inc
-+AM_CPPFLAGS = -include $(top_builddir)/autoconfig.h -I$(srcdir)/inc -I$(srcdir)/src/inc
- AM_CFLAGS =
-
- LDADD = libixml.la
---- threadutil/Makefile.am.orig
-+++ threadutil/Makefile.am
-@@ -4,7 +4,7 @@
- # (C) Copyright 2005 Remi Turboult <r3mi@users.sourceforge.net>
- #
-
--AM_CPPFLAGS = -I$(srcdir)/inc -I$(srcdir)/src/inc
-+AM_CPPFLAGS = -include $(top_builddir)/autoconfig.h -I$(srcdir)/inc -I$(srcdir)/src/inc
-
- if ENABLE_DEBUG
- AM_CPPFLAGS += -DDEBUG -DSTATS
---- upnp/src/api/UpnpString.c.orig
-+++ upnp/src/api/UpnpString.c
-@@ -28,38 +28,6 @@
- /* Other systems have strncasecmp */
- #endif
-
--#ifndef UPNP_USE_MSVCPP
-- /* VC has strnlen which is already included but with (potentially) different linkage */
-- /* strnlen() is a GNU extension. */
-- #if HAVE_STRNLEN
-- extern size_t strnlen(const char *s, size_t maxlen);
-- #else /* HAVE_STRNLEN */
-- static size_t strnlen(const char *s, size_t n)
-- {
-- const char *p = (const char *)memchr(s, 0, n);
-- return p ? p - s : n;
-- }
-- #endif /* HAVE_STRNLEN */
--#endif /* WIN32 */
--
--/* strndup() is a GNU extension. */
--#if HAVE_STRNDUP && !defined(WIN32)
-- extern char *strndup(__const char *__string, size_t __n);
--#else /* HAVE_STRNDUP && !defined(WIN32) */
-- static char *strndup(const char *__string, size_t __n)
-- {
-- size_t strsize = strnlen(__string, __n);
-- char *newstr = (char *)malloc(strsize + 1);
-- if (newstr == NULL)
-- return NULL;
--
-- strncpy(newstr, __string, strsize);
-- newstr[strsize] = 0;
--
-- return newstr;
-- }
--#endif /* HAVE_STRNDUP && !defined(WIN32) */
--
- /*!
- * \brief Internal implementation of the class UpnpString.
- *
---- upnp/Makefile.am.orig
-+++ upnp/Makefile.am
-@@ -6,7 +6,7 @@
-
- SUBDIRS = doc . sample
-
--AM_CPPFLAGS = \
-+AM_CPPFLAGS = -include $(top_builddir)/autoconfig.h \
- -I$(srcdir)/inc \
- -I$(top_srcdir)/threadutil/inc \
- -I$(top_srcdir)/ixml/inc
diff --git a/net-libs/libupnp/files/libupnp-1.6.19-suse.patch b/net-libs/libupnp/files/libupnp-1.6.19-suse.patch
deleted file mode 100644
index 75a7f0dac75c..000000000000
--- a/net-libs/libupnp/files/libupnp-1.6.19-suse.patch
+++ /dev/null
@@ -1,132 +0,0 @@
---- configure.ac 2013-01-29 16:39:56.000000000 +0100
-+++ configure.ac 2013-02-17 10:40:53.680021913 +0100
-@@ -7,9 +7,9 @@
- # (C) Copyright 2005-2007 Rémi Turboult <r3mi@users.sourceforge.net>
- #
-
--AC_PREREQ(2.60)
-+AC_PREREQ([2.60])
-
--AC_INIT([libupnp], [1.6.19], [mroberto@users.sourceforge.net])
-+AC_INIT([libupnp],[1.6.19],[mroberto@users.sourceforge.net])
- dnl ############################################################################
- dnl # *Independently* of the above libupnp package version, the libtool version
- dnl # of the 3 libraries need to be updated whenever there is a change released:
-@@ -366,7 +366,6 @@
- # installed libraries.
- #
- AC_CONFIG_HEADERS([autoconfig.h upnp/inc/upnpconfig.h])
--#AC_SYS_LARGEFILE_SENSITIVE
-
- AC_REVISION([$Revision: 1.1 $])
-
-@@ -519,10 +519,12 @@
- #
- # Checks for programs
- #
--AC_PROG_CC
-+AC_PROG_CC_STDC
-+AC_USE_SYSTEM_EXTENSIONS
-+AC_SYS_LARGEFILE
- AM_PROG_CC_C_O
- m4_ifdef([AM_PROG_AR], [AM_PROG_AR])
--AC_PROG_LIBTOOL
-+LT_INIT
- AC_PROG_INSTALL
- AC_PROG_MAKE_SET
- AC_PROG_EGREP
-@@ -532,9 +534,7 @@
- #:
- # Use -O0 in debug so that variables do not get optimized out
- AX_CFLAGS_GCC_OPTION([-O0, -g])
-- else
-- # add optimise for size
-- AX_CFLAGS_GCC_OPTION([-Os])
-+
- fi
- ;;
- esac
-@@ -548,8 +548,7 @@
- #
- AC_TYPE_SIZE_T
- AC_TYPE_OFF_T
--AC_DEFINE([_LARGE_FILE_SOURCE], [], [Large files support])
--AC_DEFINE([_FILE_OFFSET_BITS], [64], [File Offset size])
-+
-
-
- #
---- ixml/Makefile.am.orig
-+++ ixml/Makefile.am
-@@ -7,7 +7,7 @@
-
- SUBDIRS = doc
-
--AM_CPPFLAGS = -I$(srcdir)/inc -I$(srcdir)/src/inc
-+AM_CPPFLAGS = -include $(top_builddir)/autoconfig.h -I$(srcdir)/inc -I$(srcdir)/src/inc
- AM_CFLAGS =
-
- LDADD = libixml.la
---- threadutil/Makefile.am.orig
-+++ threadutil/Makefile.am
-@@ -4,7 +4,7 @@
- # (C) Copyright 2005 Remi Turboult <r3mi@users.sourceforge.net>
- #
-
--AM_CPPFLAGS = -I$(srcdir)/inc -I$(srcdir)/src/inc
-+AM_CPPFLAGS = -include $(top_builddir)/autoconfig.h -I$(srcdir)/inc -I$(srcdir)/src/inc
-
- if ENABLE_DEBUG
- AM_CPPFLAGS += -DDEBUG -DSTATS
---- upnp/src/api/UpnpString.c.orig
-+++ upnp/src/api/UpnpString.c
-@@ -28,38 +28,6 @@
- /* Other systems have strncasecmp */
- #endif
-
--#ifndef UPNP_USE_MSVCPP
-- /* VC has strnlen which is already included but with (potentially) different linkage */
-- /* strnlen() is a GNU extension. */
-- #if HAVE_STRNLEN
-- extern size_t strnlen(const char *s, size_t maxlen);
-- #else /* HAVE_STRNLEN */
-- static size_t strnlen(const char *s, size_t n)
-- {
-- const char *p = (const char *)memchr(s, 0, n);
-- return p ? p - s : n;
-- }
-- #endif /* HAVE_STRNLEN */
--#endif /* WIN32 */
--
--/* strndup() is a GNU extension. */
--#if HAVE_STRNDUP && !defined(WIN32)
-- extern char *strndup(__const char *__string, size_t __n);
--#else /* HAVE_STRNDUP && !defined(WIN32) */
-- static char *strndup(const char *__string, size_t __n)
-- {
-- size_t strsize = strnlen(__string, __n);
-- char *newstr = (char *)malloc(strsize + 1);
-- if (newstr == NULL)
-- return NULL;
--
-- strncpy(newstr, __string, strsize);
-- newstr[strsize] = 0;
--
-- return newstr;
-- }
--#endif /* HAVE_STRNDUP && !defined(WIN32) */
--
- /*!
- * \brief Internal implementation of the class UpnpString.
- *
---- upnp/Makefile.am.orig
-+++ upnp/Makefile.am
-@@ -6,7 +6,7 @@
-
- SUBDIRS = doc . sample
-
--AM_CPPFLAGS = \
-+AM_CPPFLAGS = -include $(top_builddir)/autoconfig.h \
- -I$(srcdir)/inc \
- -I$(top_srcdir)/threadutil/inc \
- -I$(top_srcdir)/ixml/inc