summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-04-15 12:01:05 +0200
committerJeroen Roovers <jer@gentoo.org>2019-04-15 12:02:35 +0200
commit41b8b24cdbb2ce84fb60e262b4bfd843f1f0ca98 (patch)
treee57f7918a5663613b341721dd1cfdf697c3e7f88 /net-libs
parentnet-analyzer/bwping: Use HTTPS (diff)
downloadgentoo-41b8b24cdbb2ce84fb60e262b4bfd843f1f0ca98.tar.gz
gentoo-41b8b24cdbb2ce84fb60e262b4bfd843f1f0ca98.tar.bz2
gentoo-41b8b24cdbb2ce84fb60e262b4bfd843f1f0ca98.zip
net-libs/libprotoident: Version 2.0.13
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libprotoident/Manifest1
-rw-r--r--net-libs/libprotoident/libprotoident-2.0.13.ebuild40
-rw-r--r--net-libs/libprotoident/libprotoident-9999.ebuild6
3 files changed, 44 insertions, 3 deletions
diff --git a/net-libs/libprotoident/Manifest b/net-libs/libprotoident/Manifest
index eeda9ad52f81..b7a5dc11e05e 100644
--- a/net-libs/libprotoident/Manifest
+++ b/net-libs/libprotoident/Manifest
@@ -1 +1,2 @@
DIST libprotoident-2.0.12.tar.gz 571466 BLAKE2B 604dee2d33f7944615211ee3ab0a3ba610354bd604bcbf5296d58698ab963b5e667ea3e08fc2df62dfdb1e7dc7a336a57be6e61b6f410fdd7a96f3b46c35d70c SHA512 b8ba13ce9286a026062f47ffe3bf9407b408f64fbf0521aeebaf0e39e6ddf70cfbc6574f8e9c0f35fc2c2e5f9c4e71e200536665988f88c65bbdbeb9b7baed16
+DIST libprotoident-2.0.13.tar.gz 592008 BLAKE2B b8e4ecf5fdc1b40881709e9a572148e666f6d1a56c00cca39efd81caba3c3344a57bbc57e0794a92d1ec23bac3c928ac2b06323c1785cb8fc08cb33f55f2195c SHA512 905c97ba3f994d7b63c95ee80bc7b2c2be13b86745d072f5aecb4df88f791c02dcda3f851f01b5cca3cd36ad87379759789238a8c05f3209a5aad3d854e6ff20
diff --git a/net-libs/libprotoident/libprotoident-2.0.13.ebuild b/net-libs/libprotoident/libprotoident-2.0.13.ebuild
new file mode 100644
index 000000000000..8d80ce7cabdc
--- /dev/null
+++ b/net-libs/libprotoident/libprotoident-2.0.13.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A library that performs application layer protocol identification for flows"
+HOMEPAGE="https://research.wand.net.nz/software/libprotoident.php"
+SRC_URI="https://research.wand.net.nz/software/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0/2"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs tools"
+
+DEPEND="
+ >=net-libs/libtrace-4.0.1
+ >=net-libs/libflowmanager-3.0.0
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/-Werror/d' \
+ lib/Makefile{.am,.in} || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with tools)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/net-libs/libprotoident/libprotoident-9999.ebuild b/net-libs/libprotoident/libprotoident-9999.ebuild
index 397ba5fb9253..89b8578c07c5 100644
--- a/net-libs/libprotoident/libprotoident-9999.ebuild
+++ b/net-libs/libprotoident/libprotoident-9999.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit autotools eutils git-r3
+EAPI=7
+inherit autotools git-r3
DESCRIPTION="A library that performs application layer protocol identification for flows"
HOMEPAGE="https://research.wand.net.nz/software/libprotoident.php"
@@ -38,5 +38,5 @@ src_configure() {
src_install() {
default
- prune_libtool_files
+ find "${D}" -name '*.la' -delete || die
}