summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-11-27 16:44:09 -0500
committerMike Frysinger <vapier@gentoo.org>2016-11-27 16:46:08 -0500
commit9c0484d722082e016aebab6b90d7cbedec93857b (patch)
treec146e189654d0e6859d886774c951f1d574d64a8 /net-libs
parentapp-crypt/gnupg: Fix typo in previous commit (diff)
downloadgentoo-9c0484d722082e016aebab6b90d7cbedec93857b.tar.gz
gentoo-9c0484d722082e016aebab6b90d7cbedec93857b.tar.bz2
gentoo-9c0484d722082e016aebab6b90d7cbedec93857b.zip
net-libs/libvncserver: require USE=threads for openssl builds #550916
The libvncclient/tls_openssl.c module hard requires pthread support currently, so update the required USE list to reflect that.
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libvncserver/libvncserver-0.9.10-r3.ebuild1
-rw-r--r--net-libs/libvncserver/libvncserver-0.9.10-r4.ebuild1
-rw-r--r--net-libs/libvncserver/libvncserver-0.9.10_p20160127.ebuild1
3 files changed, 3 insertions, 0 deletions
diff --git a/net-libs/libvncserver/libvncserver-0.9.10-r3.ebuild b/net-libs/libvncserver/libvncserver-0.9.10-r3.ebuild
index 2513920a9de..298b3dff2e2 100644
--- a/net-libs/libvncserver/libvncserver-0.9.10-r3.ebuild
+++ b/net-libs/libvncserver/libvncserver-0.9.10-r3.ebuild
@@ -14,6 +14,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
IUSE="+24bpp gcrypt gnutls ipv6 +jpeg +png ssl static-libs test threads +zlib"
+REQUIRED_USE="!gnutls? ( ssl? ( threads ) )"
DEPEND="
gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )
diff --git a/net-libs/libvncserver/libvncserver-0.9.10-r4.ebuild b/net-libs/libvncserver/libvncserver-0.9.10-r4.ebuild
index fb9059f56fc..c5903de34a7 100644
--- a/net-libs/libvncserver/libvncserver-0.9.10-r4.ebuild
+++ b/net-libs/libvncserver/libvncserver-0.9.10-r4.ebuild
@@ -14,6 +14,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
IUSE="+24bpp gcrypt gnutls ipv6 +jpeg libressl +png ssl static-libs test threads +zlib"
+REQUIRED_USE="!gnutls? ( ssl? ( threads ) )"
DEPEND="
gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )
diff --git a/net-libs/libvncserver/libvncserver-0.9.10_p20160127.ebuild b/net-libs/libvncserver/libvncserver-0.9.10_p20160127.ebuild
index 4190a404e2b..8d83469a337 100644
--- a/net-libs/libvncserver/libvncserver-0.9.10_p20160127.ebuild
+++ b/net-libs/libvncserver/libvncserver-0.9.10_p20160127.ebuild
@@ -14,6 +14,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
IUSE="+24bpp gcrypt gnutls ipv6 +jpeg libressl +png ssl static-libs test threads +zlib"
+REQUIRED_USE="!gnutls? ( ssl? ( threads ) )"
DEPEND="
gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )