summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2019-10-28 13:35:12 -0400
committerAnthony G. Basile <blueness@gentoo.org>2019-10-28 13:35:25 -0400
commitdcfeb165fb214a1eee2692cf247a79f25e1aee2e (patch)
tree555796632b8b7cabb347e1051cc98cfb122229ec /net-libs
parentmedia-libs/gegl: Stop enforcing USE=introspection (diff)
downloadgentoo-dcfeb165fb214a1eee2692cf247a79f25e1aee2e.tar.gz
gentoo-dcfeb165fb214a1eee2692cf247a79f25e1aee2e.tar.bz2
gentoo-dcfeb165fb214a1eee2692cf247a79f25e1aee2e.zip
net-libs/libmicrohttpd: version bump to 0.9.68
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libmicrohttpd/Manifest1
-rw-r--r--net-libs/libmicrohttpd/libmicrohttpd-0.9.68.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/net-libs/libmicrohttpd/Manifest b/net-libs/libmicrohttpd/Manifest
index cd14d94b2c55..487c1a9a9718 100644
--- a/net-libs/libmicrohttpd/Manifest
+++ b/net-libs/libmicrohttpd/Manifest
@@ -3,3 +3,4 @@ DIST libmicrohttpd-0.9.64.tar.gz 1631384 BLAKE2B 15437188f0246ea0270338e45016c34
DIST libmicrohttpd-0.9.65.tar.gz 1633346 BLAKE2B ce6ba2b6c52e30194872c66ab5b9e358f0979dd99ef24ce59fddf9e6fc2b76b01f424f9c9b511cf88c2dde2ca98d3f6a25cbcd26bdfadf0b9db65efd36435dc7 SHA512 751b7a5970cef07f260660254bfdeda4882e9e28d5cbdfbfed50e2c4583caf8f19c96ede6d368babc4223e7fbdf85d85eec37dc96abf333377dc13d6a9c6be12
DIST libmicrohttpd-0.9.66.tar.gz 1877096 BLAKE2B 4788fa63b0438e250264852f291a7661ee64f4116cbe95eec0902a47115721040a9259acb9c3385d833364f9b27695a90a2cedc516a35ee89125e0852d545579 SHA512 59cc56a9511d9d1c05647a57d920a16d0aaa0d0523d0241ceb88641d18bd95fdb3bb5a60fd648ac54a6f4323a673a3145e520a2fe9e124e78973ff6dac3ad89a
DIST libmicrohttpd-0.9.67.tar.gz 1881973 BLAKE2B 640bc99642160adb6728dfa6ea71720e376bd0bca3b86a56424906a563b9ea1ef92d51c509d0e642c8e32f46a9044826ab41f0e5eef88ee971bde9094a961db7 SHA512 2a2a11e9a525024dada639b1622cc875bb9b59af266a53e2742d5bf92f544192713c4e1369a573b2e3796d27cf490a9a02ba360ccc91136b4780306769edb7ec
+DIST libmicrohttpd-0.9.68.tar.gz 1884342 BLAKE2B 3f74c48917fa19753a617242fa07b99a69510a14a802609d038964d927516f8f52b4330d0eee2c7b98096b2d840158e4945310edef290224ea256d9616fb4d94 SHA512 9daaab5fb35fef6f2a19b7e08eeb8473aeb0a67631808a8d7a7f78a09cb621ca5d32dbbbca616865a40afb92f8c6495f9e2ba1674880af8011a2bc798c070a13
diff --git a/net-libs/libmicrohttpd/libmicrohttpd-0.9.68.ebuild b/net-libs/libmicrohttpd/libmicrohttpd-0.9.68.ebuild
new file mode 100644
index 000000000000..6d9443a12376
--- /dev/null
+++ b/net-libs/libmicrohttpd/libmicrohttpd-0.9.68.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit multilib-minimal
+
+MY_P="${P/_/}"
+
+DESCRIPTION="Small C library to run an HTTP server as part of another application"
+HOMEPAGE="https://www.gnu.org/software/libmicrohttpd/"
+SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/12"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+epoll ssl static-libs test"
+
+RDEPEND="ssl? (
+ dev-libs/libgcrypt:0=
+ net-libs/gnutls
+ )"
+
+# We disable tests below because they're broken,
+# but if enabled, we'll need this.
+DEPEND="${RDEPEND}
+ test? (
+ ssl? ( net-misc/curl[ssl] )
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS NEWS README ChangeLog"
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf \
+ --enable-bauth \
+ --enable-dauth \
+ --disable-examples \
+ --enable-messages \
+ --enable-postprocessor \
+ --disable-thread-names \
+ $(use_enable epoll) \
+ $(use_enable test curl) \
+ $(use_enable ssl https) \
+ $(use_with ssl gnutls) \
+ $(use_enable static-libs static)
+}
+
+# tests are broken in the portage environment.
+src_test() {
+ :
+}
+
+multilib_src_install_all() {
+ default
+
+ use static-libs || find "${ED}" -name '*.la' -delete
+}