summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-09-27 17:51:27 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-09-27 19:50:13 +0200
commite035a4bf9fbd9853270a0a665ea80f59009b060d (patch)
treef6912eeaa800080192483d58c62802fe88e7a88f /net-libs
parentpackage.mask: Last rite virtual/python-pmw (diff)
downloadgentoo-e035a4bf9fbd9853270a0a665ea80f59009b060d.tar.gz
gentoo-e035a4bf9fbd9853270a0a665ea80f59009b060d.tar.bz2
gentoo-e035a4bf9fbd9853270a0a665ea80f59009b060d.zip
net-libs/gsoap: bump to v2.8.93
- Use proper autotools magic to address fatal error: soapcpp2_yacc.h: No such file or directory error. - Previous change will ensure that we will respect CFLAGS for soapcpp2. Fixes 6526a590e ("net-libs/gsoap: Fixed parallel make issue.") Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gsoap/Manifest1
-rw-r--r--net-libs/gsoap/files/gsoap-2.8.93-fix-parallel-build.patch17
-rw-r--r--net-libs/gsoap/gsoap-2.8.93.ebuild86
3 files changed, 104 insertions, 0 deletions
diff --git a/net-libs/gsoap/Manifest b/net-libs/gsoap/Manifest
index 3f72da213d78..8d59309406b2 100644
--- a/net-libs/gsoap/Manifest
+++ b/net-libs/gsoap/Manifest
@@ -1,3 +1,4 @@
DIST gsoap_2.8.84.zip 32538551 BLAKE2B cab2b75ac931ee6063af47975665f45514cb94f5514fb1f76d17ccb2e71d64d4ebd43543cc004ff7f5c49982975ebaa38e555e3bc45dbc370aae991bc7639273 SHA512 ec050119cd3e480b266cad36823f4862fe0ac21045ce901c3c91a552eae2fbf9e1cd515458835807cce54c04df7835a980a299d37f418190cd57684fd6bdcf79
DIST gsoap_2.8.87.zip 32545316 BLAKE2B c2d0f9fafdfa9de83ea35f8dfc88e23d9d80967a2e58c30d554d539fd93056d7a8eb00ea9c928c6cf786e4888eb9f942ba4574e343de0c0104fce8b270494d6a SHA512 638bf9b2b8aca5facba518f136ad5af5bda41f2b92ee345ee6989d73223a571ce5ddab23c0b65259e9fd524039250d861defc8cfc2fc0a366a578ce3629b9ca4
DIST gsoap_2.8.91.zip 32553307 BLAKE2B 463c2d9c2d56c2a09fa8c9ebea7fa8059ed050cff81780b04a1a47ee1f016e385e6eb338ca740a40cd0c9483b4e10cf0963d02c52d6020863ce015e2f9cf2024 SHA512 ed99f1a20fd95edc7f24cf55454ee057b8c88d2e5b5b153b61c44c57bf4d92fb65ed557e9cb9ea89e3fa8939689c0e30791cebdb91b837482ec8ec13ae281abc
+DIST gsoap_2.8.93.zip 32559296 BLAKE2B 1c27a2d99eb529715f775392a6aeed803ef03f9b703caca49e56e7b4eeb6c9bf7b801d9853fb4009ab61ec138da1c23d54dc33c2f604d73f8134121a5ea2e975 SHA512 45965d04e1c46e06803467887f62d9bea5909fa2d4c4d9ffc935f9fced014efed9169a0171a555067c89ef47b2def9983b277eecee18eb9e70d7198bc72b1ece
diff --git a/net-libs/gsoap/files/gsoap-2.8.93-fix-parallel-build.patch b/net-libs/gsoap/files/gsoap-2.8.93-fix-parallel-build.patch
new file mode 100644
index 000000000000..27e2a94d14e5
--- /dev/null
+++ b/net-libs/gsoap/files/gsoap-2.8.93-fix-parallel-build.patch
@@ -0,0 +1,17 @@
+--- a/gsoap/src/Makefile.am
++++ b/gsoap/src/Makefile.am
+@@ -10,11 +10,13 @@ AUTOMAKE_OPTIONS = foreign 1.4
+ AM_YFLAGS=-d -v
+ AM_LFLAGS=$(LEX_FLAGS)
+
++BUILT_SOURCES = soapcpp2_yacc.h
++
+ bin_PROGRAMS=soapcpp2
+
+ soapcpp2_CFLAGS=$(BISON_DEFINE) $(LEX_DEFINE) $(C_DEBUG_FLAGS) $(SOAPCPP2_IMPORTPATH) -D$(platform)
+ soapcpp2_LDADD=$(YACC_LIB) $(LEXLIB)
+-soapcpp2_SOURCES= soapcpp2_yacc.y soapcpp2_yacc.h soapcpp2_lex.l symbol2.c error2.c init2.c soapcpp2.c
++soapcpp2_SOURCES= soapcpp2_yacc.y soapcpp2_lex.l symbol2.c error2.c init2.c soapcpp2.c
+
+ CLEANFILES= *~ soapcpp2_lex.c soapcpp2_yacc.c soapcpp2_yacc.h soapcpp2_yacc.output
+
diff --git a/net-libs/gsoap/gsoap-2.8.93.ebuild b/net-libs/gsoap/gsoap-2.8.93.ebuild
new file mode 100644
index 000000000000..3dd945fab441
--- /dev/null
+++ b/net-libs/gsoap/gsoap-2.8.93.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_P="${PN}-2.8"
+
+DESCRIPTION="A cross-platform open source C and C++ SDK for SOAP/XML Web services"
+HOMEPAGE="http://gsoap2.sourceforge.net"
+SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.zip"
+
+LICENSE="GPL-2 gSOAP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug examples ipv6 libressl gnutls +ssl"
+
+RDEPEND="
+ sys-libs/zlib
+ gnutls? ( net-libs/gnutls )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl )
+ )
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ sys-devel/flex
+ sys-devel/bison
+"
+
+PATCHES=(
+ # Fix Pre-ISO headers
+ "${FILESDIR}/${PN}-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch"
+
+ # enable shared libs https://bugs.gentoo.org/583398
+ "${FILESDIR}/${PN}-2.8.91-shared_libs.patch"
+
+ # Fix parallel make
+ "${FILESDIR}/${PN}-2.8.93-fix-parallel-build.patch"
+)
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ # Don't include xlocale.h as it got removed in >=glibc-2.26
+ --disable-xlocale
+ $(use_enable debug)
+ $(use_enable examples samples)
+ $(usex gnutls --enable-gnutls '')
+ $(usex ipv6 --enable-ipv6 '')
+ $(usex ssl '' --disable-ssl)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # yes, we also install the license-file since
+ # it contains info about how to apply the licenses
+ dodoc *.txt
+
+ docinto html
+ dodoc changelog.md
+
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+
+ if use examples; then
+ rm -r gsoap/samples/Makefile* gsoap/samples/*/Makefile* gsoap/samples/*/*.o || die
+ insinto /usr/share/doc/${PF}/examples
+ doins -r gsoap/samples/*
+ fi
+
+ if use doc; then
+ docinto html
+ dodoc -r gsoap/doc/*
+ fi
+}