summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2017-04-21 00:18:11 +0800
committerJason Zaman <perfinion@gentoo.org>2017-04-21 00:34:41 +0800
commitdca31d976cb37c0644328582e8decf44c76246ca (patch)
tree9dc498778d1d75199958472c01743c4b995f5e59 /net-mail/offlineimap
parentx11-themes/elementary-xfce-icon-theme: bump to 0.8 (diff)
downloadgentoo-dca31d976cb37c0644328582e8decf44c76246ca.tar.gz
gentoo-dca31d976cb37c0644328582e8decf44c76246ca.tar.bz2
gentoo-dca31d976cb37c0644328582e8decf44c76246ca.zip
net-mail/offlineimap: bump to 7.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'net-mail/offlineimap')
-rw-r--r--net-mail/offlineimap/Manifest1
-rw-r--r--net-mail/offlineimap/offlineimap-7.1.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/net-mail/offlineimap/Manifest b/net-mail/offlineimap/Manifest
index 6b9a43bd72ad..bf2f997d5dd0 100644
--- a/net-mail/offlineimap/Manifest
+++ b/net-mail/offlineimap/Manifest
@@ -1,3 +1,4 @@
DIST offlineimap-6.5.6.tar.gz 187801 SHA256 650fa588bdf86624575a5196fa12e9059b74673a51593718d058365230189abd SHA512 3f7cb63d00486de2d648aa9dd3637ce252dd100bc8237742d11f749726b2b14907c07c802ba0fd5891c88f5062f9a2d05ebc78ceee8c30981f4c4579c3143d6e WHIRLPOOL 0ca66a196683555c5a9e193ccb0a84a8104b2a7715a3839f364d77d1376637a4938b39fa7e9a47f925cde2516a4b0ace94d9e4f9d62dcff50501510c834cb023
DIST offlineimap-6.7.0.3.tar.gz 679221 SHA256 0b7cd43501d1a65fb5e7e4f3a5d0a61f61435ec6b3a7385cc146e924eb6b03ed SHA512 21800eb14e814fa04b983e9718a5780deda4c99ae55ef900ccec9f1e65f9bb783c3469e00e6595c7dfddb60d760a6b3c98ae979da3219de51c8ae107ff1c077a WHIRLPOOL d8983260f309f427abcab65bc539bf8ff7ab38168643a863cc3d7e10a85dc864e4a6a11511a1cba32d2eb74833714f9b3f499b7d14d28800174c58816d59608c
DIST offlineimap-7.0.14.tar.gz 698081 SHA256 19494ecad4d7234ac69480abb7462d0cdcfcec444b55f5381651057d9fdfad44 SHA512 05d5ee81e5b0483038ad3bf8ba27f7b57423a75a3456df192c0c8b7926d7252424ef8f357f99dee2fa2f2590341e9f95d225ee2ad7d01af3466fb9d5488541f9 WHIRLPOOL a791cb67f1e51197fce9005ffbbbbdb8f4ee986d78a7ba46feff6aed6b50e17c5e57a9fa03bba9db0f90325b92c23b9d76071d460f6fec60fa878616cfc6544a
+DIST offlineimap-7.1.0.tar.gz 698600 SHA256 dc998d1032f0e4f944cae0e584a146b70ea732422fc52c909eebe6e8f95b1ae4 SHA512 9e9d5ea2b58dc212c9b69adb701fb4cd1ac1a7c8af90623dcfba3115ee7e1f63cc8569c352bae8f1fe09eb8c9255c39d0bf947dfb5d683ee4b03c0c822cb192d WHIRLPOOL dbf33188c790b43e4b7756a1be6c1c7950bb192e079ba729a8ec159fb3d07a505e5892dc08b2cf8b7b55e2d3dc998f74354339e1c8ed6d3a0e190a5e904bbfdc
diff --git a/net-mail/offlineimap/offlineimap-7.1.0.ebuild b/net-mail/offlineimap/offlineimap-7.1.0.ebuild
new file mode 100644
index 000000000000..c38b4b231571
--- /dev/null
+++ b/net-mail/offlineimap/offlineimap-7.1.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# Normally you need only one version of this.
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python{2_7,3_4} )
+PYTHON_REQ_USE="threads,sqlite,ssl?"
+
+inherit distutils-r1
+
+DESCRIPTION="Powerful IMAP/Maildir synchronization and reader support"
+HOMEPAGE="http://offlineimap.org"
+SRC_URI="https://github.com/OfflineIMAP/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc ssl"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="doc? ( app-text/asciidoc )"
+
+# see http://pogma.com/2009/09/09/snow-leopard-and-offlineimap/ and bug 284925
+PATCHES=(
+ "${FILESDIR}/${PN}-7.0.3-darwin10.patch"
+)
+
+src_compile() {
+ distutils-r1_src_compile
+ use doc && emake -C docs man
+}
+
+src_install() {
+ distutils-r1_src_install
+ dodoc offlineimap.conf offlineimap.conf.minimal
+ use doc && doman docs/{offlineimap.1,offlineimapui.7}
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "You will need to configure offlineimap by creating ~/.offlineimaprc"
+ elog "Sample configurations are in /usr/share/doc/${PF}/"
+ elog ""
+ elog "If you connect via ssl/tls and don't use CA cert checking, it will"
+ elog "display the server's cert fingerprint and require you to add it to the"
+ elog "configuration file to be sure it connects to the same server every"
+ elog "time. This serves to help fixing CVE-2010-4532 (offlineimap doesn't"
+ elog "check SSL server certificate) in cases where you have no CA cert."
+ fi
+}