summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-08-25 17:17:28 -0400
committerTim Harder <radhermit@gentoo.org>2016-08-25 17:33:22 -0400
commit36027b01b40bab74a224e9a55a35fd869494e1b9 (patch)
tree739d2022f53f64be94277220b678bf4fed27b4dc /net-mail
parentapp-text/duali, app-dicts/duali-data: new revisions with EAPI=6. (diff)
downloadgentoo-36027b01b40bab74a224e9a55a35fd869494e1b9.tar.gz
gentoo-36027b01b40bab74a224e9a55a35fd869494e1b9.tar.bz2
gentoo-36027b01b40bab74a224e9a55a35fd869494e1b9.zip
net-mail/offlineimap: version bump to 7.0.6
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/offlineimap/Manifest1
-rw-r--r--net-mail/offlineimap/offlineimap-7.0.6.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/net-mail/offlineimap/Manifest b/net-mail/offlineimap/Manifest
index b0e828d3e439..e95bec4795c0 100644
--- a/net-mail/offlineimap/Manifest
+++ b/net-mail/offlineimap/Manifest
@@ -4,3 +4,4 @@ DIST offlineimap-6.7.0.3.tar.gz 679221 SHA256 0b7cd43501d1a65fb5e7e4f3a5d0a61f61
DIST offlineimap-7.0.3.tar.gz 688967 SHA256 db002ba68ac5ce9336487741d9828e33dd435ee33dc5009ae91c3586d1b4507e SHA512 5ebb0411810b617f7b878df147d10bedf1a9d928645f8080f6d81683f621f503bda3ecc50dbaa86fe0d8b500e355236eebced3833313abb694b0593e626be330 WHIRLPOOL 3e4b3b42f732771e5b1d680dac12a49e2dac2c0e45174e3b40fef961f8917280d76612a048121a7f379edb014f553966f6b40df362a65a93dcf2f752666b8ca3
DIST offlineimap-7.0.4.tar.gz 689027 SHA256 3f848027a5b9865061f9ff56bc8a0ee6d7370f53fe5bb5a76e3e9220fea63ebc SHA512 29b22d5cf8deea937c6eb461b9a7e8211792e761374407ae6a17eb53a6a9a0f8ce6e43b84b90470802112389b50018cd6ee8ca85f7e0b3744720707e35a9119b WHIRLPOOL 3aa9a4e401e6851d806bff9a8a95f5bd37ce1ab16ccb5b9baa0ec2eefdb559489203927b5e3de6ad010b54c3ab6785662c979287cd706f7f05ec989ab6c8eaaf
DIST offlineimap-7.0.5.tar.gz 689611 SHA256 76668c032d3e1c845addaf99b7f4dc61bbb2e06038a85322347d46d2233e9517 SHA512 f489468266455346f9bce30796b4fb270a61caf66dada22b21e5408b9207e41ae437e271a808662fe0105e30d670273c5f102b51c2b5b497665dc0ab3601e386 WHIRLPOOL e0bf449497810ed6035d5f3ad5d32db7f7d18f71d95af242895007d41bf2670ed85941bbd97357302039f5df2459e005806d3bff798f24ab61f75668416f2901
+DIST offlineimap-7.0.6.tar.gz 690372 SHA256 f50002d0760794f1190526b74e2010becc16d2ff541526aadc95ec11cb064fd7 SHA512 9a1ff0abecb8d0b6cbedf4c7fad9f40de403ac789bb8bcfdea1dcacc1c36769643348ffe095d5e0b044f9ea17378512856a285c079c1713074432cc9f8ffeb27 WHIRLPOOL 596981227579162da62029c0a9ed4cda49ee35e8bc1ab6d1773f9933808c9909ef92c462e1f83f28deee2926dbc5641b417040281180921fe196fea53fd60c3b
diff --git a/net-mail/offlineimap/offlineimap-7.0.6.ebuild b/net-mail/offlineimap/offlineimap-7.0.6.ebuild
new file mode 100644
index 000000000000..2915dc79919a
--- /dev/null
+++ b/net-mail/offlineimap/offlineimap-7.0.6.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# Normally you need only one version of this.
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python{2_7,3_4} )
+PYTHON_REQ_USE="threads,sqlite,ssl?"
+
+inherit distutils-r1
+
+DESCRIPTION="Powerful IMAP/Maildir synchronization and reader support"
+HOMEPAGE="http://offlineimap.org"
+SRC_URI="https://github.com/OfflineIMAP/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc ssl"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="doc? ( app-text/asciidoc )"
+
+# see http://pogma.com/2009/09/09/snow-leopard-and-offlineimap/ and bug 284925
+PATCHES=(
+ "${FILESDIR}/${PN}-7.0.3-darwin10.patch"
+)
+
+src_compile() {
+ distutils-r1_src_compile
+ use doc && emake -C docs man
+}
+
+src_install() {
+ distutils-r1_src_install
+ dodoc offlineimap.conf offlineimap.conf.minimal
+ use doc && doman docs/{offlineimap.1,offlineimapui.7}
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "You will need to configure offlineimap by creating ~/.offlineimaprc"
+ elog "Sample configurations are in /usr/share/doc/${PF}/"
+ elog ""
+ elog "If you connect via ssl/tls and don't use CA cert checking, it will"
+ elog "display the server's cert fingerprint and require you to add it to the"
+ elog "configuration file to be sure it connects to the same server every"
+ elog "time. This serves to help fixing CVE-2010-4532 (offlineimap doesn't"
+ elog "check SSL server certificate) in cases where you have no CA cert."
+ fi
+}