summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-12-30 11:22:28 +0100
committerPacho Ramos <pacho@gentoo.org>2015-12-30 11:24:15 +0100
commit929421c0ac8b8951fece1bfc83bc7f270bb7b1e5 (patch)
tree3c92f8b8040cd5ad42e1c0a7d3376d067a7a741e /net-misc/gnome-online-miners
parentnet-misc/gnome-online-miners: Drop old (diff)
downloadgentoo-929421c0ac8b8951fece1bfc83bc7f270bb7b1e5.tar.gz
gentoo-929421c0ac8b8951fece1bfc83bc7f270bb7b1e5.tar.bz2
gentoo-929421c0ac8b8951fece1bfc83bc7f270bb7b1e5.zip
net-misc/gnome-online-miners: libgdata now uses a separate USE flag for switching gnome-online-accounts support and rename gnome USE to crypto (#566324)
Package-Manager: portage-2.2.26
Diffstat (limited to 'net-misc/gnome-online-miners')
-rw-r--r--net-misc/gnome-online-miners/gnome-online-miners-3.14.3-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-misc/gnome-online-miners/gnome-online-miners-3.14.3-r2.ebuild b/net-misc/gnome-online-miners/gnome-online-miners-3.14.3-r2.ebuild
new file mode 100644
index 000000000000..1822c2960fe4
--- /dev/null
+++ b/net-misc/gnome-online-miners/gnome-online-miners-3.14.3-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="Crawls through your online content"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeOnlineMiners"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="flickr"
+KEYWORDS="~amd64 ~x86"
+
+# libgdata[gnome] needed for goa support
+RDEPEND="
+ >=app-misc/tracker-1:0=
+ >=dev-libs/glib-2.35.1:2
+ >=dev-libs/libgdata-0.15.2:0=[crypt,gnome-online-accounts]
+ >=media-libs/grilo-0.2.6:0.2
+ >=net-libs/gnome-online-accounts-3.13.3
+ >=net-libs/libgfbgraph-0.2.2:0.2
+ >=net-libs/libzapojit-0.0.2
+ flickr? ( media-plugins/grilo-plugins[flickr] )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable flickr) \
+ --disable-static \
+ --enable-facebook \
+ --enable-google \
+ --enable-media-server \
+ --enable-owncloud \
+ --enable-windows-live
+}