summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-10-28 14:16:57 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-11-08 23:28:36 +0100
commitf8f1efbcfbb6909316395e45d2a01c9cb547a1aa (patch)
tree2fb3817d0abd4d8b9c21c0caa35381c92b5519b2 /net-misc/igmpproxy
parentnet-misc/mcproxy: drop old version. (diff)
downloadgentoo-f8f1efbcfbb6909316395e45d2a01c9cb547a1aa.tar.gz
gentoo-f8f1efbcfbb6909316395e45d2a01c9cb547a1aa.tar.bz2
gentoo-f8f1efbcfbb6909316395e45d2a01c9cb547a1aa.zip
net-misc/igmpproxy: bump to EAPI=7.
Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/10262 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'net-misc/igmpproxy')
-rw-r--r--net-misc/igmpproxy/igmpproxy-0.2.1-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/net-misc/igmpproxy/igmpproxy-0.2.1-r1.ebuild b/net-misc/igmpproxy/igmpproxy-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..06a8c2699a05
--- /dev/null
+++ b/net-misc/igmpproxy/igmpproxy-0.2.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit linux-info systemd
+
+DESCRIPTION="A multicast routing daemon which uses IGMP forwarding"
+HOMEPAGE="https://github.com/pali/igmpproxy"
+SRC_URI="https://github.com/pali/igmpproxy/releases/download/${PV}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+
+CONFIG_CHECK="~IP_MULTICAST ~IP_MROUTE"
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}/igmpproxy.initd" igmpproxy
+ systemd_dounit "${FILESDIR}/${PN}.service"
+
+ newconfd "${FILESDIR}/igmpproxy.confd" igmpproxy
+}