summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/lanmap
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/lanmap')
-rw-r--r--net-misc/lanmap/Manifest1
-rw-r--r--net-misc/lanmap/files/lanmap-81-make.patch69
-rw-r--r--net-misc/lanmap/files/lanmap-81-printf-format.patch11
-rw-r--r--net-misc/lanmap/lanmap-81-r1.ebuild41
-rw-r--r--net-misc/lanmap/lanmap-81-r2.ebuild43
-rw-r--r--net-misc/lanmap/metadata.xml6
6 files changed, 171 insertions, 0 deletions
diff --git a/net-misc/lanmap/Manifest b/net-misc/lanmap/Manifest
new file mode 100644
index 000000000000..df9fff0b70e9
--- /dev/null
+++ b/net-misc/lanmap/Manifest
@@ -0,0 +1 @@
+DIST lanmap-2006-03-07-rev81.zip 405933 SHA256 9a67645c5cde565e61c1a717a17a3491d027e72bfe6825d1d50262f6a6600fa3 SHA512 9216d753548fba48f4fcd18a55136a50c0dd01c87f1d5f7736319a7a71b28bd50f082a9aa94d8c426924e0fa4fb6537cd8c8cbd2a289736ede54fd4c6f4679f2 WHIRLPOOL e7d9d24dfafea9430d3a65da6d6cf7b8b12d176d6b99911f581a12074166c09099b56fcf50913e293c42ab962fc5f4bc41184184aaa41fbd453f7a3f667e86f3
diff --git a/net-misc/lanmap/files/lanmap-81-make.patch b/net-misc/lanmap/files/lanmap-81-make.patch
new file mode 100644
index 000000000000..e0c1988cc836
--- /dev/null
+++ b/net-misc/lanmap/files/lanmap-81-make.patch
@@ -0,0 +1,69 @@
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -2,8 +2,8 @@
+ # $Id$
+
+ # complation
+-CFLAGS = -W -Wall -Wno-unused -DLINUX -DLANMAP_DATADIR=$(LANMAP_DATADIR)
+-LDFLAGS = -lpcap -lm
++CFLAGS += -DLINUX -DLANMAP_DATADIR=$(LANMAP_DATADIR)
++LDFLAGS += -lpcap -lm
+ CFLAGS_DEBUG = -D_DEBUG -ggdb
+ LDFLAGS_DEBUG = -pg
+ BINARY = lanmap
+@@ -14,12 +14,12 @@
+ $(CC) $(OBJS) -o $(BINARY) $(LDFLAGS)
+
+ static:
+- make clean
+- make LDFLAGS="$(LDFLAGS) -static" all
++ $(MAKE) clean
++ $(MAKE) LDFLAGS="$(LDFLAGS) -static" all
+
+ debug:
+- make clean
+- make CFLAGS="$(CFLAGS) $(CFLAGS_DEBUG)" LDFLAGS="$(LDFLAGS)" all
++ $(MAKE) clean
++ $(MAKE) CFLAGS="$(CFLAGS) $(CFLAGS_DEBUG)" LDFLAGS="$(LDFLAGS)" all
+
+ # for testing the classify code by itself
+ os_classify: os_classify.c misc.c
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -10,18 +10,18 @@
+ DATADEST = ${prefix}/share/lanmap/
+
+ all:
+- cd ./src && make LANMAP_DATADIR="$(DATADEST)"
++ cd ./src && $(MAKE) LANMAP_DATADIR="$(DATADEST)"
+
+ install:
+- install -m 0755 ./src/$(BINARY) $(BINDEST)
++ install -m 0755 -D ./src/$(BINARY) $(BINDEST)/$(BINARY)
+ install -m 0755 -d $(DATADEST)
+ install -m 0755 -d $(DATADEST)data/
+ install -m 0755 -d $(DATADEST)data/graph/
+ install -m 0755 -d $(DATADEST)graph/img/
+ install -m 0644 ./data/mac_vendor $(DATADEST)data/
+- install -m 0644 -d $(DATADEST)graph
++ install -m 0755 -d $(DATADEST)graph
+ install -m 0644 ./graph/lanmap.header $(DATADEST)graph/
+- for f in ./graph/img/*.{png,gif,svg}; do install -m 0644 $$f $(DATADEST)graph/img/; done
++ for f in ./graph/img/*.gif ./graph/img/*.png ./graph/img/*.svg; do install -m 0644 $$f $(DATADEST)graph/img/; done
+
+ uninstall:
+ rm $(BINDEST)$(BINARY)
+@@ -29,11 +29,11 @@
+
+ clean:
+ rm -f ./src/$(BINARY)
+- cd ./src && make clean
++ cd ./src && $(MAKE) clean
+
+ distclean: clean
+ rm -f Makefile config.cache config.log config.status config.h
+
+ debug:
+- cd ./src && make debug
++ cd ./src && $(MAKE) debug
+
diff --git a/net-misc/lanmap/files/lanmap-81-printf-format.patch b/net-misc/lanmap/files/lanmap-81-printf-format.patch
new file mode 100644
index 000000000000..cbe330434f20
--- /dev/null
+++ b/net-misc/lanmap/files/lanmap-81-printf-format.patch
@@ -0,0 +1,11 @@
+--- a/src/misc.c
++++ b/src/misc.c
+@@ -58,7 +58,7 @@
+ linebuf[64] = ' ';
+ linebuf[56 + j - 1 + (j - 1 > 7) + 1] = '\n';
+ linebuf[56 + j - 1 + (j - 1 > 7) + 2] = '\0';
+- printf(linebuf);
++ printf("%s", linebuf);
+ #ifdef DEBUG
+ if (strlen(linebuf) > 73) {
+ fprintf(stderr, "line too long, wtf?!\n");
diff --git a/net-misc/lanmap/lanmap-81-r1.ebuild b/net-misc/lanmap/lanmap-81-r1.ebuild
new file mode 100644
index 000000000000..0d754b63e3de
--- /dev/null
+++ b/net-misc/lanmap/lanmap-81-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils toolchain-funcs
+
+DESCRIPTION="lanmap sits quietly on a network and builds a picture of what it sees"
+HOMEPAGE="http://www.parseerror.com/lanmap"
+SRC_URI="http://www.parseerror.com/${PN}/rev/${PN}-2006-03-07-rev${PV}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+
+CDEPEND="net-libs/libpcap"
+RDEPEND="
+ ${CDEPEND}
+ media-gfx/graphviz
+"
+DEPEND="
+ ${CDEPEND}
+ app-arch/unzip
+"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-make.patch
+ rm configure || die
+ eautoreconf
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake prefix="${ED}"/usr install
+ dodoc README.txt TODO.txt
+}
diff --git a/net-misc/lanmap/lanmap-81-r2.ebuild b/net-misc/lanmap/lanmap-81-r2.ebuild
new file mode 100644
index 000000000000..c85554e2d695
--- /dev/null
+++ b/net-misc/lanmap/lanmap-81-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils toolchain-funcs
+
+DESCRIPTION="lanmap sits quietly on a network and builds a picture of what it sees"
+HOMEPAGE="http://www.parseerror.com/lanmap"
+SRC_URI="http://www.parseerror.com/${PN}/rev/${PN}-2006-03-07-rev${PV}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+
+CDEPEND="net-libs/libpcap"
+RDEPEND="
+ ${CDEPEND}
+ media-gfx/graphviz
+"
+DEPEND="
+ ${CDEPEND}
+ app-arch/unzip
+"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-make.patch \
+ "${FILESDIR}"/${P}-printf-format.patch
+ rm configure || die
+ eautoreconf
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake prefix="${ED}"/usr install
+ dodoc README.txt TODO.txt
+}
diff --git a/net-misc/lanmap/metadata.xml b/net-misc/lanmap/metadata.xml
new file mode 100644
index 000000000000..9ca15ca788e8
--- /dev/null
+++ b/net-misc/lanmap/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+</pkgmetadata>
+