summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-02-13 14:31:59 +0100
committerMichał Górny <mgorny@gentoo.org>2019-02-13 15:28:45 +0100
commit5f24cde13775417e49f4fb9f90916392ff13dddf (patch)
treebd42750ee4403250eed056a598116c63fbb61a02 /net-misc/miniupnpd
parentsci-mathematics/z3: Bump to 4.8.4 (diff)
downloadgentoo-5f24cde13775417e49f4fb9f90916392ff13dddf.tar.gz
gentoo-5f24cde13775417e49f4fb9f90916392ff13dddf.tar.bz2
gentoo-5f24cde13775417e49f4fb9f90916392ff13dddf.zip
net-misc/miniupnpd: Bump to 2.1.20190210
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-misc/miniupnpd')
-rw-r--r--net-misc/miniupnpd/Manifest1
-rw-r--r--net-misc/miniupnpd/miniupnpd-2.1.20190210.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/net-misc/miniupnpd/Manifest b/net-misc/miniupnpd/Manifest
index 020b8d4282c9..f95f7bc2a90e 100644
--- a/net-misc/miniupnpd/Manifest
+++ b/net-misc/miniupnpd/Manifest
@@ -1 +1,2 @@
DIST miniupnpd-2.1.20180706.tar.gz 233675 BLAKE2B 641be6dc6a32383a02711139ac56236dc285041f2bda595a909ed5281a5163d1300212892e011f6256c6cf73b877f0e5e2e93efbfb08a77b0ae7d3dde94c28f6 SHA512 90881e08754f9fe3d1ef01da1fe437626d1fef09bea5eab9c1bcf3347e1197038ab87de8c7c454083ba90a86760230a323a6c293307b0fcecefbd5cfb658d227
+DIST miniupnpd-2.1.20190210.tar.gz 235093 BLAKE2B d86b4a73ebfe6b5f3665b92624e7eac36718fffea058c0e7d2cb4af2c0871534c7f7ec56ade6c3cb2e13215a77971173259f912efd61a37e41d0f2f0a4596e5c SHA512 d664d5f61a0e2e71086aa520cb91af9f7f9b8b34268a76d570bbca271d86eab4976655a1fec1d21be80a93e357a0cb185281037604a0cfc00e4944d8e8b6f664
diff --git a/net-misc/miniupnpd/miniupnpd-2.1.20190210.ebuild b/net-misc/miniupnpd/miniupnpd-2.1.20190210.ebuild
new file mode 100644
index 000000000000..7937133ad3d3
--- /dev/null
+++ b/net-misc/miniupnpd/miniupnpd-2.1.20190210.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="MiniUPnP IGD Daemon"
+HOMEPAGE="http://miniupnp.free.fr/"
+SRC_URI="http://miniupnp.free.fr/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+leasefile igd2 ipv6 pcp-peer portinuse strict"
+
+RDEPEND=">=net-firewall/iptables-1.4.6:0=[ipv6?]
+ net-libs/libnfnetlink:=
+ net-libs/libmnl:=
+ dev-libs/gmp:0=
+ sys-apps/util-linux:=
+ dev-libs/openssl:0="
+DEPEND="${RDEPEND}
+ sys-apps/lsb-release"
+
+src_prepare() {
+ default
+ mv Makefile.linux Makefile || die
+}
+
+src_configure() {
+ local -a opts
+ opts=(
+ --vendorcfg
+ $(usex igd2 '--igd2' '')
+ $(usex ipv6 '--ipv6' '')
+ $(usex leasefile '--leasefile' '')
+ $(usex portinuse '--portinuse' '')
+ $(usex pcp-peer '--pcp-peer' '')
+ $(usex strict '--strict' '')
+ )
+
+ emake CONFIG_OPTIONS="${opts[*]}" config.h
+}
+
+src_compile() {
+ # By default, it builds a bunch of unittests that are missing wrapper
+ # scripts in the tarball
+ emake CC="$(tc-getCC)" STRIP=true miniupnpd
+}
+
+src_install() {
+ emake PREFIX="${ED}" STRIP=true install
+
+ newinitd "${FILESDIR}"/${PN}-init.d-r1 ${PN}
+ newconfd "${FILESDIR}"/${PN}-conf.d-r1 ${PN}
+}
+
+pkg_postinst() {
+ elog "Please correct the external interface in the top of the two"
+ elog "scripts in /etc/miniupnpd and edit the config file in there too"
+}