summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2019-03-06 00:33:42 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2019-03-06 00:33:52 +0100
commit4eca64a213519d2aeb0fb3f737a0f31cf9c023d9 (patch)
tree5f74d4794bdc0a4e80a2812180d214dd95a9f6f7 /net-misc/nextcloud-client
parentnet-misc/nextcloud-client: drop old (diff)
downloadgentoo-4eca64a213519d2aeb0fb3f737a0f31cf9c023d9.tar.gz
gentoo-4eca64a213519d2aeb0fb3f737a0f31cf9c023d9.tar.bz2
gentoo-4eca64a213519d2aeb0fb3f737a0f31cf9c023d9.zip
net-misc/nextcloud-client: fix compilation with Qt 5.12
Closes: https://bugs.gentoo.org/677008 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'net-misc/nextcloud-client')
-rw-r--r--net-misc/nextcloud-client/files/nextcloud-client-2.5.1-missing_qt_include.patch23
-rw-r--r--net-misc/nextcloud-client/nextcloud-client-2.5.1.ebuild6
2 files changed, 28 insertions, 1 deletions
diff --git a/net-misc/nextcloud-client/files/nextcloud-client-2.5.1-missing_qt_include.patch b/net-misc/nextcloud-client/files/nextcloud-client-2.5.1-missing_qt_include.patch
new file mode 100644
index 000000000000..a5d6f03581b0
--- /dev/null
+++ b/net-misc/nextcloud-client/files/nextcloud-client-2.5.1-missing_qt_include.patch
@@ -0,0 +1,23 @@
+From 129588442041c32b0d98f2361a69e0e350592f70 Mon Sep 17 00:00:00 2001
+From: Oskar Kruschitz <okr@huemer-it.com>
+Date: Thu, 13 Dec 2018 16:13:01 +0100
+Subject: [PATCH] Added missing Include
+
+Fixing an error during Build with Qt5.12:
+error: member access into incomplete type 'const QWebEngineCertificateError'
+---
+ src/gui/wizard/webview.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/gui/wizard/webview.cpp b/src/gui/wizard/webview.cpp
+index 15c1f314e..73e671b8f 100644
+--- a/src/gui/wizard/webview.cpp
++++ b/src/gui/wizard/webview.cpp
+@@ -10,6 +10,7 @@
+ #include <QProgressBar>
+ #include <QLoggingCategory>
+ #include <QLocale>
++#include <QWebEngineCertificateError>
+
+ #include "common/utility.h"
+
diff --git a/net-misc/nextcloud-client/nextcloud-client-2.5.1.ebuild b/net-misc/nextcloud-client/nextcloud-client-2.5.1.ebuild
index 29daa11a9dbe..d4aa0a622a2a 100644
--- a/net-misc/nextcloud-client/nextcloud-client-2.5.1.ebuild
+++ b/net-misc/nextcloud-client/nextcloud-client-2.5.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -53,6 +53,10 @@ DEPEND="${COMMON_DEPEND}
)
"
+PATCHES=(
+ "${FILESDIR}"/${P}-missing_qt_include.patch
+ )
+
S=${WORKDIR}/desktop-${PV/_/-}
src_prepare() {