summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Browning <JamesB.fe80@gmail.com>2024-06-04 11:31:51 -0700
committerSam James <sam@gentoo.org>2024-06-14 09:01:15 +0100
commita0359d5441b73a07358be07a8bcb20d4a90373d1 (patch)
treeb98b59db280d270b088b9b2c7ff7126b45649cfe /net-misc/ntpsec/files
parentnet-misc/ntpsec: Replace USE_EXPANDish flags with normal ones (diff)
downloadgentoo-a0359d5441b73a07358be07a8bcb20d4a90373d1.tar.gz
gentoo-a0359d5441b73a07358be07a8bcb20d4a90373d1.tar.bz2
gentoo-a0359d5441b73a07358be07a8bcb20d4a90373d1.zip
net-misc/ntpsec: Replace egg-info with a Flit pyproject.toml file
Bug: https://bugs.gentoo.org/910009 Bug: https://bugs.gentoo.org/922819 Signed-off-by: James Browning <JamesB.fe80@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/ntpsec/files')
-rw-r--r--net-misc/ntpsec/files/flit.toml34
-rw-r--r--net-misc/ntpsec/files/ntpsec-1.2.3-pep517-no-egg.patch38
2 files changed, 72 insertions, 0 deletions
diff --git a/net-misc/ntpsec/files/flit.toml b/net-misc/ntpsec/files/flit.toml
new file mode 100644
index 000000000000..b3c782f9bc30
--- /dev/null
+++ b/net-misc/ntpsec/files/flit.toml
@@ -0,0 +1,34 @@
+[project]
+name = "ntp"
+version = "@NTPSEC_VERSION_EXTENDED@"
+dependencies = ["argparse"]
+requires-python = ">=2.6"
+authors = [
+ {name = "the NTPsec project", email = "devel@ntpsec.org"},
+]
+maintainers = [
+ {name = "the NTPsec project", email = "devel@ntpsec.org"}
+]
+description = "The NTP reference implementation, refactored"
+license = {text = "BSD 2 License"}
+keywords = ["ntp"]
+classifiers = [
+ 'Development Status :: 5 - Production/Stable',
+ 'License :: OSI Approved :: BSD License',
+ 'Operating System :: POSIX',
+ 'Programming Language :: Python',
+]
+
+[project.urls]
+Homepage = "https://www.ntpsec.org/"
+Documentation = "https://www.ntpsec.org/latest/"
+Repository = "https://gitlab.com/NTPsec/ntpsec/"
+"Bug Tracker" = "https://gitlab.com/NTPsec/ntpsec/-/issues"
+Changelog = "https://gitlab.com/NTPsec/ntpsec/-/blob/master/NEWS.adoc"
+
+[build-system]
+requires = ["flit_core >=3.2,<4"]
+build-backend = "flit_core.buildapi"
+
+[tool.flit.module]
+name = "ntp"
diff --git a/net-misc/ntpsec/files/ntpsec-1.2.3-pep517-no-egg.patch b/net-misc/ntpsec/files/ntpsec-1.2.3-pep517-no-egg.patch
new file mode 100644
index 000000000000..549a69792af4
--- /dev/null
+++ b/net-misc/ntpsec/files/ntpsec-1.2.3-pep517-no-egg.patch
@@ -0,0 +1,38 @@
+diff --git a/pylib/ntp-in.egg-info b/pylib/ntp-in.egg-info
+deleted file mode 100644
+index b672a8431..000000000
+--- a/pylib/ntp-in.egg-info
++++ /dev/null
+@@ -1,12 +0,0 @@
+-Metadata-Version: 1.0
+-Name: ntpsec
+-Version: @NTPSEC_VERSION_EXTENDED@
+-Platform: POSIX
+-Summary: The NTP reference implementation, refactored
+-Home-page: https://ntpsec.org/
+-License: Beerware, BSD-2-Clause, BSD-3-Clause, BSD-4-Clause, CC-BY-4.0, ISC, MIT, NTP
+-Description:
+- The Network Time Protocol suite, refactored
+-Author: the NTPsec project
+-Author-email: devel@ntpsec.org
+-Keywords:
+\ No newline at end of file
+diff --git a/pylib/wscript b/pylib/wscript
+index e285b768b..1137fb814 100644
+--- a/pylib/wscript
++++ b/pylib/wscript
+@@ -96,11 +96,9 @@ def build(ctx):
+ install_path='${PYTHONARCHDIR}/ntp'
+ )
+
+- # pep241 lay an egg
+- egg = ['ntp-%s.egg-info' % ctx.env.NTPSEC_VERSION]
++ # pep517 pyproject.toml
+ ctx(
+ features="subst",
+- source=['ntp-in.egg-info'],
+- target=egg
++ source=['pyproject.toml'],
++ target=['../pyproject.toml']
+ )
+- ctx.install_files(ctx.env.PYTHONARCHDIR, egg)