summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-05-31 17:02:41 -0400
committerAaron Bauman <bman@gentoo.org>2018-06-01 10:05:15 -0400
commit8e3f7e4ab976ef3fea3714c9a75346c116a11bfa (patch)
treec4e241bf6018aeac89179fc278f5c082b26cf78a /net-misc/pedro
parentnet-misc/aggregate: bump EAPI and drop eutils (diff)
downloadgentoo-8e3f7e4ab976ef3fea3714c9a75346c116a11bfa.tar.gz
gentoo-8e3f7e4ab976ef3fea3714c9a75346c116a11bfa.tar.bz2
gentoo-8e3f7e4ab976ef3fea3714c9a75346c116a11bfa.zip
net-misc/pedro: bump EAPI and drop eutils
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'net-misc/pedro')
-rw-r--r--net-misc/pedro/files/pedro-1.6-portage.patch4
-rw-r--r--net-misc/pedro/pedro-1.6.ebuild24
2 files changed, 12 insertions, 16 deletions
diff --git a/net-misc/pedro/files/pedro-1.6-portage.patch b/net-misc/pedro/files/pedro-1.6-portage.patch
index be1f9d3b2136..b72a3251b89a 100644
--- a/net-misc/pedro/files/pedro-1.6-portage.patch
+++ b/net-misc/pedro/files/pedro-1.6-portage.patch
@@ -1,5 +1,5 @@
---- pedro-1.6.orig/configure 2011-08-23 11:01:21.000000000 +1200
-+++ pedro-1.6/configure 2011-11-19 21:28:47.000000000 +1300
+--- a/configure
++++ b/configure
@@ -10478,7 +10478,7 @@
ac_config_headers="$ac_config_headers config.h"
diff --git a/net-misc/pedro/pedro-1.6.ebuild b/net-misc/pedro/pedro-1.6.ebuild
index 00b9a3e6b9af..a3983f5619e8 100644
--- a/net-misc/pedro/pedro-1.6.ebuild
+++ b/net-misc/pedro/pedro-1.6.ebuild
@@ -1,9 +1,7 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=2
-
-inherit eutils
+EAPI=6
DESCRIPTION="Pedro is a subscription/notification communications system"
HOMEPAGE="http://www.itee.uq.edu.au/~pjr/HomePages/PedroHome.html"
@@ -20,25 +18,23 @@ DEPEND="${RDEPEND}"
S="${WORKDIR}"/${P}
-src_prepare() {
- epatch "${FILESDIR}"/${P}-portage.patch
-}
+PATCHES=( "${FILESDIR}/${P}-portage.patch" )
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dodoc AUTHORS README || die
+ default
if use doc ; then
- dodoc "${WORKDIR}"/${PN}.pdf || die
+ dodoc "${WORKDIR}"/${PN}.pdf
fi
if use examples ; then
insinto /usr/share/doc/${PF}/examples
- doins src/examples/*.{c,tcl} || die
+ doins src/examples/*.{c,tcl}
+
insinto /usr/share/doc/${PF}/examples/java_api
- doins src/java_api/*.java || die
+ doins src/java_api/*.java
+
insinto /usr/share/doc/${PF}/examples/python_api
- doins src/python_api/*.py || die
+ doins src/python_api/*.py
fi
}