summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2016-03-25 10:08:42 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2016-03-25 10:08:50 +0100
commitab5cedb56a43a49f0036cddc0096dfbd35522274 (patch)
tree4315858aeb61d13a315f6f195cfbe8f3d5a40f56 /net-misc/pyhoca-gui/pyhoca-gui-0.5.0.6.ebuild
parentnet-misc/x2goclient: version bump, ebuild update for EAPI6 (diff)
downloadgentoo-ab5cedb56a43a49f0036cddc0096dfbd35522274.tar.gz
gentoo-ab5cedb56a43a49f0036cddc0096dfbd35522274.tar.bz2
gentoo-ab5cedb56a43a49f0036cddc0096dfbd35522274.zip
net-misc/pyhoca-gui: version bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'net-misc/pyhoca-gui/pyhoca-gui-0.5.0.6.ebuild')
-rw-r--r--net-misc/pyhoca-gui/pyhoca-gui-0.5.0.6.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-misc/pyhoca-gui/pyhoca-gui-0.5.0.6.ebuild b/net-misc/pyhoca-gui/pyhoca-gui-0.5.0.6.ebuild
new file mode 100644
index 000000000000..73ce007c3027
--- /dev/null
+++ b/net-misc/pyhoca-gui/pyhoca-gui-0.5.0.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1
+
+DESCRIPTION="X2Go graphical client applet"
+HOMEPAGE="http://www.x2go.org"
+SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/notify-python[${PYTHON_USEDEP}]
+ dev-python/pycups[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ dev-python/wxpython[${PYTHON_USEDEP}]
+ >=net-misc/python-x2go-0.5.0.0[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]"
+
+python_install() {
+ distutils-r1_python_install
+ python_doscript ${PN}
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman man/man1/*
+}