summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-03-19 18:35:38 +0200
committerMart Raudsepp <leio@gentoo.org>2017-03-19 18:36:59 +0200
commitc36ab2a59abb21750cfefd92112c027ad2cb5c0e (patch)
treedd29777467b2cfd932c274d1b89a30d61ca94340 /net-misc/rygel
parentdev-php/pecl-geoip: new revision with php-7.1 support. (diff)
downloadgentoo-c36ab2a59abb21750cfefd92112c027ad2cb5c0e.tar.gz
gentoo-c36ab2a59abb21750cfefd92112c027ad2cb5c0e.tar.bz2
gentoo-c36ab2a59abb21750cfefd92112c027ad2cb5c0e.zip
net-misc/rygel: Fix REPLACING_VERSIONS handling and gdk-pixbuf dep (USE=sqlite only)
Gentoo-bug: 589498
Diffstat (limited to 'net-misc/rygel')
-rw-r--r--net-misc/rygel/rygel-0.30.3.ebuild20
-rw-r--r--net-misc/rygel/rygel-0.32.1.ebuild22
2 files changed, 25 insertions, 17 deletions
diff --git a/net-misc/rygel/rygel-0.30.3.ebuild b/net-misc/rygel/rygel-0.30.3.ebuild
index 69aeeb22b310..459a2906564e 100644
--- a/net-misc/rygel/rygel-0.30.3.ebuild
+++ b/net-misc/rygel/rygel-0.30.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -73,11 +73,15 @@ src_configure() {
pkg_postinst() {
gnome2_pkg_postinst
- if ! version_is_at_least 0.28.2-r1 ${REPLACING_VERSIONS}; then
- elog "This version stops forcing the automatical starting of"
- elog "rygel as upstream pretends. This way, it will honor the"
- elog "user settings at Sharing section in gnome-control-center."
- elog "If you desire to keep getting rygel autostarting always"
- elog "you will need to configure your desktop to do it."
- fi
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if ! version_is_at_least 0.28.2-r1 ${v}; then
+ elog "This version stops forcing the automatical starting of"
+ elog "rygel as upstream pretends. This way, it will honor the"
+ elog "user settings at Sharing section in gnome-control-center."
+ elog "If you desire to keep getting rygel autostarting always"
+ elog "you will need to configure your desktop to do it."
+ break
+ fi
+ done
}
diff --git a/net-misc/rygel/rygel-0.32.1.ebuild b/net-misc/rygel/rygel-0.32.1.ebuild
index 5988bd231610..bccf3fbb206e 100644
--- a/net-misc/rygel/rygel-0.32.1.ebuild
+++ b/net-misc/rygel/rygel-0.32.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -30,12 +30,12 @@ RDEPEND="
>=net-libs/gupnp-av-0.12.8
>=net-libs/libsoup-2.44:2.4
>=sys-apps/util-linux-2.20
- x11-libs/gdk-pixbuf:2
x11-misc/shared-mime-info
introspection? ( >=dev-libs/gobject-introspection-1.33.4:= )
sqlite? (
>=dev-db/sqlite-3.5:3
dev-libs/libunistring:=
+ x11-libs/gdk-pixbuf:2
)
tracker? ( >=app-misc/tracker-0.16:= )
transcode? (
@@ -74,11 +74,15 @@ src_configure() {
pkg_postinst() {
gnome2_pkg_postinst
- if ! version_is_at_least 0.28.2-r1 ${REPLACING_VERSIONS}; then
- elog "This version stops forcing the automatical starting of"
- elog "rygel as upstream pretends. This way, it will honor the"
- elog "user settings at Sharing section in gnome-control-center."
- elog "If you desire to keep getting rygel autostarting always"
- elog "you will need to configure your desktop to do it."
- fi
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if ! version_is_at_least 0.28.2-r1 ${v}; then
+ elog "This version stops forcing the automatical starting of"
+ elog "rygel as upstream pretends. This way, it will honor the"
+ elog "user settings at Sharing section in gnome-control-center."
+ elog "If you desire to keep getting rygel autostarting always"
+ elog "you will need to configure your desktop to do it."
+ break
+ fi
+ done
}