summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/socket
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/socket')
-rw-r--r--net-misc/socket/Manifest1
-rw-r--r--net-misc/socket/files/socket-1.5-makefile.patch14
-rw-r--r--net-misc/socket/metadata.xml8
-rw-r--r--net-misc/socket/socket-1.5.ebuild33
4 files changed, 56 insertions, 0 deletions
diff --git a/net-misc/socket/Manifest b/net-misc/socket/Manifest
new file mode 100644
index 000000000000..8126e5bc5dca
--- /dev/null
+++ b/net-misc/socket/Manifest
@@ -0,0 +1 @@
+DIST socket-1.5.tar.gz 22002 SHA256 fa36abdc29e1b8a48156061f8a16779ee3446770197071802efbdb01051024a7 SHA512 9503139087a65a63462571788b6710c486c7a00532bc027b87d9f4bd0c92a7e90befe8a3ec86c622bc02ff51beaec05cacfcaffb06d7c983a73c38a18bca315d WHIRLPOOL a220486af2c6cb9c95c6518c630ebc2fc11f6d250e5e02d532d50744eb29271318d3d0c2bf8bc09fc828071aca989cdad78cf18854735eaec874346a5c07ba44
diff --git a/net-misc/socket/files/socket-1.5-makefile.patch b/net-misc/socket/files/socket-1.5-makefile.patch
new file mode 100644
index 000000000000..7dc3e7c1f5c3
--- /dev/null
+++ b/net-misc/socket/files/socket-1.5-makefile.patch
@@ -0,0 +1,14 @@
+--- Makefile.orig 2008-06-27 13:57:47.000000000 +0400
++++ Makefile 2013-02-05 00:42:25.241748516 +0400
+@@ -38,9 +38,8 @@
+ INSTALLMANPATH = $(INSTALLBASE)/man
+ INSTALLMANMODE = 444
+ GCCOPTS = -Wall -Wstrict-prototypes
+-CC = cc
+-CFLAGS = $(SWITCHES) -g
+-LDFLAGS = $(SWITCHES) # -s
++CC ?= cc
++CFLAGS += $(SWITCHES)
+ # To use an architecture-specific compile directory (inside of the
+ # source directory):
+ ARCHDIR = .
diff --git a/net-misc/socket/metadata.xml b/net-misc/socket/metadata.xml
new file mode 100644
index 000000000000..b6b8956cde34
--- /dev/null
+++ b/net-misc/socket/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-misc/socket/socket-1.5.ebuild b/net-misc/socket/socket-1.5.ebuild
new file mode 100644
index 000000000000..46528c1242f1
--- /dev/null
+++ b/net-misc/socket/socket-1.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit base toolchain-funcs
+
+DESCRIPTION="A shell-level interface to TCP sockets"
+HOMEPAGE="http://www.jnickelsen.de/socket/"
+SRC_URI="http://www.jnickelsen.de/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+
+IUSE="examples"
+
+PATCHES=( "${FILESDIR}/${P}-makefile.patch" )
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin socket
+ doman socket.1
+ dodoc BLURB CHANGES README
+ if use examples; then
+ docinto examples
+ dodoc scripts/*
+ fi
+}