summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-07-05 19:06:28 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-07-05 19:06:50 -0400
commit2e5771a83a3d4f0705bde3136aa96b443fe58afe (patch)
tree27c1258642955a3954449be7ab2681d3593db261 /net-misc/stunnel
parentpackage.mask: cleanup bug #500970 (diff)
downloadgentoo-2e5771a83a3d4f0705bde3136aa96b443fe58afe.tar.gz
gentoo-2e5771a83a3d4f0705bde3136aa96b443fe58afe.tar.bz2
gentoo-2e5771a83a3d4f0705bde3136aa96b443fe58afe.zip
net-misc/stunnel: version bump to 5.34
Package-Manager: portage-2.2.28
Diffstat (limited to 'net-misc/stunnel')
-rw-r--r--net-misc/stunnel/Manifest1
-rw-r--r--net-misc/stunnel/stunnel-5.34.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/net-misc/stunnel/Manifest b/net-misc/stunnel/Manifest
index f095a5c13236..4684fa1e4b4b 100644
--- a/net-misc/stunnel/Manifest
+++ b/net-misc/stunnel/Manifest
@@ -1,3 +1,4 @@
DIST stunnel-5.24.tar.gz 631730 SHA256 ab2e5a1034d422951ddad21b572eb7fa8efb4c4ce04bc86536c6845f3d02b07e SHA512 d9a1ef9cdd3ffafc2a3d1b3383bcf3dfc1a52cdd5a0bcfd64f50addf78a0fd0ce0def6b32ed801f8dfcabbecd64284454b1c90a18435b5d603ecba594d840340 WHIRLPOOL b625adbc9299c04308733bb5ee732350084b603128734214ec3079f58c02b58d08bfc53bf604468cd83cc5dc1bf5d968a4d5139cd98d7b2219303fdd3d6eae64
DIST stunnel-5.30.tar.gz 638771 SHA256 7d6eb389f6a1954b3bcf6c71d4ae3c5f9dde1990dd0b9e0cb1c7caf138d60570 SHA512 66bb610241e70881f8b14bfaec712a48361ec43a631db8b38ea0c94547fa184896e2d1fbbce52eb13c65411aa1ca10b3e9e42bde1651b38a5d551504b3b38f3c WHIRLPOOL 6b375be08c52088de065028d4d2e4d99301dbeb3a6771bbfe19f715d1dd9f7ccf893b87b973dbb19bfc5decf7f6e487322d857e04fdccdd535140ebecef358f8
DIST stunnel-5.32.tar.gz 641907 SHA256 0ee64774d7a720f3ffd129b08557ee0882704c7f65b859c40e315a175b68a6fd SHA512 aad3b718a727ae23bc88bda027017a5e4e19d2d08c1d4e95087dae20d4ed994d0ce29e9ae4b4d40456a7d7aaeb10c30a4283c6be2965d7183982204a347781bc WHIRLPOOL e2ec5471a33e033670ba23323ee86f02a1a368572138dd30075d1cee408a8fc298e98bdfc64143399ffbb0ead2dd62b834cacdca0adab0b7c72eef08dd2f3f38
+DIST stunnel-5.34.tar.gz 644677 SHA256 786111168a84a5a01188dddfcecb37d8c69a4c725dc3b476fbbd294e86741a55 SHA512 32edd2e3461536a35b150068720492a84d3174f8ede46b3d79e42a1c00e5096ea631dae41072c982c95b46ce3cb9dcf8dd1e48a4c429e94933d30b12c21d1181 WHIRLPOOL fc0d22cdb8a9bf4c5bdbd12c14d09d2fbb31ec3d16e5b9d32436980aaedd321cdffed031ced9b93b04bc1f97111d7379f8473400b44064abf417fb65d846ff18
diff --git a/net-misc/stunnel/stunnel-5.34.ebuild b/net-misc/stunnel/stunnel-5.34.ebuild
new file mode 100644
index 000000000000..6fb712f83c96
--- /dev/null
+++ b/net-misc/stunnel/stunnel-5.34.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit ssl-cert eutils multilib systemd user
+
+DESCRIPTION="TLS/SSL - Port Wrapper"
+HOMEPAGE="http://www.stunnel.org/index.html"
+SRC_URI="ftp://ftp.stunnel.org/stunnel/archive/${PV%%.*}.x/${P}.tar.gz
+ http://www.usenix.org.uk/mirrors/stunnel/archive/${PV%%.*}.x/${P}.tar.gz
+ http://ftp.nluug.nl/pub/networking/stunnel/archive/${PV%%.*}.x/${P}.tar.gz
+ http://www.namesdir.com/mirrors/stunnel/archive/${PV%%.*}.x/${P}.tar.gz
+ http://stunnel.cybermirror.org/archive/${PV%%.*}.x/${P}.tar.gz
+ http://mirrors.zerg.biz/stunnel/archive/${PV%%.*}.x/${P}.tar.gz
+ ftp://mirrors.go-parts.com/stunnel/archive/${PV%%.*}.x/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="ipv6 libressl selinux stunnel3 tcpd"
+
+DEPEND="tcpd? ( sys-apps/tcp-wrappers )
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )"
+RDEPEND="${DEPEND}
+ stunnel3? ( dev-lang/perl )
+ selinux? ( sec-policy/selinux-stunnel )"
+
+RESTRICT="test"
+
+pkg_setup() {
+ enewgroup stunnel
+ enewuser stunnel -1 -1 -1 stunnel
+}
+
+src_prepare() {
+ # Hack away generation of certificate
+ sed -i -e "s/^install-data-local:/do-not-run-this:/" \
+ tools/Makefile.in || die "sed failed"
+
+ # libressl compat
+ epatch "${FILESDIR}"/stunnel-compat-libressl.patch
+
+ echo "CONFIG_PROTECT=\"/etc/stunnel/stunnel.conf\"" > "${T}"/20stunnel
+}
+
+src_configure() {
+ econf \
+ --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ $(use_enable ipv6) \
+ $(use_enable tcpd libwrap) \
+ --with-ssl="${EPREFIX}"/usr \
+ --disable-fips
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ rm -rf "${ED}"/usr/share/doc/${PN}
+ rm -f "${ED}"/etc/stunnel/stunnel.conf-sample \
+ "${ED}"/usr/share/man/man8/stunnel.{fr,pl}.8
+ use stunnel3 || rm -f "${ED}"/usr/bin/stunnel3
+
+ # The binary was moved to /usr/bin with 4.21,
+ # symlink for backwards compatibility
+ dosym ../bin/stunnel /usr/sbin/stunnel
+
+ dodoc AUTHORS BUGS CREDITS PORTS README TODO ChangeLog
+ dohtml doc/stunnel.html doc/en/VNC_StunnelHOWTO.html tools/ca.html \
+ tools/importCA.html
+
+ insinto /etc/stunnel
+ doins "${FILESDIR}"/stunnel.conf
+ doinitd "${FILESDIR}"/stunnel
+
+ doenvd "${T}"/20stunnel
+
+ systemd_dounit "${S}/tools/stunnel.service"
+ systemd_newtmpfilesd "${FILESDIR}"/stunnel.tmpfiles.conf stunnel.conf
+}
+
+pkg_postinst() {
+ if [ ! -f "${EROOT}"/etc/stunnel/stunnel.key ]; then
+ install_cert /etc/stunnel/stunnel
+ chown stunnel:stunnel "${EROOT}"/etc/stunnel/stunnel.{crt,csr,key,pem}
+ chmod 0640 "${EROOT}"/etc/stunnel/stunnel.{crt,csr,key,pem}
+ fi
+
+ einfo "If you want to run multiple instances of stunnel, create a new config"
+ einfo "file ending with .conf in /etc/stunnel/. **Make sure** you change "
+ einfo "\'pid= \' with a unique filename."
+}