summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-05-03 19:56:13 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-05-03 19:56:13 -0400
commit71ffa5f690f3f29c2b974acb0bcbd8135f1491ee (patch)
treecda20e6e011afc77137adf413c9348e0da70b36d /net-misc/stunnel
parentmedia-gfx/qiviewer: drop qt@g.o from maintainers (diff)
downloadgentoo-71ffa5f690f3f29c2b974acb0bcbd8135f1491ee.tar.gz
gentoo-71ffa5f690f3f29c2b974acb0bcbd8135f1491ee.tar.bz2
gentoo-71ffa5f690f3f29c2b974acb0bcbd8135f1491ee.zip
net-misc/stunnel: version bump to 5.32
Package-Manager: portage-2.2.26
Diffstat (limited to 'net-misc/stunnel')
-rw-r--r--net-misc/stunnel/Manifest1
-rw-r--r--net-misc/stunnel/stunnel-5.32.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/net-misc/stunnel/Manifest b/net-misc/stunnel/Manifest
index 48bff4d82f7c..aa9924f3cdda 100644
--- a/net-misc/stunnel/Manifest
+++ b/net-misc/stunnel/Manifest
@@ -2,3 +2,4 @@ DIST stunnel-5.24.tar.gz 631730 SHA256 ab2e5a1034d422951ddad21b572eb7fa8efb4c4ce
DIST stunnel-5.29.tar.gz 637806 SHA256 43909625403ea634fa7cb8399d58faf8e7f11c1b7b29097491469951f56df551 SHA512 1a7017921e29416dfb934d258c89b9b47db9922e6af1a29bd53895cb153d7de3908fd4cfd6e65e6aa8992cb26670dbfeab366c0f7ce0317d9045a67d1e30a934 WHIRLPOOL c15e09aa9777f6150f9cf3663c8e1dc32e3556295a63945aa7b4186e2c7a52e0d766f010afce548798aba2d7a2165b6af46613457e0b7339da8f438cb4694085
DIST stunnel-5.30.tar.gz 638771 SHA256 7d6eb389f6a1954b3bcf6c71d4ae3c5f9dde1990dd0b9e0cb1c7caf138d60570 SHA512 66bb610241e70881f8b14bfaec712a48361ec43a631db8b38ea0c94547fa184896e2d1fbbce52eb13c65411aa1ca10b3e9e42bde1651b38a5d551504b3b38f3c WHIRLPOOL 6b375be08c52088de065028d4d2e4d99301dbeb3a6771bbfe19f715d1dd9f7ccf893b87b973dbb19bfc5decf7f6e487322d857e04fdccdd535140ebecef358f8
DIST stunnel-5.31.tar.gz 639381 SHA256 a746b71ab3dc6c23eacb0daf7342467870e43ac933430905eb1b1d050bbae0b7 SHA512 250d55e684311ed79d43f25f7980e67627d8d58cfe8c13d4f90a8e0b00f13819adc1732bbc94ebba7dccc183384ea75c8ff3171f697d147f204b62fa60f63b67 WHIRLPOOL 61664e7e7d075627d6cbbfd0663d6d4770243ed2b469199a06d3d6b0ff338f631a51f6510bef5d761e56301c3f2c46a622c949f14b0560117fd756780c2945bb
+DIST stunnel-5.32.tar.gz 641907 SHA256 0ee64774d7a720f3ffd129b08557ee0882704c7f65b859c40e315a175b68a6fd SHA512 aad3b718a727ae23bc88bda027017a5e4e19d2d08c1d4e95087dae20d4ed994d0ce29e9ae4b4d40456a7d7aaeb10c30a4283c6be2965d7183982204a347781bc WHIRLPOOL e2ec5471a33e033670ba23323ee86f02a1a368572138dd30075d1cee408a8fc298e98bdfc64143399ffbb0ead2dd62b834cacdca0adab0b7c72eef08dd2f3f38
diff --git a/net-misc/stunnel/stunnel-5.32.ebuild b/net-misc/stunnel/stunnel-5.32.ebuild
new file mode 100644
index 000000000000..4eac53ed941b
--- /dev/null
+++ b/net-misc/stunnel/stunnel-5.32.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit ssl-cert eutils multilib systemd user
+
+DESCRIPTION="TLS/SSL - Port Wrapper"
+HOMEPAGE="http://www.stunnel.org/index.html"
+SRC_URI="ftp://ftp.stunnel.org/stunnel/archive/${PV%%.*}.x/${P}.tar.gz
+ http://www.usenix.org.uk/mirrors/stunnel/archive/${PV%%.*}.x/${P}.tar.gz
+ http://ftp.nluug.nl/pub/networking/stunnel/archive/${PV%%.*}.x/${P}.tar.gz
+ http://www.namesdir.com/mirrors/stunnel/archive/${PV%%.*}.x/${P}.tar.gz
+ http://stunnel.cybermirror.org/archive/${PV%%.*}.x/${P}.tar.gz
+ http://mirrors.zerg.biz/stunnel/archive/${PV%%.*}.x/${P}.tar.gz
+ ftp://mirrors.go-parts.com/stunnel/archive/${PV%%.*}.x/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="ipv6 libressl selinux stunnel3 tcpd"
+
+DEPEND="tcpd? ( sys-apps/tcp-wrappers )
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )"
+RDEPEND="${DEPEND}
+ stunnel3? ( dev-lang/perl )
+ selinux? ( sec-policy/selinux-stunnel )"
+
+RESTRICT="test"
+
+pkg_setup() {
+ enewgroup stunnel
+ enewuser stunnel -1 -1 -1 stunnel
+}
+
+src_prepare() {
+ # Hack away generation of certificate
+ sed -i -e "s/^install-data-local:/do-not-run-this:/" \
+ tools/Makefile.in || die "sed failed"
+
+ echo "CONFIG_PROTECT=\"/etc/stunnel/stunnel.conf\"" > "${T}"/20stunnel
+}
+
+src_configure() {
+ econf \
+ --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ $(use_enable ipv6) \
+ $(use_enable tcpd libwrap) \
+ --with-ssl="${EPREFIX}"/usr \
+ --disable-fips
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ rm -rf "${ED}"/usr/share/doc/${PN}
+ rm -f "${ED}"/etc/stunnel/stunnel.conf-sample \
+ "${ED}"/usr/share/man/man8/stunnel.{fr,pl}.8
+ use stunnel3 || rm -f "${ED}"/usr/bin/stunnel3
+
+ # The binary was moved to /usr/bin with 4.21,
+ # symlink for backwards compatibility
+ dosym ../bin/stunnel /usr/sbin/stunnel
+
+ dodoc AUTHORS BUGS CREDITS PORTS README TODO ChangeLog
+ dohtml doc/stunnel.html doc/en/VNC_StunnelHOWTO.html tools/ca.html \
+ tools/importCA.html
+
+ insinto /etc/stunnel
+ doins "${FILESDIR}"/stunnel.conf
+ doinitd "${FILESDIR}"/stunnel
+
+ doenvd "${T}"/20stunnel
+
+ systemd_dounit "${S}/tools/stunnel.service"
+ systemd_newtmpfilesd "${FILESDIR}"/stunnel.tmpfiles.conf stunnel.conf
+}
+
+pkg_postinst() {
+ if [ ! -f "${EROOT}"/etc/stunnel/stunnel.key ]; then
+ install_cert /etc/stunnel/stunnel
+ chown stunnel:stunnel "${EROOT}"/etc/stunnel/stunnel.{crt,csr,key,pem}
+ chmod 0640 "${EROOT}"/etc/stunnel/stunnel.{crt,csr,key,pem}
+ fi
+
+ einfo "If you want to run multiple instances of stunnel, create a new config"
+ einfo "file ending with .conf in /etc/stunnel/. **Make sure** you change "
+ einfo "\'pid= \' with a unique filename."
+}