summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/vconfig
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/vconfig')
-rw-r--r--net-misc/vconfig/Manifest1
-rw-r--r--net-misc/vconfig/metadata.xml10
-rw-r--r--net-misc/vconfig/vconfig-1.9.ebuild39
3 files changed, 50 insertions, 0 deletions
diff --git a/net-misc/vconfig/Manifest b/net-misc/vconfig/Manifest
new file mode 100644
index 000000000000..7c941772ee70
--- /dev/null
+++ b/net-misc/vconfig/Manifest
@@ -0,0 +1 @@
+DIST vlan.1.9.tar.gz 176135 SHA256 3b8f0a1bf0d3642764e5f646e1f3bbc8b1eeec474a77392d9aeb4868842b4cca
diff --git a/net-misc/vconfig/metadata.xml b/net-misc/vconfig/metadata.xml
new file mode 100644
index 000000000000..712c2d256e0a
--- /dev/null
+++ b/net-misc/vconfig/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>base-system</herd>
+ <longdescription>
+ The vconfig program allows you to create and remove vlan-devices on a
+ vlan enabled kernel. Vlan-devices are virtual ethernet devices which
+ represents the virtual lans on the physical lan.
+ </longdescription>
+</pkgmetadata>
diff --git a/net-misc/vconfig/vconfig-1.9.ebuild b/net-misc/vconfig/vconfig-1.9.ebuild
new file mode 100644
index 000000000000..8283da014584
--- /dev/null
+++ b/net-misc/vconfig/vconfig-1.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils flag-o-matic toolchain-funcs
+
+MY_PN="vlan"
+S=${WORKDIR}/${MY_PN}
+
+DESCRIPTION="802.1Q vlan control utility"
+HOMEPAGE="http://www.candelatech.com/~greear/vlan.html"
+SRC_URI="http://www.candelatech.com/~greear/vlan/${MY_PN}.${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm hppa ~ppc ~ppc64 sparc x86"
+IUSE="static"
+
+src_compile() {
+ use static && appened-ldflags -static
+ emake purge
+ emake CC="$(tc-getCC)" CCFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" STRIP="true" vconfig || die
+}
+
+src_install() {
+ into /
+ dosbin vconfig || die "dosbin error"
+
+ sed -e "s:/usr/local/bin/vconfig:/sbin/vconfig:g" -i vlan_test.pl
+ sed -e "s:/usr/local/bin/vconfig:/sbin/vconfig:g" -i vlan_test2.pl
+
+ doman vconfig.8 || die "doman error"
+ dohtml howto.html vlan.html || die "dohtml error"
+ dodoc CHANGELOG README vlan_test*.pl || die "dodoc error"
+}
+
+pkg_postinst() {
+ ewarn "MTU problems exist for many ethernet drivers."
+ ewarn "Reduce the MTU on the interface to 1496 to work around them."
+}