summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/vino
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/vino')
-rw-r--r--net-misc/vino/Manifest2
-rw-r--r--net-misc/vino/metadata.xml10
-rw-r--r--net-misc/vino/vino-3.14.2.ebuild69
-rw-r--r--net-misc/vino/vino-3.16.0.ebuild67
4 files changed, 148 insertions, 0 deletions
diff --git a/net-misc/vino/Manifest b/net-misc/vino/Manifest
new file mode 100644
index 000000000000..c09843eda2eb
--- /dev/null
+++ b/net-misc/vino/Manifest
@@ -0,0 +1,2 @@
+DIST vino-3.14.2.tar.xz 750452 SHA256 9042ca347968617f831a472a5c6c123b71bb9ba5339e45ccf46004a7452da3a5 SHA512 daf6710ad89991ae248c633ffcd623182c7b7404daea75762123e17687ea3ede5f49102d6dff7bde9d233257b044a3b95a26b0ea235587004877203bd077d1c8 WHIRLPOOL 975b9d739adafbee5c0276ba630e3232953a39d03f55c97b60b0d0c055ed87a6fb3b19818aa4d7062643419c22ed854761126df16cb1e17f2094b77557e942b7
+DIST vino-3.16.0.tar.xz 760508 SHA256 608d3613d4e0ad40566759df06587effcfae77f205fce83e3bcf7574bc608dc5 SHA512 232cf9e2d986043e8da4db6d7a07ada77b46f71280da85915c54ed53c7212d47256b0e9532aa4879f6e3fa374a46c7ec7e58310d07581f7708efc1a131ba643f WHIRLPOOL 676c055ce1ef93c966c9691d415c84922247993ac6821ba174108bbaf359d3ee7f6d5d6b8e070bc4af02136ead206a25d11b1efba92a46b4dc209d83e0f88543
diff --git a/net-misc/vino/metadata.xml b/net-misc/vino/metadata.xml
new file mode 100644
index 000000000000..326077bc4073
--- /dev/null
+++ b/net-misc/vino/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+<use>
+ <flag name="libsecret">Enable app-crypt/libsecret support to store
+ login credentials.</flag>
+ <flag name="telepathy">Enable desktop sharing through a telepathy client</flag>
+</use>
+</pkgmetadata>
diff --git a/net-misc/vino/vino-3.14.2.ebuild b/net-misc/vino/vino-3.14.2.ebuild
new file mode 100644
index 000000000000..32f65b27e679
--- /dev/null
+++ b/net-misc/vino/vino-3.14.2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+
+inherit gnome2
+
+DESCRIPTION="An integrated VNC server for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Projects/Vino"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
+IUSE="crypt libsecret ipv6 jpeg networkmanager ssl +telepathy zeroconf +zlib"
+# bug #394611; tight encoding requires zlib encoding
+REQUIRED_USE="jpeg? ( zlib )"
+
+# cairo used in vino-fb
+# libSM and libICE used in eggsmclient-xsmp
+RDEPEND="
+ >=dev-libs/glib-2.26:2
+ >=x11-libs/gtk+-3.0.0:3
+ >=dev-libs/libgcrypt-1.1.90:0=
+
+ dev-libs/dbus-glib
+ x11-libs/cairo:=
+ x11-libs/pango[X]
+ x11-libs/libICE
+ x11-libs/libX11
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libSM
+ x11-libs/libXtst
+
+ >=x11-libs/libnotify-0.7.0:=
+
+ crypt? ( >=dev-libs/libgcrypt-1.1.90:0= )
+ libsecret? ( app-crypt/libsecret )
+ jpeg? ( virtual/jpeg:0= )
+ networkmanager? ( >=net-misc/networkmanager-0.7 )
+ ssl? ( >=net-libs/gnutls-2.2.0:= )
+ telepathy? ( >=net-libs/telepathy-glib-0.18 )
+ zeroconf? ( >=net-dns/avahi-0.6:=[dbus] )
+ zlib? ( sys-libs/zlib:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ >=dev-util/intltool-0.50
+ virtual/pkgconfig
+ app-crypt/libsecret
+"
+# libsecret is always required at build time per bug 322763
+
+src_configure() {
+ gnome2_src_configure \
+ --with-gcrypt \
+ $(use_with crypt gcrypt) \
+ $(use_enable ipv6) \
+ $(use_with jpeg) \
+ $(use_with libsecret secret) \
+ $(use_with networkmanager network-manager) \
+ $(use_with ssl gnutls) \
+ $(use_with telepathy) \
+ $(use_with zeroconf avahi) \
+ $(use_with zlib)
+}
diff --git a/net-misc/vino/vino-3.16.0.ebuild b/net-misc/vino/vino-3.16.0.ebuild
new file mode 100644
index 000000000000..037b150630ab
--- /dev/null
+++ b/net-misc/vino/vino-3.16.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+
+inherit gnome2
+
+DESCRIPTION="An integrated VNC server for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Projects/Vino"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="crypt libsecret ipv6 jpeg ssl +telepathy zeroconf +zlib"
+# bug #394611; tight encoding requires zlib encoding
+REQUIRED_USE="jpeg? ( zlib )"
+
+# cairo used in vino-fb
+# libSM and libICE used in eggsmclient-xsmp
+RDEPEND="
+ >=dev-libs/glib-2.26:2
+ >=dev-libs/libgcrypt-1.1.90:0=
+ >=x11-libs/gtk+-3:3
+
+ dev-libs/dbus-glib
+ x11-libs/cairo:=
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXtst
+ x11-libs/pango[X]
+
+ >=x11-libs/libnotify-0.7.0:=
+
+ crypt? ( >=dev-libs/libgcrypt-1.1.90:0= )
+ jpeg? ( virtual/jpeg:0= )
+ libsecret? ( app-crypt/libsecret )
+ ssl? ( >=net-libs/gnutls-2.2.0:= )
+ telepathy? ( >=net-libs/telepathy-glib-0.18 )
+ zeroconf? ( >=net-dns/avahi-0.6:=[dbus] )
+ zlib? ( sys-libs/zlib:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ >=dev-util/intltool-0.50
+ virtual/pkgconfig
+ app-crypt/libsecret
+"
+# libsecret is always required at build time per bug 322763
+
+src_configure() {
+ gnome2_src_configure \
+ --with-gcrypt \
+ $(use_enable ipv6) \
+ $(use_with crypt gcrypt) \
+ $(use_with jpeg) \
+ $(use_with libsecret secret) \
+ $(use_with ssl gnutls) \
+ $(use_with telepathy) \
+ $(use_with zeroconf avahi) \
+ $(use_with zlib)
+}