summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2016-03-09 21:39:53 +0100
committerThomas Kahle <tomka@gentoo.org>2016-03-09 21:40:04 +0100
commit376b2786f5e19cc3f2fd503de77bc1b5f4038825 (patch)
treee1e7ebe27be724270c7f14e471a95710b5f8c247 /net-misc/wicd
parentvirtual/mysql: Revbump to fix dependencies (diff)
downloadgentoo-376b2786f5e19cc3f2fd503de77bc1b5f4038825.tar.gz
gentoo-376b2786f5e19cc3f2fd503de77bc1b5f4038825.tar.bz2
gentoo-376b2786f5e19cc3f2fd503de77bc1b5f4038825.zip
net-misc/wicd: Bump to 1.7.4
Package-Manager: portage-2.2.26
Diffstat (limited to 'net-misc/wicd')
-rw-r--r--net-misc/wicd/Manifest1
-rw-r--r--net-misc/wicd/wicd-1.7.4.ebuild144
2 files changed, 145 insertions, 0 deletions
diff --git a/net-misc/wicd/Manifest b/net-misc/wicd/Manifest
index e0d790ba2caf..842ddef4310f 100644
--- a/net-misc/wicd/Manifest
+++ b/net-misc/wicd/Manifest
@@ -1,3 +1,4 @@
DIST Icone-Wicd-Lucid.tar.gz 9015 SHA256 6e4e3483c6cff7398e6871dd3e4360e361e5c6e64007e8e1240fd1c259ac707e SHA512 0df0dbdf05b462264dca2dd9955454a82f688b0fbfa7c2ad70a424df57eb27b35561d37819fc88b5746cff8a54de5b7b43ec325d2f98a4a1a30e4d500e86d2f8 WHIRLPOOL 336f363092c9bac7523047b6052a856a699820147967820418c6ac1ca528c472d371c6c211c505c325b5eb001812042c01425b05e1dfdf2d4a528f96686c530a
DIST wicd-1.7.3.tar.gz 542341 SHA256 91e38857b1651d242ed7e3b3e3fd8b076b4d06a23eedb033310fae510ece8401 SHA512 3ff3f42cd228327641b584bf85ef785a7d490fa5a57d1aa695f9b4860dae086c240a60321832a0aeee2dfb23de70da1a9f6abce4f1b6ecab58455304407fd536 WHIRLPOOL 69a9042e77f78f6d0dabc73e0569023d5a6747b82e3c944aad51a74681765b1b439beef1a578fcba4f048dbba6cbeabe0aca54ea62076d7dacdcbc4100ef2025
+DIST wicd-1.7.4.tar.gz 547393 SHA256 67989614004773db349791c37675efb914d084bdb221356a05e4369c35e7eb62 SHA512 1e99a45daa858eba634e60e50c22aa2fab3fc4d643979a6741b6164bf500bd6db285d11c12ccd164ab6cf0792284e319e3c3447804088e74b4fc67bb6f431959 WHIRLPOOL 680c79380ea645a286889c737c7b478a933e4243ad20c5c0f8cf53d37747a1d98780e21a4aeb98bed6da37f93f61d5dd4a42b22466f2feceae08e87d853b80fd
DIST wicd-mac4lin-icons.tar.xz 53136 SHA256 4c48c769c71f962415e3bd3573557e9288351afb867347f9a6f652883ae31011 SHA512 98ed3f92ec361aa8651c64efdb5128b8f73068f1cf2423640dafc4b46889ae32c1d1f56f509ad609b2bf98f634f8ada4c501f2294e3a64affd1befd4400498a8 WHIRLPOOL 84c097432ebb6ca66c0fa48d4226c8da5f6342b6fdeeb9546c98952b8f6e52a1f87d0ba23c1b409f3008432e5c6346bf65949dad99070804b1dcc2c1055eb9ea
diff --git a/net-misc/wicd/wicd-1.7.4.ebuild b/net-misc/wicd/wicd-1.7.4.ebuild
new file mode 100644
index 000000000000..bc4f53bb0c45
--- /dev/null
+++ b/net-misc/wicd/wicd-1.7.4.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="ncurses?,xml"
+
+inherit eutils distutils-r1 linux-info readme.gentoo systemd
+
+DESCRIPTION="A lightweight wired and wireless network manager for Linux"
+HOMEPAGE="https://launchpad.net/wicd"
+SRC_URI="https://launchpad.net/wicd/1.7/${PV}/+download/${P}.tar.gz
+ mac4lin? ( https://dev.gentoo.org/~anarchy/dist/wicd-mac4lin-icons.tar.xz )
+ ambiance? ( http://freetimesblog.altervista.org/blog/wp-content/uploads/downloads/2010/05/Icone-Wicd-Lucid.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE="doc X ambiance +gtk ioctl libnotify mac4lin ncurses nls +pm-utils gnome-shell"
+
+DEPEND="nls? ( dev-python/Babel[${PYTHON_USEDEP}] )"
+RDEPEND="${PYTHON_DEPS}
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ X? (
+ gtk? ( dev-python/pygtk[${PYTHON_USEDEP}] )
+ || (
+ x11-misc/ktsuss
+ x11-libs/gksu
+ kde-apps/kdesu
+ )
+ )
+ || (
+ net-misc/dhcpcd
+ net-misc/dhcp
+ net-misc/pump
+ )
+ net-wireless/wireless-tools
+ net-wireless/wpa_supplicant
+ || (
+ sys-apps/net-tools
+ sys-apps/ethtool
+ )
+ !gtk? ( dev-python/pygobject:2[${PYTHON_USEDEP}] )
+ ioctl? ( dev-python/python-iwscan[${PYTHON_USEDEP}]
+ dev-python/python-wpactrl[${PYTHON_USEDEP}] )
+ libnotify? ( dev-python/notify-python[${PYTHON_USEDEP}] )
+ ncurses? (
+ dev-python/urwid[${PYTHON_USEDEP}]
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ )
+ pm-utils? ( sys-power/pm-utils )
+ gnome-shell? ( gnome-base/gnome-shell )
+ "
+
+src_prepare() {
+ CONFIG_CHECK="~CFG80211_WEXT"
+ local WARNING_CFG80211_WEXT="Wireless extensions have not been \
+ configured in your kernel. Wicd will not work unless CFG80211_WEXT is set."
+ check_extra_config
+
+ epatch "${FILESDIR}"/${PN}-init-sve-start.patch
+ # The Categories entry in the .desktop files is outdated
+ epatch "${FILESDIR}"/${PN}-1.7.2.4-fix-desktop-categories.patch
+ # Upstream bug https://bugs.launchpad.net/wicd/+bug/1412413
+ # Creates files -> give -p
+ epatch -p1 "${FILESDIR}"/${PN}-1.7.3-add-missing-gnome-shell-extension.patch
+ # If LANG is undefined, build can fail (bug 537202)
+ epatch "${FILESDIR}"/${PN}-1.7.3-undefined-LANG.patch
+ # Fix urwid compat again
+ epatch "${FILESDIR}"/${PN}-1.7.3-urwid-1.3.0.patch
+ # Another compatibility patch from launchpad bug 1075399
+ epatch "${FILESDIR}"/${PN}-1.7.3-bitrate-property.patch
+ # get rid of opts variable to fix bug 381885
+ sed -i "/opts/d" "in/init=gentoo=wicd.in" || die
+ # Need to ensure that generated scripts use Python 2 at run time.
+ sed -e "s:self.python = '/usr/bin/python':self.python = '/usr/bin/python2':" \
+ -i setup.py || die "sed failed"
+ # Fix misc helper scripts:
+ sed -e "s:/usr/bin/env python:/usr/bin/env python2:" \
+ -i wicd/suspend.py wicd/autoconnect.py wicd/monitor.py
+ if use nls; then
+ # Asturian is faulty with PyBabel
+ # (https://bugs.launchpad.net/wicd/+bug/928589)
+ rm po/ast.po
+ # zh_CN fails with newer PyBabel (Aug 2013)
+ rm po/zh_CN.po
+ else
+ # nuke translations
+ rm po/*.po
+ fi
+
+ DOC_CONTENTS="To start wicd at boot with openRC, add
+ /etc/init.d/wicd to a runlevel and: (1) Remove all net.*
+ initscripts (except for net.lo) from all runlevels (2) Add these
+ scripts to the RC_PLUG_SERVICES line in /etc/rc.conf (For
+ example, rc_hotplug=\"!net.eth* !net.wlan*\")"
+}
+
+src_configure() {
+ local myconf
+ use gtk || myconf="${myconf} --no-install-gtk"
+ use libnotify || myconf="${myconf} --no-use-notifications"
+ use ncurses || myconf="${myconf} --no-install-ncurses"
+ use pm-utils || myconf="${myconf} --no-install-pmutils"
+ use gnome-shell || myconf="${myconf} --no-install-gnome-shell-extensions"
+ python_setup
+ "${EPYTHON}" ./setup.py configure --no-install-docs \
+ --resume=/usr/share/wicd/scripts/ \
+ --suspend=/usr/share/wicd/scripts/ \
+ --verbose ${myconf}
+}
+
+src_install() {
+ distutils-r1_src_install
+ keepdir /var/lib/wicd/configurations
+ keepdir /etc/wicd/scripts/{postconnect,disconnect,preconnect}
+ keepdir /var/log/wicd
+ use nls || rm -rf "${D}"/usr/share/locale
+ systemd_dounit "${S}/other/wicd.service"
+
+ if use mac4lin; then
+ rm -rf "${D}"/usr/share/pixmaps/wicd || die "Failed to remove old icons"
+ mv "${WORKDIR}"/wicd "${D}"/usr/share/pixmaps/
+ fi
+ if use ambiance; then
+ # Overwrite tray icons with ambiance icon
+ rm "${WORKDIR}/Icone Wicd Lucid"/signal*
+ cp "${WORKDIR}/Icone Wicd Lucid"/*.png "${D}"/usr/share/pixmaps/wicd/
+ fi
+ readme.gentoo_src_install
+}
+
+pkg_postinst() {
+ # Maintainer's note: the consolekit use flag short circuits a dbus rule and
+ # allows the connection. Else, you need to be in the group.
+ if ! has_version sys-auth/consolekit; then
+ ewarn "Wicd-1.6 and newer requires your user to be in the 'users' group. If"
+ ewarn "you are not in that group, then modify /etc/dbus-1/system.d/wicd.conf"
+ fi
+
+ readme.gentoo_print_elog
+}