summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-09-01 14:57:59 +0200
committerJeroen Roovers <jer@gentoo.org>2018-09-01 14:57:59 +0200
commit223383631c8342f702939b50e2a8f83b754de40b (patch)
tree09a21cdb9c3493871351988b7313ba2d2d941eff /net-misc
parentdev-lua/luasocket: Patch to fix proxy variable issue, EAPI 7 (diff)
downloadgentoo-223383631c8342f702939b50e2a8f83b754de40b.tar.gz
gentoo-223383631c8342f702939b50e2a8f83b754de40b.tar.bz2
gentoo-223383631c8342f702939b50e2a8f83b754de40b.zip
net-misc/iperf: Add live ebuilds.
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/iperf/iperf-2.99999.99999.ebuild34
-rw-r--r--net-misc/iperf/iperf-3.99999.99999.ebuild33
-rw-r--r--net-misc/iperf/metadata.xml19
3 files changed, 78 insertions, 8 deletions
diff --git a/net-misc/iperf/iperf-2.99999.99999.ebuild b/net-misc/iperf/iperf-2.99999.99999.ebuild
new file mode 100644
index 000000000000..ee2ce2958181
--- /dev/null
+++ b/net-misc/iperf/iperf-2.99999.99999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit git-r3
+
+DESCRIPTION="Tool to measure IP bandwidth using UDP or TCP"
+HOMEPAGE="http://iperf2.sourceforge.net/"
+#SRC_URI="mirror://sourceforge/${PN}2/${P}.tar.gz"
+EGIT_REPO_URI="https://git.code.sf.net/p/iperf2/code"
+
+LICENSE="HPND"
+SLOT="2"
+KEYWORDS=""
+IUSE="ipv6 threads debug"
+
+DOCS="INSTALL README"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.12-ipv6.patch
+)
+
+src_configure() {
+ econf \
+ $(use_enable debug debuginfo) \
+ $(use_enable ipv6) \
+ $(use_enable threads)
+}
+
+src_install() {
+ default
+ dodoc doc/*
+ newinitd "${FILESDIR}"/${PN}.initd-r1 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}
diff --git a/net-misc/iperf/iperf-3.99999.99999.ebuild b/net-misc/iperf/iperf-3.99999.99999.ebuild
new file mode 100644
index 000000000000..605135d8e2e8
--- /dev/null
+++ b/net-misc/iperf/iperf-3.99999.99999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils git-r3
+
+DESCRIPTION="A TCP, UDP, and SCTP network bandwidth measurement tool"
+HOMEPAGE="https://github.com/esnet/iperf/"
+EGIT_REPO_URI="${HOMEPAGE}"
+
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS=""
+IUSE="profiling sctp static-libs"
+
+DEPEND="sctp? ( net-misc/lksctp-tools )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P/_/}
+
+src_configure() {
+ use sctp || export ac_cv_header_netinet_sctp_h=no
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable profiling)
+}
+
+src_install() {
+ default
+ newconfd "${FILESDIR}"/iperf.confd iperf3
+ newinitd "${FILESDIR}"/iperf3.initd iperf3
+ prune_libtool_files
+}
diff --git a/net-misc/iperf/metadata.xml b/net-misc/iperf/metadata.xml
index c2391d465b93..f3c92356707b 100644
--- a/net-misc/iperf/metadata.xml
+++ b/net-misc/iperf/metadata.xml
@@ -1,12 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>netmon@gentoo.org</email>
- <name>Gentoo network monitoring and analysis project</name>
- </maintainer>
- <upstream>
- <remote-id type="github">esnet/iperf</remote-id>
- <remote-id type="sourceforge">iperf</remote-id>
- </upstream>
+<maintainer type="project">
+<email>netmon@gentoo.org</email>
+<name>Gentoo network monitoring and analysis project</name>
+</maintainer>
+<upstream>
+<remote-id type="github">esnet/iperf</remote-id>
+<remote-id type="sourceforge">iperf</remote-id>
+</upstream>
+<use>
+<flag name='profiling'>Create a profiled iperf3 binary</flag>
+</use>
</pkgmetadata>