summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-07-18 19:43:32 +0200
committerJeroen Roovers <jer@gentoo.org>2017-07-18 19:44:49 +0200
commit54b9ff1b54a44df3a492f7136a66e691facb3a42 (patch)
tree08ebfd51d8d3344d89d196bff87349a67eaf9bc1 /net-misc
parentdev-ml/ocaml-cstruct: Add missing test deps, bug #625532 (diff)
downloadgentoo-54b9ff1b54a44df3a492f7136a66e691facb3a42.tar.gz
gentoo-54b9ff1b54a44df3a492f7136a66e691facb3a42.tar.bz2
gentoo-54b9ff1b54a44df3a492f7136a66e691facb3a42.zip
net-misc/youtube-dl: Version bump.
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2017.07.15.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 1b66137fb7d3..9f8f2ff81ba2 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2017.03.16.tar.gz 2631620 SHA256 55df3cbda9cf86e49baf54040340ec74c692bb3d6da3d2f5a1bc1238017dd492 SHA512 f3b8942f6b2be3b1cfd4bddfb74c17bad48c8ef4bea34114970ecb9d65b5a3dcbe71beba6d7c2dbda168371bbb2e8bbaddce58039bd9d158bf23950a2a88123c WHIRLPOOL 8345da00074e62ec9a9c244cb9ef64930fbd0e5e9e5bc1709bfcf56517cc6312031a09523c3016db2a1542c16a0297bea9d6883a201ae94e347e358307e92422
DIST youtube-dl-2017.06.25.tar.gz 2737382 SHA256 0531958d4dc10f0fae7960a4c8d08d17fe57acf79719a76387d765c382809f59 SHA512 49a298ab041b264ca4a48b479851bcff96b2a535da8ed280d69fc1799702a43eb38289f00253271d9b320a538a8a374dcc27a0f3148d44db22fa57f8b41afce4 WHIRLPOOL e7bf63b54e35a2061d36c358f000dadb22769e20a1309dd4c43215c0fe1bb4096b198da2245c9ba4c967837d065525229861ca345a6392b83829f2ce58726f82
DIST youtube-dl-2017.07.02.tar.gz 2740061 SHA256 5b8b11c932ddbc346e2188f0e3a4c0ab8203b1b749f8ea9b212e10d34fa20168 SHA512 08cf4693450ad9ecdad653d4e5508c0899a54e3e16f49f5957ee1ff1486f55333860c3b8ea0d45a1ec12bf5cdc4ce3f57abf9f6c1eb73eca1dd41a38e86bbe68 WHIRLPOOL f28898208dfe3230284f7e6803cb4002a0bd7f493bbc5826ae0ad76ee4453cb5c7413cfc9609fa7bb1131754a07415318e1c380e04a07bba4ff9c88ba1517915
+DIST youtube-dl-2017.07.15.tar.gz 2752839 SHA256 665905606b61cad2f4ac945823722c3bf951f3003f5a24506aea690f4189b5ca SHA512 372ac27be349fb10ce21249d7d455cec291c1691b78a67f20ae425cb5c146226ee278e97fc5903a5fd6df6dca8e0cd09da8377f606b93633161bc02ba239f573 WHIRLPOOL dc8db12f3d69ebe6bc1a8ed3fe3f7c53c2ab987ad56d683726c22eb03fe3f8829bc73a4986ef978c88252071d386fa0132d2d467c14215d5d395413411994f11
diff --git a/net-misc/youtube-dl/youtube-dl-2017.07.15.ebuild b/net-misc/youtube-dl/youtube-dl-2017.07.15.ebuild
new file mode 100644
index 000000000000..867867e73614
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2017.07.15.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="+offensive test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+python_prepare_all() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate eporner
+ eroprofile extremetube fourtube foxgay goshgay hellporno
+ hentaistigma hornbunny keezmovies lovehomeporn mofosex motherless
+ myvidster porn91 porncom pornflip pornhd pornotube pornovoisines
+ pornoxo ruleporn sexu slutload spankbang spankwire sunporno thisav
+ tube8 vporn watchindianporn xbef xnxx xtube xvideos xxxymovies
+ youjizz youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ drtuber pornhub redtube tnaflix xhamster
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+}